Hacking Necessary Files for new games?

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
Hey everyone! I wanted to ask what required files I need to play newer games such as Wii Party & NBA Jam.
I'm running the last big version of cIOSCORP (Before the release of DarkCorp), and the last big thing I've done with the wii is update the shop channel to v. 20 and updated to IOS56 v5662. Since then, games such as the ones I listed above give me the message "An Error has Occured. Please eject the disk and press power".

I figured it requires a new IOS of sorts, but from the few NBA Jam threads I've browsed through, there doesn't seem to be any mention. I'm assuming it's for the onslaught of new games that have been coming out in the past month or so.

Does anyone know what I need to update? Whether it be to rid myself of cIOSCORP and move to DarkCorp, or if it may be as simple as a few IOS upgrades; any help would be greatly appreciated.
 

dcmanryan

New Member
Newbie
Joined
Feb 11, 2008
Messages
3
Trophies
0
XP
98
Country
United States
Prince Valmont said:
Riley, do I need to run the cIOSCORP removal tool before installing DarkCorp 1.1, or is it safe to write over?
No. I just went from cIOSCORP 3.6 TO DarkCorp 1.1. Just use the upgrade instead of virgin wii option it will give you.
 

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
Alright, funny story. Everything worked perfect on my wii, but now I'm updating all the homebrew stuff on my bud's wii.

I installed DarkCorp 1.1, the IOS58 for WiiMC & IOS56 for Shop Channel.

But when I put NBA Jam into the wii, it shows up on the disc channel alright, but once I hit the "start" button, it immediately takes me to a black screen where it says "An Error has occured..."

I'm absolutely baffled. Am I missing certain IOS's or what? It's irritating me because it works on my wii, and we're both on 4.1U, and same model of wiis.

Does anyone have any suggestions? I heard from somewhere that I need to run ModMii, but another thread said as he tried to use it, it asked him to update his IOS to a newer version, which another user replied with "Don't update that, it will brick your wii"

So I'm at a loss of what to do. Please. I need sleep.
 

koji2009

Well-Known Member
Member
Joined
Mar 13, 2009
Messages
1,193
Trophies
0
XP
197
Country
United States
I don't think updating any IOS with an official version will cause your wii to brick ever... The only time you should ever have to worry about a true brick from installing IOS is if you uninstall them first for whatever reason.

Don't uninstall any IOS (c or otherwise), it's always better (safer) to just overwrite. Also, don't install an updated system menu without it's proper IOS
wink.gif



As for your friend's problem... He has the right cIOS installed for the system menu, but he must not have the right cIOS installed for NBA Jam. Double check that all of darkcorp installed correctly.
 

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
I installed DarkCorp twice. When I first install it, I would put in NBA Jam, and immediately the screen would turn black while trying to read the disc and say "And Error Has Occurred".

I then install IOS56 and I'll get a disc channel icon of NBA Jam, but as soon as I hit START, I'll get that same message again.

But that exact same disc works on my wii.
 

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
Are there any big important IOS/cIOS files I need? Like rev17b-wise?
Anything current?

I know the shop channel needed one, and I got that.
But what about recent games? Anything that might be missed? Can anyone remember?
 

Dteyn

Well-Known Member
Member
Joined
Aug 3, 2008
Messages
335
Trophies
0
XP
90
Country
Canada
First, if you haven't already, install IOS236. Some of the newer cIOS revs don't have the ability to install WADs, so by installing a patched IOS36 into slot 236, you will be able to install WADs regardless of which cIOS revs are installed. Make sure you're using a WAD manager that lets you choose which IOS to use for installing WADs, I usually use Multi-Mod Manager.

In the Modify Any Wii thread you can find an e-mail address, e-mail them for links to the current files. One of the files is cios.zip, download that and extract it. Copy the WAD files to the WAD folder on your SD card. If you want you can put them in a separate folder, ie sd:\wad\cIOS\

Using the WAD Manager of your choice, select IOS236 and install the following WADs:

cIOS249[57]-v20.wad - (rev20 of Waninkokos cIOS) = Recommend by Waninkoko. Improves speed for USB loading. However, some Games might not work, and Wads cannot be installed.
cIOS250[38]-v20.wad - (rev20 of Waninkokos cIOS) = Stable IOS with the ability to install Wads

cIOS202[60]-v5.wad - (v5 of Hermes cIOS) = USB2.0 for MPlayer, WiiXplorer and stuff
cIOS222[38]-v5.wad - (v5 of Hermes cIOS) = Stable IOS with the ability to install Wads
cIOS223[37]-v5.wad - (v5 of Hermes cIOS) = For use with Music Games with USB devices like Rock Band, Guitar Hero...
cIOS224[57]-v5.wad - (v5 of Hermes cIOS) = Better speed for USB loading. However, some Games might not work

Once those are installed you will have the latest cIOS files on your Wii which are responsible for backup loading. There is a newer version of Hermes cIOS (v5.1) that hasn't been added to cios.zip yet, if you want to install that the installer is here: Hermes cIOS v5.1 Installer
(offline install instructions for Hermes cIOS installer)

I hope that works for you. I normally use USB Loader which the above cIOS versions are ideal for. These versions may or may not be ideal for disc loading. That's why I recommended installing IOS236, so you can experiment with different versions and see which works best for you.

Good luck!
smile.gif
 

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
I've installed DarkCorp 1.1, IOS236, Waninkoko's cIOSX rev 20 (using IOS236), and no matter what, every time I insert NBA Jam, I get an error when I click "START".

There has to be something I'm missing. It works on my wii, but not my friends. I'm going crazy trying to think of possible causes/solutions.

Can anyone please help?
 

smash_brew

I may or may not have fallen
Member
Joined
Oct 8, 2008
Messages
708
Trophies
0
Website
Visit site
XP
118
Country
United States
Prince Valmont said:
I've installed DarkCorp 1.1, IOS236, Waninkoko's cIOSX rev 20 (using IOS236), and no matter what, every time I insert NBA Jam, I get an error when I click "START".

There has to be something I'm missing. It works on my wii, but not my friends. I'm going crazy trying to think of possible causes/solutions.

Can anyone please help?
use neogama and set it to load using latest hermes cios 222. that should load nba jam from disc without a problem. although it's nice to load from disc channel there seem to be less issues with neogama for disc loading. I like to be able to choose what cios i use when loading back ups.
 

brausm08

Well-Known Member
Member
Joined
Nov 15, 2009
Messages
721
Trophies
0
Age
44
Location
USA - Midwest
XP
233
Country
United States
as far as missing IOSes...you could post a syschk...then we may be able to tell...

have you tried NeoGamma?...

AFAIK, when launching games through Disc Channel, all the cIOS in the world don't matter; the games launch on the system IOSes they were designed to run under (which makes CIOSCORP/DARKCORP a necessity)....unless....you have priiloader; i think there's a hack or a setting in priiloader which forces all games to launch under cIOS249...i'd say try this....hopefully it helps....
 

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
I found a setting in my priiloader that allows me to choose an IOS to run my sys menu under. I guess this is what you meant? I selected 249, and tried inserting NBA Jam again. Error.

What I don't understand is that my wii has DarkCorp 1.1 installed, and it runs this exact same disc perfectly. My friend's wii also has DarkCorp 1.1 installed (from the same source).

I don't like the idea of NeoGamma just because I prefer loading my games via disc channel. That and the fact I'm able to do this on my wii.

What I don't understand is that all my other backups work perfectly; no hitch; no errors. Just...NBA Jam.
And it's boggling me because I can't determine what I've done to mine that happens to be missing from his.

You mentioned a syschk. How may I present one to you?
 

Yuan

Well-Known Member
Member
Joined
Oct 1, 2007
Messages
1,291
Trophies
0
XP
371
Country
Brazil
Prince Valmont said:
I found a setting in my priiloader that allows me to choose an IOS to run my sys menu under. I guess this is what you meant? I selected 249, and tried inserting NBA Jam again. Error.

What I don't understand is that my wii has DarkCorp 1.1 installed, and it runs this exact same disc perfectly. My friend's wii also has DarkCorp 1.1 installed (from the same source).

I don't like the idea of NeoGamma just because I prefer loading my games via disc channel. That and the fact I'm able to do this on my wii.

What I don't understand is that all my other backups work perfectly; no hitch; no errors. Just...NBA Jam.
And it's boggling me because I can't determine what I've done to mine that happens to be missing from his.

You mentioned a syschk. How may I present one to you?

http://www.mediafire.com/?9dnlffypfqdndnf

Run this homebrew, chosse All.

When it finishes, it will create a syscheck.csv on root of your SD card. Open it with notepad/excel and paste the content here.
 

ChrisRX

Well-Known Member
Member
Joined
Nov 8, 2006
Messages
490
Trophies
0
Website
Visit site
XP
420
Country
koji2009 said:
I don't think updating any IOS with an official version will cause your wii to brick ever
Actually it's quite easy to brick your wii using official IOS if you accidentally install a stub. Take this as a cautionary tale from a few weeks ago when I accidentally bricked my wii.
I'm still on system menu 4.0 and so to play the latest games I thought I'd update all my IOS to the latest versions, accidentally overwriting the IOS that the system menu used with a stub and so the wii refused to boot and just sat at a black screen.
Luckily I had bootmii installed (which everyone should) so I could boot into the homebrew channel and reinstall the proper non-stubbed IOS.
 

Prince Valmont

Well-Known Member
OP
Member
Joined
Oct 7, 2007
Messages
228
Trophies
0
Location
Midwest
XP
372
Country
United States
sysCheck v2.0.1 by Double_A
...runs on IOS58 (rev 6176).

Region: NTSC-U
System Menu 4.1U (v449)
Hollywood v0x11
Console ID: 72462566
Boot2 v4

Found 126 titles.
Found 46 IOS on this console. 4 of them are stub.

IOS4 (rev 65280): Stub
IOS9 (rev 65535): Trucha Bug
IOS10 (rev 768): Stub
IOS11 (rev 65535): Trucha Bug
IOS12 (rev 11): No Patches
IOS13 (rev 15): No Patches
IOS14 (rev 262): No Patches
IOS15 (rev 265): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 65535): Trucha Bug
IOS20 (rev 65535): Trucha Bug
IOS21 (rev 65535): Trucha Bug
IOS22 (rev 777): No Patches
IOS28 (rev 65535): Trucha Bug
IOS30 (rev 65535): Trucha Bug
IOS31 (rev 3088): No Patches
IOS33 (rev 65535): Trucha Bug
IOS34 (rev 3348): No Patches
IOS35 (rev 65535): Trucha Bug, ES Identify, NAND Access
IOS36 (rev 65535): Trucha Bug, ES Identify, NAND Access
IOS37 (rev 65535): Trucha Bug, NAND Access
IOS38 (rev 65535): Trucha Bug
IOS40 (rev 65535): Trucha Bug
IOS41 (rev 65535): Trucha Bug
IOS43 (rev 65535): Trucha Bug
IOS45 (rev 65535): Trucha Bug
IOS46 (rev 65535): Trucha Bug
IOS48 (rev 65535): Trucha Bug
IOS50 (rev 65535): Trucha Bug
IOS51 (rev 4864): Stub
IOS52 (rev 65535): Trucha Bug
IOS53 (rev 65535): Trucha Bug
IOS55 (rev 65535): Trucha Bug
IOS56 (rev 5662): No Patches
IOS57 (rev 65535): Trucha Bug
IOS58 (rev 6176): No Patches
IOS60 (rev 65535): Trucha Bug
IOS61 (rev 5405): No Patches
IOS70 (rev 65535): Trucha Bug
IOS80 (rev 65535): Trucha Bug
IOS202 (rev 65535): Trucha Bug, ES Identify, NAND Access, USB 2.0
IOS222 (rev 65535): Trucha Bug, ES Identify, NAND Access, USB 2.0
IOS236 (rev 65535): Trucha Bug, ES Identify, NAND Access
IOS249 (rev 20): Trucha Bug, NAND Access, USB 2.0
IOS250 (rev 65535): Trucha Bug, NAND Access, USB 2.0
IOS254 (rev 65281): BootMii
BC v5
MIOS v65535

Report generated on 2010/10/27.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    WARIOLOVER57 @ WARIOLOVER57: hi