moonshell 2.00 beta 4 and related news

Discussion in 'GBAtemp & Scene News' started by FAST6191, Jan 12, 2009.

Jan 12, 2009
  1. FAST6191
    OP

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,697
    Country:
    United Kingdom
    moonshell 2.00 beta 4 and related news
    A few updates.
    Moonlight has posted several pieces of news on the subject of moonshell, most notably beta4 of moonshell 2.00. For those just joining us moonshell is a popular multimedia player (video in DPG format, audio in many formats, pictures and text) for the DS.
    The author again thanks the translation teams and skinmakers and reminds you all that the format may well change before the final version, the author is however attempting to finalise the specification and hopes to do so before week's end.

    [​IMG]

    moonshell 2.00 beta4 and 3.1 changelog

    And finally in related news moonshell "plugins"/extend link have now expanded to include a port of nesterDS (a nes emulator). As of beta 4 it is bundled, you may read about it in the links below though.

    [​IMG]Moonshell 2.00 beta4 release post (Japanese)
    [​IMG]Moonshell 2.00 beta 3.1 release post (Japanese)
    [​IMG]GBAtemp English translation thread

    [​IMG]Authors beta4 download (Zip format @ 23.2 megabytes)
    [​IMG]Authors download (source code, zip format @11.0 megabytes)
    [​IMG]GBAtemp download with source code (7z format @ 20.2 megabytes)

    NesterDS related (note it is included in beta 4).
    [​IMG]NesterDS 0.3 release post (Japanese)
    [​IMG]Discussion of nesterDS and DLDI (Japanese)

    Thanks to ccosmos for the news.
     


  2. FAST6191
    OP

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,697
    Country:
    United Kingdom
    As promised Changelog for betas thus far:
    Warning: Spoilers inside!
     
  3. ganons

    Member ganons GBAtemp Advanced Maniac

    Joined:
    Jun 12, 2005
    Messages:
    1,944
    Country:
    United Kingdom
    it tried dldi patch and unpatched on my AK2.1 but it gives errors
     
  4. enarky

    Member enarky GBAtemp Advanced Fan

    Joined:
    Jul 31, 2003
    Messages:
    997
    Country:
    Awseome. Can only recommend using these Betas for watching DPG Movies, quality has highly improved from 1.71.

    NesterDS is nice to have, but still has a long way to go before it can replace NesDS. Currently a lot of frames seem to get skipped, which makes emulation a bit choppy.

    EDIT:
    ganons, you don't need to DLDI patch with AK 2.1, that's only for carts that don't auto-DLDI patch. Works fine here with AKAIO. That error message you see is nothing to worry about.
     
  5. ganons

    Member ganons GBAtemp Advanced Maniac

    Joined:
    Jun 12, 2005
    Messages:
    1,944
    Country:
    United Kingdom
    An error was detected while trying to access the following disc or file. Please confirm the following

    Was the ROM file of a correct DLDI patch started?
    Please re-format the media and try again
    Please try with different media from another manufacturer
     
  6. hepheisto

    Newcomer hepheisto Member

    Joined:
    Aug 23, 2008
    Messages:
    30
    Country:
    Germany
    I get that error every time I start sakura, but boots through and works nevertheless [​IMG]
     
  7. Link5084

    Member Link5084 Sword & Shield at your service

    Joined:
    Aug 6, 2008
    Messages:
    1,367
    Country:
    United States
    How do you install this on CycloDS?
     
  8. wolfmanz51

    Member wolfmanz51 MrNintendosense

    Joined:
    Nov 24, 2008
    Messages:
    427
    Location:
    Somewhere in cali
    Country:
    United States
    Hey I translated the new beta for ya guys click here
     
  9. adriande2

    Member adriande2 GBAtemp Regular

    Joined:
    Aug 9, 2008
    Messages:
    199
    Country:
    United States
    no, you guys, you would get that message in to old moonshell even if it did work fine
    the real error is saying something like to clear system cache
     
  10. stephenophof

    Member stephenophof GBAtemp Regular

    Joined:
    Oct 13, 2007
    Messages:
    121
    Country:
    Netherlands
    I wonder when Moonlight releases the final version of MoonShell 2.0 [​IMG]
    It's nice homebrew
     
  11. Mbmax

    Member Mbmax Homebrew addicted

    Joined:
    Nov 7, 2006
    Messages:
    2,272
    Country:
    Antarctica
  12. r3lay

    Newcomer r3lay Advanced Member

    Joined:
    Nov 24, 2008
    Messages:
    89
    Location:
    Uk
    Country:
    United States
    acekard 2.1

    app doesn't start,i get this in logbuf.txt:
    Code:
    Start log file. topsector=104320 size=8192byte
    AppName MoonShell Ver 2.00 beta.4
    Jan 12 2009 18:35:58 GMT+09:00
    ARM RVCT3.1 [Build 569]
    __current pc=0x020346d4 sp=0x02803ea0
    active_interface = 0x0205afe0
    DeviceID=AK2S
    DeviceName=Acekard AK2 SD
    FileExistsUnicode: Not find Unicode file item. [SWAPDISP.TXT]
    FileExistsUnicode: Not find Unicode file item. [BBTNSTOP.TXT]
    FileExistsUnicode: Not find Unicode file item. [CARSUPLY.TXT]
    FileExistsUnicode: Not find Unicode file item. [CLUST64K.TXT]
    FileExistsUnicode: Not find Unicode file item. [CHKDSKT1.TXT]
    FileExistsUnicode: Not find Unicode file item. [IGNORE16.TXT]
    FileExistsUnicode: Not find Unicode file item. [USEM4A.TXT]
    FileExistsUnicode: Not find Unicode file item. [POFFMEND.TXT]
    
    Fatal error: The cluster size that exceeds 32kbyte is not supported.
    
    ÂÂÂÂ Application halted!!
    Please refer [/moonshl2/logbuf.txt]!
     
  13. ganons

    Member ganons GBAtemp Advanced Maniac

    Joined:
    Jun 12, 2005
    Messages:
    1,944
    Country:
    United Kingdom
    I get the same error
     
  14. enarky

    Member enarky GBAtemp Advanced Fan

    Joined:
    Jul 31, 2003
    Messages:
    997
    Country:
    Do you have both, the .nds and the moonshl2 folder on you cards?
     
  15. michelkok1

    Newcomer michelkok1 Advanced Member

    Joined:
    Oct 18, 2008
    Messages:
    84
    Location:
    Kampen
    Country:
    Netherlands
    this sucks, it doesnt work on my dstt and if it works i need to have all of the ds roms in the maps
     
  16. ganons

    Member ganons GBAtemp Advanced Maniac

    Joined:
    Jun 12, 2005
    Messages:
    1,944
    Country:
    United Kingdom
    yes I do
     
  17. r3lay

    Newcomer r3lay Advanced Member

    Joined:
    Nov 24, 2008
    Messages:
    89
    Location:
    Uk
    Country:
    United States
    to get this working on acekard 2.1,i copied all the text files in the misctools/Additional into the moonshl2 folder,working great now
     
  18. Mbmax

    Member Mbmax Homebrew addicted

    Joined:
    Nov 7, 2006
    Messages:
    2,272
    Country:
    Antarctica
    As said, you have to format your microSD with smaller clusters . 32kbyte max.
     
  19. Link5084

    Member Link5084 Sword & Shield at your service

    Joined:
    Aug 6, 2008
    Messages:
    1,367
    Country:
    United States
    Wait, so you have to have the folder in the root to make it work?
     
  20. Mbmax

    Member Mbmax Homebrew addicted

    Joined:
    Nov 7, 2006
    Messages:
    2,272
    Country:
    Antarctica

Share This Page