Modded Wii not reading game discs

Discussion in 'Wii - Hacking' started by corbindavenport, Jul 6, 2013.

  1. corbindavenport
    OP

    corbindavenport Member

    Newcomer
    12
    2
    May 18, 2013
    United States
    First post on the Wii forum :)

    So a few days ago game discs suddenly stopped working. It would spin for a minute, then pop it back out. I tried putting it in the other way, no luck. I thought the drive must be busted, but it still reads movie DVDs fine in WiiMBC. Does anyone know a way to fix this problem?

    If it helps, I used the HackMii installer with the Indiana Pwns exploit. Any help would be very much appreciated. Feel free to ask me any questions about my setup if it helps to find the answer.
     
  2. _acid_

    _acid_ GBAtemp Regular

    Member
    197
    9
    Jul 18, 2010
    Canada
    Canada
    i've never heard of a problem like this before......
    but in terms of what we need to know about you setup;
    How did u hack your wii? what steps did you take? Did you use modmii?

    For more thoroughness please post a syscheck. hopefully this is not a hardware problem.

    How are you starting your games? From an app or the disc channel?
    on a side note, maybe try gecko os, it has a disc laucher, maybe that app wont spit out your disc.
     
  3. Leo Alves

    Leo Alves GBAtemp Regular

    Member
    117
    17
    Dec 16, 2012
    Brazil
    I don't know if i can help, but i will try:

    Have you tried to run the game through a Disc Launch like Riivolution or Gecko OS ?
    Or Through Wii Maintenance Mode ??
    (Press (+) Plus and Minus (-) at the same time on the ''Health and Safety Screen'' to enter in Maintenance Mode)

    try and see if it works
     
  4. corbindavenport
    OP

    corbindavenport Member

    Newcomer
    12
    2
    May 18, 2013
    United States
    I used Team Twiizer's Indiana Pwns method, and used the HackMii installer to install BootMii and the Homebrew channel.

    I'll look how to do a syscheck and post it here. I'm starting the games with the Disc Channel. Thanks for pointing out Gecko OS, I'll give it a shot.
     
    _acid_ likes this.
  5. corbindavenport
    OP

    corbindavenport Member

    Newcomer
    12
    2
    May 18, 2013
    United States
    I'm going to download Gecko OS and give it a try, and I'll try the Maintenance Mode when I turn on my Wii in a few minutes.
     
  6. tbgtbg

    tbgtbg Shaking the ring ropes up in the sky

    Member
    1,951
    448
    Nov 27, 2006
    United States
    Putting it in what other way? Upside down?

    Also, it would help to know if you are trying to run originals or backups. And if your working movie discs are originals or burned.

    Anyway, I would suggest trying to clean your lens and see if that helps.
     
  7. corbindavenport
    OP

    corbindavenport Member

    Newcomer
    12
    2
    May 18, 2013
    United States
    Yes, I thought I put it upside down and right-side up but they both have the same affect. My games are store-bought original discs (I tried Wii Sports and LEGO Star Wars), and the DVDs I tested were also originals (I tried A Space Odyssey). Gecko OS said "No DVD in drive" when I tried loading a commercial disc, and the Wii System Menu went to a black screen asking me to remove the disc and force reboot the disc.

    I updated to the latest System Menu, disabled all System Menu hacks, and tried to load my disc again. On first try it shows the little question mark, and on the second try it shows the black screen again.
     
  8. corbindavenport
    OP

    corbindavenport Member

    Newcomer
    12
    2
    May 18, 2013
    United States
    Now it's not reading discs of any kind. I suppose now it's a hardware problem and not a GeckOS/System Menu problem :(
     
  9. _acid_

    _acid_ GBAtemp Regular

    Member
    197
    9
    Jul 18, 2010
    Canada
    Canada
    was your wii noisy when it was able to play discs?

    i had a wii which had a dead disc drive, it was griding teeth when it died
    i think it might because the laser is dead....but, whatever it is, no playing from a disc i guess :(
     
  10. natkoden

    natkoden Not a New Member

    Member
    783
    185
    Jul 25, 2006
    Argentina
    yeah, it happened to me too, it was making a grinding noise and would spit out the discs after a few seconds, or not at all

    sometimes it wouldnt even take the damn discs

    I just had to open it up and fix the position of the metal "lid" covering the laser.
     
    _acid_ likes this.