Metroid Prime Trilogy - Update? (for playing from disc!)

Discussion in 'Wii - Hacking' started by Kaaji1359, Aug 28, 2009.

  1. Kaaji1359
    OP

    Newcomer Kaaji1359 Member

    Joined:
    Jul 4, 2009
    Messages:
    21
    Country:
    United States
    Hello. Due to Metroid Prime Trilogy not playing well on the USB Loader, I've decided to just play via the main retail disc. Unfortunately it asks for a system update (from what I've read, it's 4.1). Now I've searched and searched and I keep on getting conflicting results: "You can update, all it does is update your weather/news channels" and "NO DON'T UPDATE, YOUR WII WILL BE UNHACKED AFTERWARDS".

    So can someone please give me a definitive answer: If I have a 4.0 hacked Wii using USB Loader GX with cIOS36 Rev10 and I want to play Metroid Prime Trilogy VIA THE RETAIL DISC, is it OK to do the system update that the disc gives me?

    Thanks guys
     
  2. Serris

    Newcomer Serris Member

    Joined:
    Aug 26, 2009
    Messages:
    10
    Country:
    United States
    Yes. I was in the same boat as you and updated without issue.
     
  3. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    yea just re-mod with my guide or use preloader to disable disc update checks.
     
  4. Gullwing

    Member Gullwing Synesthete

    Joined:
    Dec 5, 2007
    Messages:
    964
    Location:
    Behind You
    Country:
    Greece
    Just use Gecko OS or Neogamma to bypass the update... I think that using Preloader is going to trouble you much... You can always update via Wanikoko's 4.1 Updater... Which actually updates you Wii but with an unharmful way (which is pretty complicated)... You are a noob in the Wii modding scene, right???
     
  5. ChrisRX

    Member ChrisRX GBAtemp Fan

    Joined:
    Nov 8, 2006
    Messages:
    490
    Country:
    United Kingdom
    Generally speaking, never update from game discs because you don't know what they do specifically. Just run startpatch to disable updating from the disc and as long as you have the proper IOS installed then it should run fine.
     
  6. Kaaji1359
    OP

    Newcomer Kaaji1359 Member

    Joined:
    Jul 4, 2009
    Messages:
    21
    Country:
    United States
    Again, getting conflicting answers [​IMG]

    I'm semi-noob Gullwing. I've heard of Wanikoko's 4.1 update, but I've also heard that it will still want to update via the disc due to it not reading your cIOS (or something like that). Honestly I'd rather do the update though...

    What exactly is Neogamma? And assuming that I do run the update (and potentially have to re-hack my Wii), will rev 10 run MPT?
     
  7. illinialex24

    Member illinialex24 GBAtemp Advanced Fan

    Joined:
    May 26, 2009
    Messages:
    968
    Location:
    The Midwest
    Country:
    United States
    Startpatch can patch the 4.0 update easily and quickly. Best solution IMO, can load it from the disc channel easily and effectively and play it like a retail disc.
     

Share This Page