Mario Kart DS flashcart difference

Discussion in 'Acekard' started by radorn, Sep 19, 2010.

  1. radorn
    OP

    radorn Member

    Newcomer
    37
    0
    Mar 18, 2009
    Sorry if this has been answered before, but the forum search stupidly refuses to accept any word shorter than 4 characters. Tried to search for [+"Mario Kart DS" +"here we go"] but apparently I should search for [+"Mario Kart" +here] which is ridiculous. rant over.

    I have backed up my own Mario Kart DS card (European version bouth in Spain) with Rudolph's 3in1 expansion based backup utility.
    When I load the original cart, at the initial screen I hear the usual throthling sound followed by mario saying "yahoo!". When I load the dumped ROM through my ak 2.1 (with AKAIO, if that makes a difference), mario says "here we go!" instead.

    Does someone know why this happens?
    The game runs ok otherwise, but I'm really curious about this strange difference.
    It wouldn't mean squat to me if I were using a downloaded ROM since there could be different builds, etc, but since I dumped it myself...

    edit: http://www.youtube.com/watch?v=aHGJZbF4dl8
    edit2: forgot to say that I also dumped my cart's save and used it on the flashcard, and also initialized the cart's save with the backup util and used an empty save for the rom just to make sure it wasn't something that depended on the save file... I got no variance.
     
  2. SixtySixHundred

    SixtySixHundred GBAtemp Fan

    Member
    433
    2
    May 21, 2010
    Eternia!
    Couldn't resist testing this myself on a similar setup, Wood R4 with my own dumped version of MKDS and the very cart I dumped the ROM from.

    Mine, was the other way round tho. From the retail cart, I got Mario shouting "Here We Go!" But from the R4, I got Yoshii saying "Yahoo!" Or something!

    It could be just a different start up effect every time you boot the game, I'm gonna sit here starting MKDS up until I solve it [​IMG]

    EDIT: I've booted the ROM 10 times and the retail cart 10 times and every time it's Mario's "Here We Go!" For the cart and Yoshii's "Yahoo!" for the ROM!

    How the hell does it know? Really strange!
     
  3. radorn
    OP

    radorn Member

    Newcomer
    37
    0
    Mar 18, 2009
  4. 0ddity

    0ddity GBAtemp Fan

    Member
    440
    1
    Aug 7, 2010
    Canada
    Ontario
    The E release says Yahoo, the U release says here we go, so maybe the flash cart is confusing the game as to which region it is in.
     
  5. Taellon

    Taellon GBAtemp Regular

    Member
    136
    12
    Apr 30, 2009
    Canada
    Not sure about the E release, but I have an retail copy of the U release. It does the "Yahoo!" on a regular DS PHAT and the "Here we go!" on a DS Lite. Not sure what causes the differences with the ROM though. Maybe something to do with the different chips in the flashcarts.
     
  6. Orangejb5

    Orangejb5 Member

    Newcomer
    45
    0
    Feb 1, 2010
    Canada
    ^ i was about to say that.
    and yes, the region has different sayings at the beginning i believe.
     
  7. biggman15

    biggman15 Member

    Newcomer
    36
    0
    Sep 12, 2009
    United States
    I'm getting a different result... My retail Cart always says "Here we go!" My Dstt just goes "VVVrrroooommm!" And then My Acekard has 2 different results... It goes "Yahoo!" at first... then when my Ezflash 3-in-1 is inserted it goes "Here we go!"

    The ezflash doesn't affect the real cart or the DStt....
     
  8. Mario92

    Mario92 GBAtemp Advanced Fan

    Member
    878
    85
    Feb 20, 2010
    Finland
    Finland
    I thought about that also. Real card says "Here we go", DSTT theres just "Vroom vroom" and Acekard 2i "Yahoo". I have E version real game and E dump [​IMG]
     
  9. zruben

    zruben Advanced Member

    Newcomer
    97
    0
    Mar 21, 2007
    Mexico
    I don't remember exactly what my rom says... but I remember that it changed when I got bored of the game and started using cheats...
     
  10. HaniKazmi

    HaniKazmi GBAtemp Advanced Maniac

    Member
    1,657
    42
    Jan 30, 2008
    Manchester
    It actually has to do with ds internal ids. Back when it was just the ds phat, each colour had a different internal id, and therefore you got a different saying on each colour. I'm not sure how it works with the ds lite and dsi, but the flashcards cant read the id properly, therefore youll get a different saying per flashcard.
     
  11. thaddius

    thaddius Charmander is not pleased.

    Member
    1,330
    264
    May 5, 2008
    Canada
    I noticed that the game did different startups noises depending on which of my DS' I used. I own the actual game and my DS Phat would go "vroom vroom", by Lite "Yahoo" and my DSi goes "Here we go!".
     
  12. SgtThom

    SgtThom GBAtemp Regular

    Member
    129
    0
    Dec 22, 2009
    United States

    This explain everything.I can't believe Nintendo didn't release information about this.
     
  13. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,128
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Did you know the original DS models had a pressure-sensitive screen, and they took it out on the DSi models because nothing actually used it?