M3 perfect sd wont flash, boot, do anything.

Discussion in 'GBA - Flashing Hardware and Software' started by sprandel, Jul 18, 2009.

Jul 18, 2009
  1. sprandel
    OP

    Newcomer sprandel Newbie

    Joined:
    Nov 4, 2008
    Messages:
    2
    Country:
    United States
    Hey guys, I have an M3 perfect sd, slot 2, used solely for gba. The cart is about 6 months old, it stopped working about a week ago. I turn on my SP and I get a black screen with nothing on it. I decided to reformat my sd card to fat32 just to see if it would work. Nothin. I've tried 5 different sd cards, including sandisks, which I've heard are the solution to thos problem. I've tried an sd reader as well as a digital camera to transfer firmware files and write roms to the card.

    I've noticed that when I get the black screen that if I wiggle the m3 out of the slot slowly then it will come up and say: "Warning! Card has not been Formated. Please shut down and insert a formated Secure Digital card. Or press START to continue anyway." So I press start and it tells me: "Please use English version update file for this card. Update file language version error!" (I've used every firmware I could find for sd, 11-35, all .eXX files) but it doesn't seem to care.

    Any tips?
     
  2. antonkan

    Member antonkan GBAtemp Maniac

    Joined:
    Jun 13, 2009
    Messages:
    1,063
    Location:
    Burlington, ON
    Country:
    Canada
    No tips. I recommend to buy EZ-Flash 3-in-1 so that you play game on GBA. It's the flashcart!
     
  3. WigWrm

    Member WigWrm GBAtemp Regular

    Joined:
    Apr 17, 2007
    Messages:
    179
    Country:
    United States
    Sounds like a contact problem. Use isopropyl alcohol on a q-tip and swab the contacts on your m3 card till you remove most of the grit.

    And this is probably an erroneous question but are you using "english" firmware update files and not
    chinese ones?
     
  4. Maz7006

    Member Maz7006 iSEXu

    Joined:
    Aug 2, 2008
    Messages:
    3,622
    Country:
    Lebanon

    Errr..... lol?
     
  5. Pliskron

    Banned Pliskron Banned

    Joined:
    Jul 22, 2009
    Messages:
    1,276
    Country:
    United States
    I had to stick some paper in mine to make it work. I've had no problems since. This problem is not uncommon with the M3. Put the paper between the card and the top half of the shell. Try it and get back to me.
     
  6. notwork

    Newcomer notwork Newbie

    Joined:
    Feb 17, 2007
    Messages:
    1
    Country:
    United States
    Had the same problem...seems like the sram can get corrupt. I booted into a slot1 cart, ran slot2 in nds mode and it worked (cyclods). Did it again but in gba mode and again it worked. From that point on, i could boot directly into the m3 perfect either on a real gba or holding down b while booting with a cyclods. I think by booting into slot2 in nds mode, then overwriting sram, it cleared things up. All is good now.
     

Share This Page