Luma 8.1 Rosalina Input Redirection Cuts Out

Discussion in '3DS - Homebrew Development and Emulators' started by biggusdeekus, Jul 27, 2017.

  1. biggusdeekus
    OP

    biggusdeekus Newbie

    Newcomer
    1
    0
    Jul 27, 2017
    Australia
    Hi, I've got Input Redirection through Rosalina working and all that, using the Qt client, but every couple of minutes all input cuts out for about 5 - 10 seconds. This makes it pretty unusable, obviously. I've been using NTR input redirection for a long time with no problems (except not having the C-stick or extra shoulder buttons) so I'm certain it's not my wireless setup, I think the problem is in the 3DS itself. I can't find anyone talking about the Rosalina input redirection, much less my own problem with it, so I'm at a loss as to how to go about fixing it.

    I'm using a normal-size N3DS with B9S. I've tried connecting to the 3DS through a direct ad-hoc connection and via my router. Both work for approximately the same amount of time until the cut-outs happen. Occasionally after the input cuts out all further inputs will be on a massive 10 second or so delay and it becomes totally unusable. All of this is the same, whether I'm in a game or just flailing the sticks around at the home screen. I have no evidence of this, but it feels like the input redirection is losing processor priority every now and then for some reason.

    Any input would be helpful. Thank you!

    Edit: I think it's also worth mentioning that an enormous (10 sec +) input delay gets instantly introduced if I enable the debugger in Rosalina. I'm sure the two things aren't intended to work together so that's fine, but it lends more reason to why I believe it's something to do with allocation of resources in the 3DS. Of course for any of this to be true it would have to be untested beyond a few seconds by the developer and however many users there are, so I have no idea why only I would be experiencing it unless just no one has tried it for more than a minute yet which seems unlikely.
     
    Last edited by biggusdeekus, Jul 27, 2017
  2. lurkerer

    lurkerer Member

    Newcomer
    37
    6
    Jan 12, 2016
    Ditto on this issue, I am however unable to disqualify the network being an issue as I haven't completely optimised it or tested it under controlled circumstances.