Lost SD data, what to do from here?

Discussion in 'Wii - Hacking' started by Steena, Nov 23, 2013.

  1. Steena
    OP

    Steena GBAtemp Advanced Fan

    Member
    557
    271
    Sep 13, 2009
    Italy
    Hey guys, I'm having some issues with my Wii.

    I've tried to read around before posting, and everywhere I looked there was a general issue of not being able to explain what the problem was, so I'll start from the beginning.

    A couple years ago, some time after it was possible to read wii games off USB medias, I softomodded my wii. Everything ran perfectly, never had a single issue, freeze or incompatibility. I never updated it again for a long time, as every game I played was supported.

    Last year, I found out about dios mios, and I had to update the cios (I believe) in order for the new loaders to work properly/increase compatibility. I installed dios mios and have been playing gamecube games with not a single issue.

    Everything ran fine. Something worth noting, is that I put whatever file was required (that was not a game, those went to an external HD) on an SD. I read that the files required for installing the mod are not needed anymore, as in, it's not mandatory to have the SD in your wii, however, only with the SD inserted I could access the bootmii menu on startup (http://www.moddingstudio.com/images/bootmii.png), allowing me to go directly to the HBC and bypass the annoying usage of the wiimote when trying to select the homebrew channel in the wii menu.

    I also kept my loaders on the SD. Basically everything from install files to tools, was on the SD. Except the actual game files.

    Fast forward to yesterday, while switching around my microsd from computer to DS (for something completely unrelated to the Wii), turns out my SD card was corrupted. I had no choice but to format it, and when I would take it out and put it in again, it would again make me format. So I did a system check/fix, and that seemed to work, however, I of course lost all the data on the SD. I had a backup of it but unfortunately the HDD that stored it died some months ago and I forgot completely about the SD backup.

    Now, since I always played/used my tools on the Wii with that SD, I felt like I was screwed. I turn on the Wii, and, as I said, there is no bootmii system menu on startup, so I have to manually choose the HBC, which is completely empty because all my tools/apps were on the SD.

    I push start on the gamecube controller and I am able to find out some information about the HBC/system, I believe: on the top right corner it says:
    "1.0.6
    IOS61 v22.30"

    Now, if I choose the option "launch bootmii" from the HBC menu, I get a black screen and my wii driver gives out a constant on-off blue flash undefinitely.

    Seeing this, I downloaded the latest version of WiiFlow, one of the loaders I used, and put it on the wiped SD card. Upon running the app, I find out that all the text is gone; text bubbles are there, but the text itself is not. Apparently it is also asking me for something right away, and it wont show me my games list (that I have on my HDD, which is plugged in on the wii in the right slot). Probably a NAND backup? But I have no way to navigate through or tell, due to no text.

    So as a quick recap of all that I have right now is:
    -Wiiflow app
    -gamecube/wii games

    I got absolutely no other file that may be required to use the HBC properly. And I don't remember/know exactly what is needed; I followed a guide to the letter years ago and I don't remember absolutely anything about it, since everything worked perfectly without giving any single issue whatsoever, so I'm in the dark here. I don't know what my next step should be.

    What the Wii does:
    -it reads original gamecube games just fine through the "load from disc" option on wiiflow, which is the only thing I can click on because it's an icon and doesn't rely on text. Also, I see a dios mios splash screen even though it's an original game, but I suppose that happens because dios mios replaces some system files so it cannot read original games directly without it, right?
    -it reads original wii games just fine.
    -it launches the HBC when I select it manually, though I don't have the bootmii system menu on the Wii startup
    -if I select the "launch bootmii" option on the HBC, I get blackscreen.
    -WiiFlow shows no text.

    I figure all of this can only be due to a missing file in my SD, as that was the only thing that changed. I did not install anything new on my Wii for months, and I wasn't even using it before I found out my apps/system/boot/whatever wii files went lost with the SD format.

    So I ask if anyone of you experienced guys know what I should do from here. It has been a long time since I softmodded my wii and I did it only once, I don't really know what to do. Thanks in advance.
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    5,629
    2,114
    May 11, 2008
    United States
    If you want your Wii to launch with bootmii, you need to redownload some bootmii files and put them on the root of your SD card. Alternatively, you could set bootmii or Priiloader to automatically boot into the Homebrew Channel when you start your Wii. Alternatively, you could just add forwarder channels for your favorite apps on your Wii Menu. If you go into ModMii and go to Download Page 2, you should find the Bootmii SD Files as an option to download.

    With regard to your Wiiflow, I would redownload the latest version of Wiiflow. I don't personally use Wiiflow, so I can't be of much help here. Alternatively, you could use another loader like Configurable USB Loader MOD.

    I can't remember if that's everything or not. It's also worth noting that if I were you, I would install IOS58 and reinstall the latest version of the Homebrew Channel so that it uses IOS58 instead of IOS61. If you were to run a sysCheck and drag the file into ModMii, it would download all the recommended and up-to-date IOS and cIOS files for you to install through its easy-to-follow instructions. You could also post your sysCheck here so we could see if anything looked out of the ordinary, but like you said, your immediate problems are indeed linked to your loss of SD card data.
     
  3. Steena
    OP

    Steena GBAtemp Advanced Fan

    Member
    557
    271
    Sep 13, 2009
    Italy
    Thank you Lacius, gave me a lot of useful information. I will perform all the actions you suggested as soon as I get home.
     
  4. Steena
    OP

    Steena GBAtemp Advanced Fan

    Member
    557
    271
    Sep 13, 2009
    Italy
    I downloaded a more updated version of wiiflow, but the same no-text issue popped up. I guess that has something to do with some core files in the SD other than the wiiflow app, but that's very strange, I don't know.
    Anyway, I followed your advice and downloaded CFG USB loader MOD, and now I'm able to boot my backups without having 38 discs around, thanks a lot!

    I think I will manually update to IOS58 and new HBC, like you suggested, at a later time. I've spent 3 actual hours going through the hell that was modMii and its missing downloads. The thing needs like 10 minutes to check if the file is online, each. That was frustrating to say the least. Also, getting those files seems to be illegal now because the developers do not allow for it, so I guess I'll read around for a method of updating that doesn't require hackMii or BootMii at all.

    In any case, everything else is running well now. Thanks again for the help.