Lopst Snes9x error message

Discussion in 'Wii - Hacking' started by pdarkness, Apr 21, 2008.

  1. pdarkness
    OP

    pdarkness Member

    Newcomer
    14
    0
    Aug 8, 2007
    I just have a problem getting the Lopst Snes9x 1.43 emulator to work (the one in spanish), hope you can help me. I installed the TP hack, and installed the homebrew channel which work fine. On my SD card the emulator is under the name boot.elf and is in the root directory. The setup of the SD card is as follows:

    ROOT:
    snes9x/ (have tried 'roms' and 'snes9xroms')
    roms/
    All my roms are in this folder.

    I can start up the emulator fine (using the homebrew channel) and I can get into the options fine, however when I try to load the roms from the SD card, I get a black screen with lots of crazy numbers (800ce080 etc.).

    Are there any extra files I need on the SD card (.elf etc), or is there something wrong with the directory structure?. I also get the same error with the english Snes9x 1.43 (the one w/o classic cont and 2 player support.

    Hope you can help, thanks.
     
  2. SleepyPrince

    SleepyPrince GBAtemp Regular

    Member
    173
    0
    Aug 9, 2007
    Hong Kong
    roms should be ROOT:\snes9x\roms
    did you choose to get roms from the Wii SD?
    because another option is to read from SD Gecko
     
  3. pdarkness
    OP

    pdarkness Member

    Newcomer
    14
    0
    Aug 8, 2007
    Yes, I have tried the following dir structures: roms/, snes9xroms/roms/ and snes9x/roms/ and still nothing. The Lopst emulator only has the option of: read from SD, read from GC mem slot A and read from GC mem slot B.
     
  4. Sottle

    Sottle Newbie

    Newcomer
    7
    0
    Oct 15, 2007
    Same problem as the topic creator, tried exactly the same things. Help appreciated.
     
  5. duy64

    duy64 GBAtemp Regular

    Member
    106
    0
    Nov 4, 2006
    Canada
    try unziping ur roms
     
  6. Sottle

    Sottle Newbie

    Newcomer
    7
    0
    Oct 15, 2007
    All mine are unzipped .smc roms.
     
  7. Sottle

    Sottle Newbie

    Newcomer
    7
    0
    Oct 15, 2007
    Here's the error message.

    [​IMG]

    I've tried roms in /roms and in /snes9x/roms, both zipped and unzipped in both locations, i've also tried three different emus. The original wiimote support one, the one spanish one with classic support and an older GC pad only one with Front SD loading, all the same.
     
  8. pdarkness
    OP

    pdarkness Member

    Newcomer
    14
    0
    Aug 8, 2007
    Have exactly the same prob as sottle (thanks for the screen, is hard to describe!). However I just got it working (sort of). Instead of loading the emu from the homebrew channel, I loaded it directly from the TP hack and it worked. Pain in the ass, though, to keep having to load zelda everytime.

    Another problem has come up, dont know if its fixable or a bug with the emu. Whenever I try to do 2 player mode its screwey; after connecting the 2nd remote from the emu menu and starting up a 2 player game, one of the remotes don't work and the other controls both players at the same time. Pretty weird.

    Thanks for all your help.
     
  9. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    215
    Aug 18, 2005
    Gambia, The
    Zebes
    v2 of this emu was just released. Maybe you have more luck with it.
     
  10. pdarkness
    OP

    pdarkness Member

    Newcomer
    14
    0
    Aug 8, 2007
  11. Sottle

    Sottle Newbie

    Newcomer
    7
    0
    Oct 15, 2007
    Did that solve the problem? Because it's still the same for me, confirmed that running the Emu straight through the Twilight hack works as you said, even tried deleting and re-installing the Homebrew Channel to no avail.
     
  12. NL_Patrick_D

    NL_Patrick_D Advanced Member

    Newcomer
    85
    0
    Apr 15, 2008
    Netherlands
    in my root created :

    snes9x/roms
    snes9x/saves

    I use this using the homebrew channel (no limit version)
    it boots and works like a charm.

    So sweet to finally be able to play snes games using my classic controllers

    Still looking how to change the lang [​IMG]
     
  13. Brownstone

    Brownstone Member

    Newcomer
    18
    0
    Apr 21, 2008
    Was thinking of trying this but can you remove the Snes Channel, how?

    Thanks
     
  14. Prime

    Prime GBAtemp Psycho!

    Member
    3,664
    0
    Nov 7, 2007
    Under your bed
     
  15. Sottle

    Sottle Newbie

    Newcomer
    7
    0
    Oct 15, 2007