Legit zelda disc FORCES an update.

Discussion in 'Wii - Console and Game Discussions' started by anxion, Nov 18, 2011.

  1. anxion
    OP

    anxion Newbie

    Newcomer
    7
    0
    Oct 31, 2011
    Hey, I finally got the game and popped the disc in. When I launched it the following message prompted, "initiating wii system update." (I ejected the disc in time so no harm was caused.)

    I am using priiloader to skip updates and that doesn't seem to work in my situation here.

    Any suggestions? I'm using 3.1E and my wii is softmodded.
     


  2. LTK

    LTK GBAtemp Fan

    Member
    406
    50
    Jul 28, 2008
    West Midlands
    Hmm interesting there was none on the iso.
     
  3. Kilvearn

    Kilvearn Member

    Newcomer
    10
    0
    Oct 29, 2007
    Swaziland
    I also had the update. I first checked on Pimp My Wii if there was any file to update, and since it was not the case, I applied Zelda's update. It caused me no problem with my channels (Homebrew channel, USB Loader GX, ...).
    I think it was just a minor update :)
     
  4. anxion
    OP

    anxion Newbie

    Newcomer
    7
    0
    Oct 31, 2011
    Okay thanks for confirming.

    Still it sounds a bit risky for me. I might update my IOS's
     
  5. anxion
    OP

    anxion Newbie

    Newcomer
    7
    0
    Oct 31, 2011
    Nintendo is playing nice guys against people who purchased this game I think.

    I had two updates that said it would remove everything and it didn't.

    A screen came up saying, "Thank you for your pruchase."
     
  6. RupeeClock

    RupeeClock Colors 3D Snivy!

    Member
    6,384
    860
    May 15, 2008
    There never is, Wii ISO dumpers do not dump the update partition.

    So the Zelda disc actually tries to FORCE an update, it doesn't ask? That can't be legal can it?

    By the way Anxion, if I were you I would consider updating to 4.3 anyway. I'm not sure if it's safe to update from soft-modded 3.1, ask someone else about that, but once you're on 4.3 you'll have all the benefits of it, and can reinstall homebrew channel and d2X cios with relative ease.
     
  7. shortz1994

    shortz1994 GBAtemp Maniac

    Member
    1,341
    157
    Jan 21, 2011
    United States
    stay on 3.1, as long as all your ios cios are up to date then there shouldn't be a problem playing the game(none on my side). just use base 56 dx2. i checked the iso the game uses to load an it's 56.(showmii wads mod).
     
  8. rip-it-up

    rip-it-up GBAtemp Regular

    Member
    246
    21
    Oct 19, 2009
    manchester
    The retail game for me didnt want to do any updates, but im on 4.3 and priloader blocks disc updates so maybe its if you only have a really low system menu.
     
  9. Arkangelyou

    Arkangelyou Advanced Member

    Newcomer
    51
    2
    Nov 12, 2011
    United States
    You could just use a USB Loader and play it.
     
  10. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    5,629
    801
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    I am on 3.2u and I never seen any latest update asked me to update. It doesnt happen to me at all. Maybe you need a program that blocks disc updates. However, I decide to use it just in case accident happens. Thats what I did and it works fine!
     
  11. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Your report sounds really weird. Nobody else reported that the game even asks to update with the priiloader update blocker. And nobody else reported that it forces the update.

    Are you sure your priiloader blocks disc updates?

    And if it was a new update mechanism that's independent from the known one, i'd expect it to pop up when loading via usb as well.
     
  12. shark2003

    shark2003 Advanced Member

    Newcomer
    70
    3
    Jun 10, 2006
    United States
    Or you could just launch it from Gecko OS.....
     
  13. sweenish

    sweenish GBAtemp Advanced Fan

    Member
    704
    2
    Apr 16, 2008
    United States
    WA
    i would at least update to 4.1. The SD channel and the ability to use SDHC is a pretty big feature to be missing out on.
     
  14. vpd

    vpd GBAtemp Regular

    Member
    151
    24
    Sep 2, 2009
    Yeah i second this, SD Menu and SDHC stuff is worth updating for, but no point going past 4.1.
     
  15. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,780
    1,323
    Nov 17, 2008
    United Kingdom
  16. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    21,192
    10,075
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Funny, when I ripped Donkey Kong Country Returns with USB Loader GX, it didn't prompt an update upon launching the WBFS file. It did prompt an update when loading the disc from the disc channel, however. Why should Skyward Sword be any different?

    Try the following -

    - Gecko OS
    - Turn off mandatory disc and online updates (if you have Priiloader)
    - Turn on the priiloader option(s) that prevents the Homebrew Channel and other mods from being deleted/overwritten
    - Rip the game with USB Loader GX or CFG USB Loader (the latter doesn't show a progress bar while ripping)

    Try one or all of these options; surely, there has to be a way to get the game to work without it pestering you about an update.
     
  17. 10_0ARMY

    10_0ARMY THE *Original* 1 Man Army

    Member
    884
    61
    Apr 21, 2009
    United States
    Wouldn't you like to know
    gecko os is the easiest. As soon as I get my copy this weekend, I'm gunna rip it and run it from a usb. I've never had to update anything to play a game. I've used gecko and it works to perfection.
     
  18. anxion
    OP

    anxion Newbie

    Newcomer
    7
    0
    Oct 31, 2011
    Yes, I'm 100% sure.

    This sounds like a new independent update system. I ​ officially €‹ updated to 4.3 with the content on the disc which to my surprise worked and only removed priiloader and bootmii.

    We can confirm so far this has worked for me and Kilvearn, ​but still it COULD be risky. I will see if I can reinstall bootmii
     
  19. VashTS

    VashTS Beat it, son

    Member
    3,896
    698
    Mar 14, 2009
    United States
    Upstate NY
    you should get off of 3.1, go to 4.1 or higher. just update your HBC, install a cIOS into a random slot (so you can be sure to rehack) and update.

    you could also do it via NUS downloader. get all the latest IOS files and install via wad manager. just leave out the system menu if you don't want to update it (really no reason not to though) and also leave out the stubs. i believe modmii can do this all for you in an automated fashion.
     
  20. Eight Bit Alien

    Eight Bit Alien Member

    Newcomer
    18
    0
    Jun 1, 2008
    United States
    Seems as though this only happened because OP was using a vintage system menu...? I've been fretting over this for the past week.

    I'm running 4.3U with priiloader everything, and all I want is to pick up my preorder on Sunday and run it through the disc channel without being retroactively punished for all my past sins.