Kirby's Return to DreamLand with CFG Loader

Discussion in 'Wii - Backup Loaders' started by lilpuddy31, Jan 7, 2015.

  1. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Hey All. I am trying load my backup of Kirby's Return To DreamLand using the CFG loader and my SD card. The game starts up fine until I select a new save file to begin the game, that's when the system locks up. only way to get out of it is to hold down the power button on the Wii. I am using D2x-v10-beta52 installed in 249 with 56 base and 250 with 57 base, and I'm using CFG usb loader v70-r65.

    Any ideas on what I can do for this to work?
     
  2. TheSly

    TheSly Advanced Member

    Newcomer
    89
    2
    Oct 27, 2013
    Australia
    It's maybe because of an anti-piracy protection.
    I have the same problem using Wiiflow.
    Try looking in the "Emulation and Homebrew" section! I asked the same question there yesterday and hopefully got a solution!
    (I just didn't have the time to try it until today)
     
  3. RCJayce

    RCJayce The Defender Of Tomorrow

    Member
    618
    166
    Aug 11, 2014
    United States
    New York
    Hey dude, i had the same problem the other day, Just turn off all the parches for the gane (like 16:9, force video mode and that stuff) also you can check for an Ocarina code to by-pass that AP thing, i'm on my phone now but you should check USB Loader GX thread in this forum i posted my issue there and the guys explained how to resolve this.
     
  4. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Yeah I saw that. that method didn't work for me.

    Yep, I tried turning everything off too, still didn't work for me
     
  5. Bu2d85

    Bu2d85 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    Bu2d85 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    889
    231
    Nov 6, 2014
    United States
    Run it with cios250. Worked for me.
     
  6. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Tried that too, didn't work.
     
  7. Fishaman P

    Fishaman P Speedrunner

    Member
    3,239
    505
    Jan 2, 2010
    United States
    Wisconsin
    For one, CFG Loader v70 is highly outdated. You should be using this version.
     
  8. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Yeah I realized that and updated to v70r65 last night, still didn't help though. But I will give the version you just posted a shot...

    edit: v70r78 didn't work either
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,675
    8,285
    Oct 27, 2002
    France
    Engine room, learning
    is your game the same region as your console?
    don't apply video patches language patches.

    if nothing work, try using the gameconfig.txt fix.
     
  10. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Hey Cyan, I tried the gameconfig.txt, it didn't work for me. Unless I messed it up somehow. Where exactly do I put it and is it supposed to have the "#version: 0.1 (01.11.2011)" at the top of it?

    And here are the default game settings:

    Language: auto
    Video: system def.
    Video patch: off
    VIDTV: off
    LED: off
    Country Fix: off
    IOS: auto
    Block IOS reload: auto
    Alt dol: off
    Anti 002 fix: off
    Ocarina (cheats): off
    Hook type: no hooks (this option is grayed out with ocarina set to off)
    Write playlog: off
    Clear patches: off
    NAND emu: off

    If you need more info, I can give it to you
     
  11. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,728
    2,488
    Jul 23, 2012
    United States
    Octo Canyon
    Try posting a SysCheck, if you haven't already. That might tell us a bit more about your Wii's configuration overall.
     
  12. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Sure, but uhm, where do I find that at?

    Edit: Is this what you are talking about?

    Code:
    sysCheck v2.1.0b13 by Double_A and R2-D2199
     
    ...runs on IOS58 (rev 6176).
     
    Region: NTSC-U
     
    System Menu 4.3U (v513)
     
    Homebrew Channel 1.0.0 running on IOS58
     
    Hollywood v0x11
     
    Console ID: 86189987
     
    Boot2 v4
     
    Found 79 titles.
     
    Found 48 IOS on this console. 15 of them are stub.
     
    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS222 (rev 65280): Stub
    IOS223 (rev 65280): Stub
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS249[56] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21010, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
     
    BC v6
     
    MIOS v10
     
    Report generated on 2015/01/07.
     
  13. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    I just tried loading Kirby Return To DreamLand with WiiFlow, I'm getting the same result.

    Could loading the game from the SD card be the problem?
     
  14. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Good news for me!!!!!! Kirby's Return to DreamLand is NOT compatible with loading from an SD card! How did I find out? A friend let me borrow his 2gb flash drive, CFG USB loader had me format it to WBFS, I copied my backup of Kirby's RTD to it, loaded it up, AND IT STARTED RIGHT UP!!!! I did NOT need the gameconfig.txt file either!
     
  15. TheSly

    TheSly Advanced Member

    Newcomer
    89
    2
    Oct 27, 2013
    Australia
    Hmm... Does anybody know if there exists a fix to start it from SD? I'm using Wiiflow...
     
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,675
    8,285
    Oct 27, 2002
    France
    Engine room, learning
    is starting it from USB but using FAT32 working?
    WBFS partition format shouldn't be required by Wiiflow, it's strange it asked you to format the drive.

    maybe it didn't find a /wbfs/ folder, so it displayed a partition picker/formater prompt?
    you can create the /wbfs/ folder and move the game from your SD to USB.
    Or maybe your Game ISO is bad, and re-dumping/re-installing it to USB is now a proper dump.
     
  17. lilpuddy31
    OP

    lilpuddy31 Member

    Newcomer
    37
    0
    Sep 14, 2003
    United States
    Missouri
    Cyan, you were correct. When I put K'sRTD on the usb drive last night, I totally forgot to put it in a WBFS folder. I re-did it today, and put the game in the proper folder. Everything is working perfectly on both of my backups (Metroid Prime Trilogy and K'sRTD)
     
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,675
    8,285
    Oct 27, 2002
    France
    Engine room, learning
    so it's really the game location which prevents kirby from working.
    that's really strange. I don't know how Wiiflow is working to load games from SD instead of USB, but it should work the same way (only a setting is passed to cIOS to tell the device to use).