just updated to 3.3j

Discussion in 'Wii - Hacking' started by ricflairandy, Aug 20, 2008.

  1. ricflairandy
    OP

    ricflairandy GBAtemp Regular

    Member
    166
    4
    Nov 7, 2007
    guys, ive just updated tpo 3.3j, what are the drawbacks, ive just tried a truca wii language patched game which i belive is truca signed but it still works.
     
  2. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,099
    1,248
    Aug 5, 2007
    You believe yes, try one that you KNOW is.
     
  3. Joey90

    Joey90 Not around any more

    Member
    703
    0
    Apr 21, 2007
    UK
    Do you have a Jap wii?

    If you do, then the only drawback is that trucha discs can only be run by gecko OS (not normally).

    If you have a PAL wii then you might have more serious problems.

    However both of these can be solved if necessary.
     
  4. .:Niki:.

    .:Niki:. Member

    Newcomer
    46
    0
    Nov 27, 2007
    Italy
    OMG
    Use the downgrader
     
  5. ricflairandy
    OP

    ricflairandy GBAtemp Regular

    Member
    166
    4
    Nov 7, 2007
    yes, its a jap wii. Was trying to work out if it was connected via wifi when i must have clicked to download the update.

    Apart from the truca situation, which doesnt bother me if they can be run by gecko , as i have installed the homebrew channel. are there any major differences?
     
  6. Richy Freeway

    Richy Freeway GBAtemp Advanced Fan

    Member
    776
    5
    Oct 9, 2006
    No. Everything else will work fine.
     
  7. SenorClean

    SenorClean GBAtemp Advanced Fan

    Member
    522
    0
    Mar 21, 2008
    Mii OS has been updated, but that's about all.

    The only real change is that the system menu boots with IOS37 - so no more trucha. The only real downside of this that I see, is if you install a WAD with a bad banner - and 'banner brick'... with 3.2 you could make an auto booting disc with wad manager on it (and trucha sign it), boot that, remove the wad.. and you're safe.

    In 3.3 you can't.

    To be safe for this - make sure you have the twilight hack (new, beta, 3.3 friendly version) savegame on your wii before installing any suspect wads. Then you can make an auto-boot copy of zelda, and run homebrew through twilight hack to fix your mess.

    Personally - I am just very weary of which WADs I install on my wii. If possible, I just run things via the Homebrew channel.


    Plusses for running 3.3..... Less likely to brick/semi-brick your wii from out-of-region updates on discs in the future.
     
  8. CambridgeGuy

    CambridgeGuy GBAtemp Regular

    Member
    141
    0
    Nov 22, 2006
    No, it doesn't. When you install 3.3, the IOS used previously (I believe it's IOS 30 or 31) is still used, but it is patched so that it no longer has the signing bug.
     
  9. samsam12

    samsam12 Test

    Banned
    818
    0
    May 13, 2008
    United States
    A House
    to be safe if you dont have a chip, install starfall + twilight hack so you can autoboot zelda.
     
  10. ricflairandy
    OP

    ricflairandy GBAtemp Regular

    Member
    166
    4
    Nov 7, 2007
    thanks guys, it has a d2ckey installed aswell.
     
  11. Arm the Homeless

    Arm the Homeless Custom Title

    Member
    1,762
    5
    May 26, 2008
    United States
    /home/andy/
    I might be wrong, but doesn't the DVD stub (libdi) give remove the fix which stops Trucha?
     
  12. StuMcBill

    StuMcBill Member

    Newcomer
    33
    0
    Jan 24, 2006
    I have a PAL Wii with 3.3E update and I havent had any problems?
     
  13. kedest

    kedest GBAtemp Psycho!

    Member
    3,287
    110
    Feb 6, 2007
    Netherlands
    So you can still run Trucha discs through Gecko OS. Or you can use Menuloader to force the system menu to use IOS36, which can still run Trucha discs.