Issues with Smash

Discussion in 'Switch - Backup Loaders & Modchips' started by davd, Aug 7, 2019.

  1. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    When I tried to install a DLC for Smash things were never the same, the DLC failed and now after removing the game and installing again, no matter how many times I've tried I get: Corrupted data has been detected. Please run a check for corrupt data.

    Any way to try to fix this?
     
  2. Wika

    Wika Member

    Newcomer
    4
    Jun 23, 2018
    United States
    Have you tried to remove all the dlc + updates from smash, then running the game on 1.0? I think it'll prompt you to update again from then assuming your saves are on a higher FW.

    Alternatively: Settings > Data Management > Manage Software > Smash ultimate > Check for Corrupt Data
     
    Last edited by Wika, Aug 7, 2019
  3. EmulateLife

    EmulateLife GBAtemp Psycho!

    Member
    7
    May 30, 2016
    United States
    You're either using ExFat or Atmosphere without patches.
     
    RHOPKINS13 likes this.
  4. Unleanone999

    Unleanone999 GBAtemp Advanced Fan

    Member
    6
    May 15, 2018
    Togo
    Try installing a fresh copy of smash then install the the update and dlc using goldleaf. Also what fw and cfw do you use?
     
  5. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    I tried removing the entire game from Manage Software -> Delete Software, and installed 1.0. Didn't work.

    It says Corrupted data found, The data can be restored by redownloading which I suppose I shouldn't do.

    I probably am, but don't know how to do it other way or how to install the patches.

    Current version reads: 8.0.1 (AMS 0.9.1). Using Atmosphere, and I've already tried goldleaf with just smash and it didn't work.
     
  6. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    I recommend the following steps:
    1. Remove all CFW files/folders from your SD card (that would be folders like /sept/ and /atmosphere/)
    2. Download the latest Atmosphere from GitHub (currently 0.9.2)
    3. Download the latest fusee-primary (next to Atmosphere)
    4. Download these signature patches
    5. Put Atmosphere and the signature patches onto your SD card
    6. Put the SD into your Switch
    7. Launch Atmosphere using fusee-primary
     
  7. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    Just /sept/ and /atmosphere/?

    Here's my SD

    upload_2019-8-7_17-43-17.

    edit: Ok did your steps, but still getting Corrupted data found.

    Gonna try re-installing.
     
    Last edited by davd, Aug 7, 2019
  8. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    There's a lot on your SD that can probably be deleted, but for the steps I gave you to work, you should only need to delete what I listed.
     
  9. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    The re-install right? Because I was still getting the corrupted data message.
     
  10. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Did you follow these steps?
     
  11. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    Yes, of course.
     
  12. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    If you followed these steps correctly, then the game might actually be corrupt. Do other games run?
     
  13. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    Yeah every other game works fine. Even Cuphead, Mario Deluxe, Mario Maker 2...
     
  14. EmulateLife

    EmulateLife GBAtemp Psycho!

    Member
    7
    May 30, 2016
    United States
    I'd say it's most likely because you're using ExFAT as your format for your sd card. I'd delete Smash, copy everything else to computer, Google GuiFormat and Format your sd card to Fat32, copy everything back, reinstall Smash. You'll have to install games using your type c cable that are over 4 GB, it's not that difficult to learn.

    If you've got the Atmosphere patches no game should be corrupt so by process of elimination it's gotta be ExFAT.
     
    Last edited by EmulateLife, Aug 8, 2019
  15. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    While FAT32 is recommended, it's unlikely the source of the problem since everything else works fine.

    Do the following:
    1. Backup your Smash save file if it's important using Checkpoint (if it works)
    2. Remove Smash
    3. Install just the base game and the latest update
    4. Check that Smash boots
    5. Install your DLC one at a time, checking that it works each time. If you run into a corruption problem, it's probably a bad file.
     
  16. EmulateLife

    EmulateLife GBAtemp Psycho!

    Member
    7
    May 30, 2016
    United States
    I have not seen a game corrupt on Fat32 ever.

    But giving the game another try is not a bad idea, if it happens again he'll have to go to Fat32 there's no other option.

    It's a short term solution though probably only a matter of time before more games corrupt or maybe his entire sd card. Everyone should be using FAT32. There's no downside only have to learn how to install through usb.
     
    Last edited by EmulateLife, Aug 8, 2019
  17. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    2. Regular remove from Options -> Delete Software?
    3. Do I need the latest update or just base game should do?
     
  18. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    For now, that should be fine.

    If you've already installed an update, then the game is going to refuse to play without an update. The DLC is also going to require an update. So, as I already said, install the latest update.
     
  19. davd
    OP

    davd Member

    Newcomer
    1
    Jun 19, 2019
    Venezuela
    How can I know which is the latest?
     
  20. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    v655360 (4.0.0) is the latest, I believe.
     
Quick Reply
Draft saved Draft deleted
Loading...