Issues installing Let's go Pikachu with Goldleaf

Discussion in 'Switch - Backup Loaders & Modchips' started by realrj, Jul 1, 2019.

  1. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    Hey guys.

    I'm trying to install via USB PKMN Let's go Pikachu via Goldleaf but I always get the same error

    "An error ocurred attempting to install the NSP

    Error: 0x234c02
    Module: FS (2)
    Description: Invalid NCA (might mean missing sigpatches or a too low firmware) (4518)"

    I even tried converting it with reNXpack using my own keys, but the issue still happens

    I'm running atmosphere via fusee-primary on an unpatched 4.1.0 switch and injecting via android Rekado

    Is it related to firmware updates?
    Can I do an update like we used to on old CFW 3ds?

    Sorry again for the noob questions, just don't want to do anything wrong since i'm pretty new on the switch scene

    Thank you
     
    Last edited by realrj, Jul 1, 2019
  2. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    If you haven't already done so, download these signature patches and put them onto your SD card:
    https://gbatemp.net/threads/i-heard-that-you-guys-need-some-sweet-patches-for-atmosphere.521164/
     
  3. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    Hmm. Now it says Invalid PFS0 instead of the last message :/
     
  4. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    I recommend using the DZ version of Tinfoil instead of Goldleaf.
     
  5. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    So it shouldn't be related to having 4.1.0 firmware on it? Glad that's the case then. I'll try it buddy. Thanks
     
  6. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Pokémon: Let's Go, Pikachu requires 5.0.0 or higher.
     
  7. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    So can I update it via ChoidujourNX like someone said to me before? I got the impression that the person was referring to NXOS because of Emunand.

    Thank you
     
  8. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    You can update to 8.1.0 with ChoiDujourNX.
     
  9. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    Thanks =) reading about it right now
     
  10. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    Up and running now, thanks a lot guys =)

    I just got worried about something. It doesn't say on the guide, but when installation finished, it said something about "be careful about controller update" or something. I noticed barely, but I don't know what it is. and then after I restarted it asked to update the controllers. I declined but don't know if that will be a problem.

    Thank you
     
  11. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    Anyone knows what's the deal with the update of the controllers and why it's dangerous? And how should it be patched?

    Thank you
     
  12. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Controller updates are fine. There's nothing to worry about if you haven't physically modified your controller.
     
  13. realrj
    OP

    realrj GBAtemp Regular

    Member
    3
    Jun 21, 2014
    Barreiro Municipality
    Thank you again Lacius. You really are a lifesaver :)

    Nope, they're just straight out of the box, but since when updating to 8.1.0 on cfw I got a warning saying I needed to patch controller updates to not have any problems, I got really worried
     
  14. squiddybaby

    squiddybaby Newbie

    Newcomer
    1
    Jul 25, 2019
    United States
    how was this solved ? i’m having the same exact issue. what did you update with choi ?

    — Posts automatically merged - Please don't double post! —

    i tried using aluminum foil & i got a similar error code on the nsp
     
  15. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    The Pokemon games require a firmware of 5.0 or higher. If your firmware is not 5.0 or higher, you will need to use the homebrew application ChoiDujourNX to update your firmware.
     
  16. squiddybaby

    squiddybaby Newbie

    Newcomer
    1
    Jul 25, 2019
    United States
    but my emunand & my sysnand are both at 8.1.0
     
  17. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Then use another title installer to install the game such as Adubbz Tinfoil.

    — Posts automatically merged - Please don't double post! —
     
  18. squiddybaby

    squiddybaby Newbie

    Newcomer
    1
    Jul 25, 2019
    United States
    seems like a dead link on his github
     
  19. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
  20. sirus1999

    sirus1999 GBAtemp Regular

    Member
    2
    Nov 24, 2015
    Iran
    my lets go pikachu game work well on firmware 6 . but when i update to 8 corrupt file and i try install again with tinfoil or goldleaf but not install .in goldleaf error is sigpatch or firmware is too low . whay can not install ?
     
Quick Reply
Draft saved Draft deleted
Loading...