Issues installing a plugin.

Discussion in 'PSP - Hacking & Homebrew' started by Zalen, Aug 24, 2012.

Aug 24, 2012

Issues installing a plugin. by Zalen at 6:35 AM (751 Views / 0 Likes) 3 replies

  1. Zalen
    OP

    Newcomer Zalen Newbie

    Joined:
    Aug 22, 2012
    Messages:
    3
    Country:
    United States
    I recently jailbroke my PSP using Rydian's wonderful guide, and haven't run into any issues until today.

    My PSP was starting to get slightly cluttered after I put a few backups and emulators onto my MS, and after checking out the plugins, I discovered one that would help to deal with this issue.

    The plugin I'm talking about is Game Categories v1.3b.
    I haven't installed a plugin before, but I (think) I did everything necessary.

    When I extracted the zip file, it came with two folders: seplugins (Which contains the category_light.prx file), and a folder named src. I have no idea what the src folder is for (Inside it contains a copy of category_light.prx, as well as a few .txt files with names like C File and H File. It also contains an EXP file named exports, and a sub folder named lib. Inside this folder are two A files named libpspsysmem_user.a and libpspsystemctrl_user.a)

    Well, I went to the root of my MS into the seplugins folder, and created four files. VSH.txt, GAME.txt, POPS.txt, and GAME150.txt
    I copied the category_light.prx file into the seplugins folder, and opened VSH.txt and added this line: ms0:/seplugins/category_light.prx

    When I went into the recovery menu of my PSP (Running 6.60 PRO-C), no plugins were listed.
    I tried multiple things like changing the line from ms0:/seplugins/category_light.prx to ms0:/seplugins/category_light.prx 1
    I tried adding the src folder into seplugins

    But nothing has worked.
    Any suggestions?


    EDIT - I decided to see if it was just the one plugin I was having issues with, so I downloaded another plugin. (Hold v4.0)
    I put hold.prx into the seplugins folder on the root of my MS, and added ms0:/seplugins/hold.prx to my VSH.txt file.
    This plugin didn't show up either, so I'm thinking it has to do with either the location of my seplugins folder, or possibly something with the VSH.txt file.

    EDIT #2 - I started from scratch and completely redid my seplugins folder. Hold.prx is now working, still no luck with category_light.prx. It shows on the plugins list and I can enable it. But I'm unable to do anything with it.
     
  2. redfalcon

    Member redfalcon GBATemp Member

    Joined:
    Feb 19, 2009
    Messages:
    250
    Country:
    Germany
    You need to set the category type in "System Settings"-"Category mode". And probably disable the "Category Prefix" option right below.
     
  3. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    it sounds like you haven't made any category folders.

    in vsh.txt make sure the first line is ms0:/seplugins/category_lite.prx 1

    then in X:\PSP\GAME place some folders:
    CAT_Apps
    CAT_Emulators
    CAT_Homebrew
    etc...

    -another world
     
  4. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    /src/ is "source", you don't need it to use the plugin.

    I haven't been able to get category_light.prx working, instead use category_lite.prx (notice the different spelling).

    Also the folders don't need CAT_ in front of them anymore. They used to in older versions.
     

Share This Page