Issue With Trinket M0

Discussion in 'Switch - Backup Loaders & Modchips' started by Joseph111, Nov 6, 2019.

  1. Joseph111
    OP

    Joseph111 Member

    Newcomer
    1
    Oct 9, 2019
    United Kingdom
    I followed this thread to install a Trinket M0 and it works just fine. https://gbatemp.net/threads/interna...ybitsy-m0-express-guide-files-support.508068/

    I keep getting my device isn't recognised on windows after connecting my Switch to the PC. But when I disconnect both the USB cables on the trinkets (traces 2 and 3) via desoldering them then I can connect the cable to the pc and everything works. Does this mean, I wouldn't be able to usb install stuff. I usually use nxmtp you see to connect my switch to the pc, but since those wires are connected I can't and when I remove them, I can use nxmtp to explore my switch content and usb install stuff. Is this normal? Here's what I disconnect to get everything working normally.
    Green Joy-Con D-Pad Shells for Nintendo Switch
     
  2. Joseph111
    OP

    Joseph111 Member

    Newcomer
    1
    Oct 9, 2019
    United Kingdom
    I don't think I soldered the wires the wrong way round. I've looked very carefully and made sure of it. I hit the power to enter ofw and power + vol to enter CFW that works just fine. Just can't actually USB install stuff or connect my Switch to PC because all I get is device is not recognised. Or does the trinket need to be turned off for that?
     
  3. Hayato213

    Hayato213 GBAtemp Guru

    Member
    12
    Dec 26, 2015
    United States
    That doesn't have to do with the Trinket, USB install rely on the USB C port, and drivers on your computer.
     
  4. Joseph111
    OP

    Joseph111 Member

    Newcomer
    1
    Oct 9, 2019
    United Kingdom
    Hmm. I know that's the D- and D+ pads and I wonder whether because the trinket is always powered it's interfering with it. When I disconnect it works and when connected it doesn't
     
  5. Hayato213

    Hayato213 GBAtemp Guru

    Member
    12
    Dec 26, 2015
    United States
    The chip has nothing to do with game title usb install method, you gotta check the usb driver and the usb c cable, double check with Zadig and Tegrasmash Gui drivers.
     
  6. Joseph111
    OP

    Joseph111 Member

    Newcomer
    1
    Oct 9, 2019
    United Kingdom
    Hmm, I just don't really know then. I can usb install fine with trinket disconnect via D - and D+. Drivers are installed and working all fine. Do you think it could be anything else or you think drivers?
     
  7. fate6

    fate6 Haha, I killed a Pumpkin!

    Member
    6
    Aug 2, 2014
    United States
    [fate6@Canterlot ~]$
    Its windows doing it afaik, USB was working fine on my system till I updated W10 and now its hitting me with errors as well.
    This is not the first time this has happened as previous updates also cause this and even same version on different PC works/doesn't work even with fresh OS installs.

    So yea IDK either but i never changed anything switch side so I assume its not the issue.
     
  8. Joseph111
    OP

    Joseph111 Member

    Newcomer
    1
    Oct 9, 2019
    United Kingdom
    I'm using Win 10 too. Are you getting Device is not recognised too?
     
  9. fate6

    fate6 Haha, I killed a Pumpkin!

    Member
    6
    Aug 2, 2014
    United States
    [fate6@Canterlot ~]$
    Yep Device not recognize no matter what mode I put it in, based on your post i guess desoldering the chip would fix it but the fact it did work at one point is odd.

    Only other thing i can think of is maybe the chipside software messing with it.
    Maybe one of the updates to it introduced some bug we are seeing.
     
  10. Joseph111
    OP

    Joseph111 Member

    Newcomer
    1
    Oct 9, 2019
    United Kingdom

    My Trinket works always just fine without connecting to PC. I don't know whether it's those two Data pads which are interfering with Windows to throw the error because once I desolder them everything is fine.
     
Quick Reply
Draft saved Draft deleted
Loading...