is it possible to Restore 3ds 4.5 NAND and install rl9h?

Discussion in '3DS - Flashcards & Custom Firmwares' started by ThatStranger, Aug 28, 2016.

  1. ThatStranger
    OP

    ThatStranger Newbie

    Newcomer
    8
    0
    Aug 28, 2016
    Netherlands
    This is my first thread on GBATemp so bear with me,


    I have installed the gateway version of the rl9h hacks on my 3ds, but if it is possible id like to delete that version and install the community one so i can install both rl9h and luma3ds on the same system because of the more features and faster boot times/reliability . I've read in another thread that this is possible but i didn't quite understand how to do it.

    i have created a backup of my 3ds's 4.5 SysNAND and i have the OTP.BIN stored safely on my pc. i have acces to homebrew and .cia files using the devmenu.

    I should have read into it a bit more before i proceeded with the gateway version of rl9h, if anything isn't clear just ask me. I have a reasonable bit of knowledge about the 3ds hacking scene so I know what im into right now.

    If anyone could help me out i would appreciate it!
     
  2. pbanj

    pbanj The "friendly" neighborhood sandwich

    Member
    2,730
    1,417
    Dec 29, 2014
    United States
    in a ziploc
    what is r9lh?
     
    Quantumcat and Davidosky99 like this.
  3. Thaulos

    Thaulos GBAtemp Regular

    Member
    172
    24
    Aug 24, 2016
    Bedfordshire
    A typo, he means a9lh

    Also, Don't use the gateway's a9lh since it can brick your console unless you had it hard modded. Also gateway's a9lh is outdated

    Use the open-sourced version which is widely used by the community here

    Guide: https://github.com/Plailect/Guide/wiki

    If you follow the guide right, it should overwrite the existing a9lh installation with a much better one
     
    Last edited by Thaulos, Aug 28, 2016
  4. pbanj

    pbanj The "friendly" neighborhood sandwich

    Member
    2,730
    1,417
    Dec 29, 2014
    United States
    in a ziploc
    oh i know
     
    Thaulos likes this.
  5. Thaulos

    Thaulos GBAtemp Regular

    Member
    172
    24
    Aug 24, 2016
    Bedfordshire
    Also if you have these files below as i have researched on the forums

    You should be able to remove the a9lh, again follow the guide since it might contains instructions on how to remove it somewhere
     
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    To remove it, restore a NAND backup from before you installed Gateway's a9lh.
     
    Thaulos and Davidosky99 like this.
  7. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    1- restore a .NAND backup before you installed gateway r9lh using something like decrypt9 not keeping r9lh(option in nand restore)(do this in 9.2 if you can)
    2- update to 9.2 or if in there follow all the steps here until the end and you'll have r9lh installed
     
    Last edited by Davidosky99, Aug 28, 2016
  8. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    Or alternative to #1 - use the Gateway menu (name it NAND.bin and hold Up over the Downgrade option and press A to restore it).
     
  9. leerz

    leerz GBAtemp Advanced Fan

    Member
    527
    133
    Jan 11, 2015
    Makati
    Does gw a9lh won't recognize regular a9 bin files? Can't we just rename to what gw is using?
     
  10. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    Gateway uses the launcher.dat as its a9lh payload.
     
  11. leerz

    leerz GBAtemp Advanced Fan

    Member
    527
    133
    Jan 11, 2015
    Makati
    Didn't know that, won't it recognize our a9lh bins even if we rename them? Question of curiosity. Funny how gw deviates too much from public tools
     
  12. astronautlevel

    astronautlevel Trying to Find My Way

    Member
    4,030
    4,968
    Jan 26, 2016
    United States
    That Nightly Siteā„¢
    No, no open source arm9 payloads will work with GW's implementation.

    However, you can use an open source a9lh implementation and the gateway arm9loaderhax.bin
     
    pbanj and leerz like this.
  13. Froster

    Froster Your Music Producer

    Member
    363
    243
    Sep 6, 2015
    Italy
    that MIDI sequencer
    Rom9LoaderHax confirmed
    Anyway just restore a pre-a9lh nand and I guess you'll be fine.
     
  14. ThatStranger
    OP

    ThatStranger Newbie

    Newcomer
    8
    0
    Aug 28, 2016
    Netherlands
    okay so i installed luma3ds al9h, Decrypt9 and all the other stuff from the guide and im stuck at the last step.. installing the homebrew on my menuscreen on sysnand v4.5 (it installs fine in emunand and what not so maybe its my sysnand version thats to low?) also i cant seem to open the luma3ds updater correctly in emunand and both sysnand. on sysnand i just get a black screen but when i press home and the software pauses i can see the gui. on emunand the updater won't even start at all...

    Also i'd like to know if it is possible to install the gateway al9h.bin from their site without losing any functionality whatsoever like booting into decrypt9 with its launcher.dat.

    is it safe to update my emunand with luma3ds to v11 and that im also capable of using my gateway card with the whole emunand setup?
    its been a few days since ive tried all the steps so i don't really remember all the things I did and it's possible my whole explanation is just plain vague. just ask me what you need to know if you need anything
     
  15. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    If you want to use Gateway with your a9lh, follow https://gbatemp.net/threads/tutorial-using-luma3ds-with-gateway-on-v2-a9lh.431691/
    I don't know if you can still use Decrypt9 from the browser if you install Gateway Time Machine but it's such a bad idea....
    A lot of stuff does not work properly below 9.0. You could try updating your sysNAND to 9.0-9.2 and see if that fixes your issue. But it would be a lot easier to just clone your emuNAND to your sysNAND then get rid of emuNAND. Then everything will work. (except never update sysNAND in Gateway mode, they don't protect it properly)
     
  16. ThatStranger
    OP

    ThatStranger Newbie

    Newcomer
    8
    0
    Aug 28, 2016
    Netherlands
    so if i replace my sysnand with my cloned emunand on v 9.9 ill still be able to use gateway 3ds and luma3ds? because right now i have the homebrew launcher setup in my emunand and fbi is set as my health and safety app, will those installs transfer over to my sysnand then also? i just read the luma wiki and from what i can make up is that it is safe to update my sysnand within systemsettings? could you please provide anything i need to pay attention so that i know luma3ds will protect my al9h and gateway install? are they both still bootable if i have updated to v11/cloned my v9 emunand to sysnand?
     
    Last edited by ThatStranger, Sep 4, 2016
  17. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yes you can flash your emuNAND to your sysNAND and get rid of emuNAND. The apps will all be there. Remember never to do an update in Gateway sysNAND mode though (will either brick or remove a9lh).
     
  18. ThatStranger
    OP

    ThatStranger Newbie

    Newcomer
    8
    0
    Aug 28, 2016
    Netherlands
    so from what i understand its possible to update my sysnand to the newest release and im still able to keep luma al9h and gateway? or as you say flash my emunand to my sysnand (i suppose by using Decrypt9?) delete emunand from my sd card and make everything including gateway 3ds use my flashed systemnand?