Is A Black Screen Wii Fixable?

Discussion in 'Wii - Emulation and Homebrew' started by ScottR31, Aug 9, 2016.

  1. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    Hi,

    I modded my old Nintendo Wii years ago with homebrew etc and after trying it the other day all I get is a black screen when I power it on.

    I still have my old nand.bin and keys.bin from BootMii backed up on my PC.

    Is there anyway to fix this or is it broke?

    Thanks
     
  2. Vishnoo

    Vishnoo Failure is success if we learn from it.

    Member
    261
    32
    Jun 1, 2016
    India
    Do you have Priloader installed.If you don't know that it has or not.Turn on the wii and hold the reset button for 5-15 seconds.
     
  3. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    Can't remember honestly what I installed at the time, I just remember Homebrew and that I have a folder on my PC with nand.bin, keys.bin and a folder for bootmii.

    I tried holding the reset button down but I got nothing happenening.

    I dont have any DVDs in the drive and also I dont have any SD cards in the slot..

    I am getting an SD card within the hour to try some stuff..
     
  4. Vishnoo

    Vishnoo Failure is success if we learn from it.

    Member
    261
    32
    Jun 1, 2016
    India
    Do you have a folder named"bootmii" in your SD card(If you used a sd card).
     
    Last edited by Vishnoo, Aug 9, 2016
  5. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    It was my niece/nephew that have been using it and when I got it back to fix it there was no SD card in it lol.. Hense why im trying to get a new one just now... I thought I could just put the files I have backed up onto my PC onto it to fix it.
     
  6. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    I have a hold of a 4gb SD card now, so do I just copy over the backed up files?
     
  7. Vishnoo

    Vishnoo Failure is success if we learn from it.

    Member
    261
    32
    Jun 1, 2016
    India
    Did you install bootmii or not.It should be installed as boot2.
    If you don't know just google bootmii sd card files and download them.
    You need to set autoboot to HBC.
     
  8. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    I followed this:


    When I put the SD card in with the files on it and turned the Wii on its still just a black screen..

    So what would I do now?

    — Posts automatically merged - Please don't double post! —

    Little update!!

    I turned the Wii off and held RESET in and turned it back on and im onto a white background called Priiloader v0.7

    The only issue im noticing is I cant get my controllers to sync up to use the menu.. they are just flashing 4 blue lights.

    Also when I turn the wii on the drive does a blue light followed by two quick ones, so from what I read that means I have BootMii as boot2 but when I have the folder with the files on my SD card nothing happens when I turn the wii on with it in.
     
    Last edited by ScottR31, Aug 10, 2016
  9. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    I got a hold of a Gamecube controller and plugged that in. These are the steps I followed:

    Copied my backed up Bootmii folder and nand.bin and key.bin to a SD card.
    Put SD card into Wii
    Turned on Wii and held the RESET button in till Priiloader appeared
    Went to BootMii IOS
    Used the power button and reset to cycle to the COG, then to the ram with the red arrow (restore)
    RestoreMii launched, said it found boot2 and done a simulation, it passed the simulation and then restored the original nand and key
    I then turned the Wii off and powered it on but it still shows a black screen.. I even tried holding RESET in to go into Priiloader but it wont work anymore..


    Have I missed anything ??? Also when I power it on the drive goes blue then quickly flashes blue twice so that means boot2 is still installed correct?
     
    Last edited by ScottR31, Aug 10, 2016
  10. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Guru

    Member
    9,820
    4,916
    May 27, 2016
    United States
    New York
    Did you check if maybe the cable for inputs are working? Is there a way to switch between interlase or progressive?
     
  11. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    Well I have a component and a scart and both do the same thing, so unless the actual AV port on the Wii is broken I cant see that being the problem... Plus I got into the Priiloader menu so video output should be working. I edited my last post.
     
  12. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    Am I right to assume the console is fully bricked now that I cant access Priiloader and still have a black screen?

    Is there anything else I can do, I seen something about using the gamecube controller for a recovery...
     
  13. maczilla

    maczilla GBAtemp Regular

    Member
    149
    21
    Nov 12, 2012
    Bermuda
    is it me or could this be hardware damage? maybe the kids dropped it?
     
    Last edited by maczilla, Aug 11, 2016
  14. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    How can it be hardware damage if Priiloader booted up successfully?
    When I turn it on the drive goes blue then double flashes blue so that means BootMii boot2 is installed correct?? But when I put an SD Card in with bootmii files it doesnt load, maybe its my Lexar SDHC 4GB Premium Series 60x that is incompatible... even though it let me read/write the NAND with Priiloader.

    Because it wont let me sync my wii remotes and only works with gamecube controller I may pick up a bluetooth module and try replacing that.
     
    Last edited by ScottR31, Aug 11, 2016
  15. ScottR31
    OP

    ScottR31 Member

    Newcomer
    10
    0
    Aug 9, 2016
    BIT OF A BREAKTHROUGH!!

    I borrowed a SanDisk SD card from a friend and put over my Bootmii folder with the three files in it.

    When I turn on the wii it loads onto BootMii...

    What can I do from here to fix the wii? If i click Wii it just resets and black screens, if I pick Homebrew it loads it but I dont have anything on it ..

    I seen a guide on WiiHacks where I ran a NAND formatter from BootMii which was done successfully, and after it said Finished Successful it just reset to a black screen..

    Is there something else I need to do here? or is this now pointing towards the bluetooth module as I have been using a gamecube controller because my Wii remotes wont sync.
     
    Last edited by ScottR31, Aug 11, 2016