1. Tanmay

    OP Tanmay Banned
    Banned

    Joined:
    Jan 17, 2009
    Messages:
    75
    Country:
    United States
    Hey guys, last year, I left my iPod Nano at home because I was going to school, I come back home from school, switch off hold, click the middle button, but the screen stays blank!! D: I plug it in to my laptop and restore it, still, nothing!!! I have a 2G 2GB Nano Silver
    Please, please, tell me what I do!! Can I get a cheap warranty or something? :[

    Posts merged

    Sorry, I accidentally pressed add post twice ^^;
     
  2. Brian117

    Brian117 GBAtemp Psycho!
    Member

    Joined:
    Oct 1, 2007
    Messages:
    3,274
    Country:
    United States
    If the switch wasn't on the Hold side, then it is most likely the battery is dead.

    Just charge it using your laptop for a few hours.
     
  3. SifJar

    SifJar Not a pirate
    Member

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    Try charging it for a few hours, then hold Menu+Center button for a while, I think its 15 secs or something, till the Apple logo appears. Also, try getting YamiPod, run it, connect iPod, then select repair iPod in one of the menus. Can't remember which manu its in.
     
  4. Tanmay

    OP Tanmay Banned
    Banned

    Joined:
    Jan 17, 2009
    Messages:
    75
    Country:
    United States
    *Facepalm* It's unlocked... I charged it for two weeks... Nothing worked...
     
  5. SifJar

    SifJar Not a pirate
    Member

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    Try holding menu+center button till apple logo appears on the screen.
     
Draft saved Draft deleted