iPhone 4 Unlock (Baseband 03.10.01)

Discussion in 'iPhone, iPod & iPad' started by sonknuck23, Feb 7, 2011.

  1. sonknuck23
    OP

    sonknuck23 Mighty Switch Force >

    Member
    851
    3
    Apr 25, 2008
    Canada
    Montreal, Quebec
    I've been reading everywhere that all of these articles from Dec. 20th 2010 are stating that "within a month" there will be an unlock for iPhone 4 Baseband 03.10.01. I'm just wondering if it's out yet, and just incredibly hard to find? Or do we still have to wait.

    Thanks in advance.
     
  2. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    183
    Apr 23, 2009
    North East Scotland
    They didn't bother when they found out that they could update an iPhone's baseband to a version of the iPad's which was still exploitable by their old method. Means they're not burning any holes yet but its a big risk for the end user as there's no way to downgrade to an official baseband (its version no. is higher than any iPhone's) and its really easy for anybody at the Apple store to spot. Voids warranty permanently.
     
  3. sonknuck23
    OP

    sonknuck23 Mighty Switch Force >

    Member
    851
    3
    Apr 25, 2008
    Canada
    Montreal, Quebec
    My question is, what do we do? We have it JAILBROKEN, How do we go about UNLOCKING it?

    (Sorry, I mixed the two up before.)
     
  4. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    183
    Apr 23, 2009
    North East Scotland
    What do you mean? How do you preserve the baseband version? The only way is to restore a custom IPSW from redsn0w I believe. The normal methods error out now I think.
     
  5. sonknuck23
    OP

    sonknuck23 Mighty Switch Force >

    Member
    851
    3
    Apr 25, 2008
    Canada
    Montreal, Quebec
    I'm all confused, haha. My friend has an iPhone 4 with AT&T but he wants to go with a different service provider. We jailbroke the phone, but the baseband is 03.10.01 and we don't know how to unlock it. . .
     
  6. metamaster

    metamaster GBAtemp Advanced Fan

    Member
    876
    3
    Mar 7, 2010
    Canada
    Ultrasn0w, but make sure that your baseband is compatible. also, MuscleNerd is working on a way to downgrade the baseband.
     
  7. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    183
    Apr 23, 2009
    North East Scotland
    I'm pretty sure that isn't the highest baseband so ultrasn0w might work. You'd have to cautiously update to 4.2.1 if you want to (redsn0w IPSW restore to preserve baseband) then try download ultrasn0w from Cydia.
     
  8. iFish

    iFish Slower than a 90s modem

    Member
    4,223
    159
    Jul 11, 2009
    Canada
    Montreal, QC
    AT&T? Do he even live near you? Since we don't have AT&T here in Canada.
    Sorry to post, just wondering.
     
  9. sonknuck23
    OP

    sonknuck23 Mighty Switch Force >

    Member
    851
    3
    Apr 25, 2008
    Canada
    Montreal, Quebec
    He bought the phone off of someone, the guy said it was with Fido, but. . . I guess it's not. Anyway, whatever. We tried Ultrasn0w 1.2, and it didn't seem to work.
     
  10. Dialexio

    Dialexio GBAtemp Advanced Maniac

    Member
    1,548
    26
    Mar 14, 2009
    United States
    You can't unlock baseband 03.10.01, period. You're out of luck for now, sorry. ;(