IOSs Look Okay?

Discussion in 'Wii - Hacking' started by SquareWheel, Jul 24, 2010.

Jul 24, 2010

IOSs Look Okay? by SquareWheel at 5:52 AM (1,236 Views / 0 Likes) 13 replies

  1. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    Hi there,

    I just wanted to verify that all my IOSs have the right patches applied and are on the right revision. A website which allows you to upload your signCheck SCV and look for problems would be a fantastic idea, but for now hopefully you guys can help me identify any problems? (Compiled with DOP-Mii)

    [​IMG]
    Apologies for the screenshot, there wasn't table formatting BBCode.

    Some IOSs I'm not sure about are 15, 36, 236 (non-existant!), and 53/55. I was a little worried because I couldn't downgrade my IOS15 as stated in this guide, this results in a Revision 0 error, this is why I don't have the IOS236.

    So please, take a look. Maybe compare it to your own IOS list. Thank you.
     
  2. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    Comparing it to my own list wouldn't do much good. First off: the list is different for each firmware version. Second: the cIOS ones happen to have some version differences within them, but that doesn't make the "old" cIOS'es unusable. And third: that list doesn't say everything. It doesn't, for example, tell the base IOS for Hermes's or Waninkoko's cIOS. [​IMG]


    Now...as far as I can see, your list is pretty much in order. If you want, you can check up with official versions here. However, keep in mind that you don't need all the latest versions for your wii. Most games that need them can use the outdated versions just as well.
    ...and if you tell a game to use Hermes or Waninkoko's cIOS instead, the actual IOS version matters even less. [​IMG]

    I checked that guide. The way I see it, it's a procedure to get things working without having to touch any of the basic IOS'es (basically: leaving all the numbers below 200 untouched). That's one way, but since you already have the trucha bug on IOS36 (the fakesign mention in the list) it's not needed to have it.
     
  3. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    Ah, good to know. Thanks for taking the time to look things over. I'll do my best to not obsess over these little things then.
     
  4. C.S.I.

    Member C.S.I. GBAtemp Fan

    Joined:
    Mar 8, 2010
    Messages:
    410
    Location:
    Down under
    Country:
    Australia
    If you want, you can also patch you SM IOS70, that allows you to play 'borrowed' WiiWare I believe.

    Otherwise all looks in good order.

    Its certainly not mandatory to patch your SM IOS.
     
  5. Slowking

    Member Slowking GBAtemp Maniac

    Joined:
    Dec 31, 2006
    Messages:
    1,396
    Country:
    Germany
    yeah maybe patch fakesigning into IOS70 ans install priiloader. otherwise it looks good.
     
  6. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    I actually have Priiloader installed. I'll look into patching IOS70 though, thanks.

    edit: Oh, and what does SM stand for? I've found plenty of references on this forum but still don't know what it means. It doesn't seem to be on WiiBrew either.
     
  7. ocdetective

    Member ocdetective GBAtemp Advanced Fan

    Joined:
    Mar 19, 2008
    Messages:
    601
    Country:
    Malaysia
    System Menu!
     
  8. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    Ahh, thanks. I never would have figured that one out. Okay, looks like after patching IOS70 you need to reinstall Priiloader. Will I have to make a new NAND backup after this as well?
     
  9. LocoRoco

    Member LocoRoco GBAtemp Fan

    Joined:
    Jun 17, 2010
    Messages:
    320
    Country:
    Australia
    ios236 is ios36fakesigned and put to slot 236...this is easly done through MMM ios feature ........you can set the rev to v1-65535....its used as alternate for wad manager ....you can use mmm and any ios and put it to any slot from 200-255 or use showmiiwads and change the ios slot.....
     
  10. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    LocoRoco, I'm afraid I'm not really following you. What does MMM stand for? It is an alternative to Wad Manager?

    edit: Ah, I see, it's "Multi-Mod-Manager". Sorry guys, I don't follow along in this scene as well as I should so some of these terms are lost on me. So you're saying I should use MMM to install IOS36 as IOS236 with the fakesign/trucha bug, and IOS revision is irrelevant?
     
  11. LocoRoco

    Member LocoRoco GBAtemp Fan

    Joined:
    Jun 17, 2010
    Messages:
    320
    Country:
    Australia
    MMM=Multi-mod manager...and i ment ios236 is used as alternate to ios249 for wad manager ....or hbc apps

    Install it only if you want to ....yeah you can set it as any rev my one is ios236v36 for the lols

    dont really see the need for it unless you have both 249 and 250 with base ios that wad manager doesn't support
     
  12. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    I can't really remember what base IOS I used when installing IOS249, it might have been 38.

    I found this guide which recommends using base 57 for IOS249 and base 38 for 250, maybe I'll do that.
     
  13. LocoRoco

    Member LocoRoco GBAtemp Fan

    Joined:
    Jun 17, 2010
    Messages:
    320
    Country:
    Australia
    wad manager 1.4,1.5,1.6 need it with base ios38 with wad manger 1.7 supports it with base ios38 and 57 so installing 250 base ios38 pointless install:


    249[57] better usb loading and use wad manager 1.7
    250[37]music games, monster hunter trii
     
  14. SquareWheel
    OP

    Newcomer SquareWheel Advanced Member

    Joined:
    Jan 1, 2010
    Messages:
    59
    Location:
    Canada
    Country:
    Canada
    Well, I don't intend to buy any music instruments, and Monster Hunter Tri works just fine with Hermes v4 on IOS222. I must have base 57 for IOS249 then.

    Thanks for the information. It's tricky to keep on top of all this Wii stuff, there is a ton of information out there and it becomes outdated very quickly.

    I'll have to install IOS70 later (and reinstall Priiloader), and then maybe think about doing IOS236 just in case something needs it in the future.

    Oh, I'll also reinstall IOS249 with base 57 just in case that's not what I have now.
     

Share This Page