IOS21? The heck is that?

Discussion in 'Wii - Hacking' started by isaac52, Feb 19, 2009.

  1. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Trying to install the homebrew channel via installation disk.

    It doesn't let me, saying i need IOS21... what is this?

    I run a 1.9s wiikey on a japanese 3.2j wii.

    I read on a older page that one would need to update to 3.2 to use it, but im at 3.2 [​IMG] can anyone help?

    Trying to cope with my inability to get brawl to work, by trying to get the homebrew channel to work.
     
  2. cactusjack901

    cactusjack901 Advanced Member

    Newcomer
    85
    5
    Feb 3, 2009
    United States
    you need a chip for the installation disc, just use the twilight hack
     
  3. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA

    I have a chip...
    And i tried the twilight hack, same end result.
     
  4. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    can anyone help?
     
  5. lll

    lll GBAtemp Regular

    Member
    132
    0
    Oct 28, 2008
    If you need IOS21 I suppose you could run the update from Super Paper Mario, otherwise you might be able to run Wad Manager using the Twilight Hack and install it that way.
     
  6. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Make a WAD Manager DVD and install IOS21 wad
     
  7. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Using wadmanager now via TWH on SD card.

    I installed it (or at least, think i did) and after i exited to the loader, i turned off the wii(unplugged) and turned it back on. and tried to use the HBC disk again, to no avail. What'd i do wrong?
     
  8. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    Hmm, why does it need IOS21? Shouldn't it change to a recent ios if exist?
    Is there a specific exploit in IOS21 that is used?
     
  9. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Updated to 1.3 WAD manager, and still no good. The installer disk, NOR the installer boot.dol can find ios21

    is this not the right IoS?

    IOS21-64-v514.wad

    It says it installs, but when i try to uninstall it, just to see if i can, it gets an error. What am i doin wrong this time?

    Edit: Oh, and i used the restard feature by hitting the home button when i was done.
     
  10. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA

    Couldn't say. I know next to nothing about all these IOS,cIOS, etc crap.
     
  11. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Ugh! can anyone explain why i can't install IOS21 via wadmanager!?
    This is pissin me off!
     
  12. mikeyt1998

    mikeyt1998 YouTube Glitcher

    Member
    1,401
    65
    Aug 11, 2007
    Dalton-in-furness, north west
    have you tried running a disc update through paper mario like lll said?
     
  13. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Couldn't that brick my wii? [​IMG]
    Isn't there a better way to update?
    I mean, i already have super paper mario... I'd prefer not to download it again...
     
  14. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Delete IOS21 with AnyTitleDeleter and reinstall it with WAD Manager. Don't care about the unabitlity of deinstalling it with WAD Manager, just try if you can run the HBC installer.
     
  15. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    Mmm... well alright. In a sec though, going to learn a bit about "anytitledeleter" first. wanna know how to use it.
     
  16. isaac52
    OP

    isaac52 GBAtemp Regular

    Member
    277
    37
    Sep 22, 2008
    United States
    MD, USA
    I don't think it worked...

    When i pressed "A" on IOS21, it said "SAFETY CHECK! cant detect system IOS. System file deletes disabled. Report this to author. ...Press any key"

    Is something wrong with my wii? [​IMG]
     
  17. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Hmm, i would recommend to install the HBC via a HBC wad as that's would be the most easy way, but's that's illegal, and i will not answer any questions about it. Maybe if you use the twilight hack to run apps, they run at IOS21 and that's why you can't mess with it. Try to load different .dol loaders found at WiiBrew and to try to 1. install the HBC or if that still fails, 2. delete/(re)install IOS21 with WAD Manager/AnyTitleDeleter. Hopefully one of the .dol loaders loads IOS35 or IOS36(if you have that).
     
  18. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    IOS21 is no cIOS and therefore musn't be deleted
    ATD knows this
     
  19. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    The only IOS you must not delete are IOS30 and IOS50(for now!). But don't mess with it unless it's necessary for some reason. And a not-working HBC installer is a good reason to me.