Invalid signature

Discussion in '3DS - Homebrew Development and Emulators' started by Atmino, Jan 27, 2016.

  1. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    Hi guys,

    Yesterday I tried to install a cia with fbi, and I had the error "invalid signature", so after some researches, I found out that formatting 3ds and emunand would help.

    So, I followed all the steps on the tutorial to install cfw, I made it and now I'm running emunand on 10.5, no problem so far. But when I try to install two cia , I've got the same issue, and the weirdest is that one of them worked great yesterday before I did all the things... Please help me guys . (Majoras mask & dual destinies)
     
    Last edited by Atmino, Jan 27, 2016


  2. Roboman

    Roboman GBAtemp Regular

    Member
    281
    68
    Jan 7, 2016
    United States
    Did you run fbi while in emunand?
     
  3. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    Yep in emunand, both fbi and devmenu, and same issue :(
     
  4. TSSableye

    TSSableye GBAtemp Regular

    Member
    101
    10
    Jan 4, 2016
    United States
    Hmm...not sure what went wrong there... you said that one of them worked great the day prior to this? If so, find the titleID of the game you were using and try deleting it from devmenu. Then afterwards, reinstall it. Not sure if that'll help, but it could be a possible fix for it.
     
  5. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    I can't do it right now since I'm not home, but I'll try it later, I'll post the results here. Hope it will be ok T_T
     
  6. TSSableye

    TSSableye GBAtemp Regular

    Member
    101
    10
    Jan 4, 2016
    United States
    If not, try formatting your emuNAND. If it none of those 2 work, then I've no idea on what to do to help you with that { ͡; ͜ʖ ͡;}
     
  7. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Did you do the database fix while setting up emunand and CFW?
     
  8. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    I just followed the tutorial skipping the un linking nands part, so I didn't fix anything with the databases
     
  9. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Which tutorial did you use?
     
  10. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    The one on gbatemp with the 7 sections, sorry I don't have the link right now, but I think it is the main one
     
  11. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
  12. TSSableye

    TSSableye GBAtemp Regular

    Member
    101
    10
    Jan 4, 2016
    United States
    AND that's where you may have messed up. Follow this guide (To the fullest I may add, don't "skip" anything). If you already used this guide to begin with, redo it and actually UNLINK your NAND please.

    EDIT: Ninja'd :ph34r:
     
  13. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    But it's not that I can't install any cias, I installed pokemon y and professor layton without any problem, I'll try your tutorial with an other sd card
     
  14. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Not carrying out the db fix leaves you with a corrupt or missing database file. That will result in unexpected behaviour, and it's totally possible that some CIAs would install and others wouldn't in this situation.
     
  15. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    About the tutorial you gave me, is it for new 3DS? I have the old 3DS with sysnand in 6.5
     
  16. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    The same principles also apply to o3DS.
     
  17. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    even if it is 6.5 instead of 9.2?
     
  18. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Sorry I didn't spot that that was your sysnand version. No, that tutorial is for sysnand 9.2. I highly recommend updating your sysnand to 9.2. There is absolutely no disadvantage to doing this, plus you get to use menuhax for coldbooting CFW. There is absolutely no reason to stay on 6.5 sysnand. Just be careful when updating to make sure you don't update beyond 9.2. You should also make a sysnand backup before doing anything so if you do accidentally update past 10.3 you can hardmod and reflash your 6.5 sysnand.
     
  19. Atmino
    OP

    Atmino Member

    Newcomer
    18
    1
    Jan 26, 2016
    France
    Okay, so how to update exactly to 9.2?
     
  20. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,537
    2,502
    Oct 28, 2015
    United States
    Use Sysupdater.