I understand cyclo won't work with DSi

Discussion in 'CycloDS' started by Tac 21, Mar 26, 2010.

Mar 26, 2010
  1. Tac 21
    OP

    Member Tac 21 GBAtemp Advanced Fan

    Joined:
    Feb 2, 2008
    Messages:
    517
    Country:
    Canada
    and that it is a hardware issue and not a software one....

    why exactly is this?
     
  2. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
  3. Sumea

    Member Sumea Disco Ninja Frog

    Joined:
    Aug 16, 2008
    Messages:
    1,316
    Location:
    Turku
    Country:
    Finland
    Hardware as in some bootstrap and hardwritten ROM data flashcarts have. Software as that the exploit is still in software level (and is not that legal) - The new flashcarts at moment changed it so it is flashable, what cycloDS is not in the bootROM level (only internal firmware level)
     
  4. Tac 21
    OP

    Member Tac 21 GBAtemp Advanced Fan

    Joined:
    Feb 2, 2008
    Messages:
    517
    Country:
    Canada
    interesting...

    Cyclo could make a newer one if they cared about DSi eh?
     
  5. Sumea

    Member Sumea Disco Ninja Frog

    Joined:
    Aug 16, 2008
    Messages:
    1,316
    Location:
    Turku
    Country:
    Finland
    I think their reason to NOT make one is clear if you look what happened to every other flashcart.

    IMHO; they were one of first ones to find the same exploit aside with Acekard team, but CycloDS team decided that the water's too hot to try take swim in. Now some retailers (dealextreme) have been forced to take down all brands of flashcarts that sell DSi compatible carts, while CycloDS still can be on inventory.
     
  6. Chrono_Tata

    Member Chrono_Tata GBAtemp Advanced Fan

    Joined:
    Jan 26, 2008
    Messages:
    851
    Country:
    Thailand
    Team Cyclops could have released a DSi flashcart much earlier (the crack-down on DSi compatible flashcarts only started more recently). I think it's more likely they decided somewhere along the line that releasing a DSi-compatible flash cart wasn't worth the investment that would have to go producing a new cart, and they could just make more money sticking with the current model.
     
  7. Bowser-jr

    Member Bowser-jr GBAtemp Fan

    Joined:
    Nov 27, 2008
    Messages:
    342
    Country:
    United States
    They were for awhile considering making a flashcard that will work for the DSi but as Sumea and Chrono have stated, they don't think it's worth it.
     
  8. Pliskron

    Banned Pliskron Banned

    Joined:
    Jul 22, 2009
    Messages:
    1,276
    Country:
    United States
    Cylo needs to develop a new card if they want to stay in the game now that the new Superard is coming out.
     
  9. gameguy95

    Banned gameguy95 Needs More Furries!

    Joined:
    Jan 27, 2009
    Messages:
    1,119
    Location:
    Furrytown
    Country:
    United States
    agreed. that would be the only condition i would buy a TC product (because they are so dang expensive)
     
  10. DeMoN

    Member DeMoN GBAtemp Guru

    Joined:
    May 12, 2004
    Messages:
    7,647
    Country:
    United States
    I really don't think they will release a DSi-compatible Cyclo, as it's already way too late for that. Unless they surprise everyone by finding a way to hack DSi-mode, but I really doubt that will happen.
    I'm just glad that Team Cyclops is still strongly supporting the CycloDS. I haven't had to wait more than a few days to play any of the recent releases.
     
  11. fst312

    Member fst312 GBAtemp Fan

    Joined:
    Nov 4, 2008
    Messages:
    482
    Location:
    New York
    Country:
    United States
    exactly why they are not making one no hack to dsi mode.i don't have a dsi cart or dsi because i see no reason of getting them because i can play all the games coming out on my ds lite with my cyclo.
     
  12. KirovAir

    Member KirovAir Dutch Alcoholic Programmer

    Joined:
    Dec 7, 2006
    Messages:
    587
    Location:
    Netherlands
    Country:
    Netherlands
    Please take everything I write with caution, because I might have no idea where the fuck I'm talking about:

    I believe that the CycloDS has ~2MB of internal memory. Where this internal firmware is stored/updated.
    Now, does anybody knows if that piece of memory also covers the bootloader, that uses the exploit the get recognized as a NDS game?
    If so, shouldn't it be possible to simply update the internal memory (and bootloader) with a DSi-compatible exploit, so that the card could be recognize by a DSi as well?

    Just a dumb thought of mine, but yeah.
     
  13. Rayder

    Former Staff Rayder Mostly lurking lately....

    Joined:
    Jan 14, 2007
    Messages:
    6,613
    Location:
    USA
    Country:
    United States
    Nope, the bootstrap is hard-coded onto the Cyclo's chip, that's why it can't be made to run on a DSi. The 2meg space for the firmware is only for the game compatibilities and various features of the cart, not how it bypasses the system's security.

    My guess as to why they never made a DSi flashcart is because when they do it, they want DSi mode unlocked too or they aren't going to bother.
     

Share This Page