Hardware How to check PCB

ExzoTikFruiT

Member
OP
Newcomer
Joined
Aug 11, 2019
Messages
14
Trophies
0
Age
28
XP
64
Country
Russia
Hello. Tell me how to check the following chips: M92T36/BQ24193/P13USB. The console does not want to charge. With a new battery, I start the firmware, and error 2101-0001 appears
 

ExzoTikFruiT

Member
OP
Newcomer
Joined
Aug 11, 2019
Messages
14
Trophies
0
Age
28
XP
64
Country
Russia
Additional information: all smd calls on one side only. Battery voltage 3.72V. 5 and 6 legs of the IC give out 2.76V
In hekate, the battery charge does not jump (which, as I understand it, says that the BQ24193 is working
 
Last edited by ExzoTikFruiT,

mattytrog

You don`t want to listen to anything I say.
Member
Joined
Apr 27, 2018
Messages
3,708
Trophies
0
Age
47
XP
4,315
Country
United Kingdom
Additional information: all smd calls on one side only. Battery voltage 3.72V. 5 and 6 legs of the IC give out 2.76V
In hekate, the battery charge does not jump (which, as I understand it, says that the BQ24193 is working
3.72 = flat.

First check something is getting into bq24193.

Check testpoint on top of bq24193. V+ should be 0v without usb plugged.

Rising to 3-4v usb plugged in.

Next, check fuel gauge registers (max17050).

The chip for this is on the other side of the board but you can check registers in Hekate (or fix/reprogram using my Hekate mod called switchboot) which has the disabled Hekate code enabled. Check registers aren't FF FF...

If all is good and console is booting, then m92t36 is probably ok. Or at least the core voltage is. Pin 5 volts should = pin 6 +/- say 200mV. Though pin 5 can go higher up to 6v according to some Chinese users.

Try this:

On the ninty error screen, plug into dock. If you get picture, assume pi3usb is ok for now.

That leaves bq24193 or fuel gauge(though this is just for battery percentages really).

I'm not near my notes as I'm at the coast but will be home at end of week.
 
  • Like
Reactions: Agilato

ExzoTikFruiT

Member
OP
Newcomer
Joined
Aug 11, 2019
Messages
14
Trophies
0
Age
28
XP
64
Country
Russia
3.72 = flat.

First check something is getting into bq24193.

Check testpoint on top of bq24193. V+ should be 0v without usb plugged.

Rising to 3-4v usb plugged in.

Next, check fuel gauge registers (max17050).

The chip for this is on the other side of the board but you can check registers in Hekate (or fix/reprogram using my Hekate mod called switchboot) which has the disabled Hekate code enabled. Check registers aren't FF FF...

If all is good and console is booting, then m92t36 is probably ok. Or at least the core voltage is. Pin 5 volts should = pin 6 +/- say 200mV. Though pin 5 can go higher up to 6v according to some Chinese users.

Try this:

On the ninty error screen, plug into dock. If you get picture, assume pi3usb is ok for now.

That leaves bq24193 or fuel gauge(though this is just for battery percentages really).

I'm not near my notes as I'm at the coast but will be home at end of week.
switch poweroff:
On green testpoint:
without usb - 3.72
w/ usb - 3.72
yellow testpoint - always 0
Switch in hekate:
On green testpoint:
without usb - 3.72
w/ usb - 3.72
yellow testpoint - always 0

Docked - only green led on dock. No picture

m92t36:
5pin - 2.4v
6pin - 3.2v
 

Attachments

  • dPPHmWSEE2E.jpg
    dPPHmWSEE2E.jpg
    626.4 KB · Views: 293
  • U4P2brAY0Y0.jpg
    U4P2brAY0Y0.jpg
    445.1 KB · Views: 228
Last edited by ExzoTikFruiT,

mattytrog

You don`t want to listen to anything I say.
Member
Joined
Apr 27, 2018
Messages
3,708
Trophies
0
Age
47
XP
4,315
Country
United Kingdom
switch poweroff:
On green testpoint:
without usb - 3.72
w/ usb - 3.72
yellow testpoint - always 0
Switch in hekate:
On green testpoint:
without usb - 3.72
w/ usb - 3.72
yellow testpoint - always 0

Docked - only green led on dock. No picture

m92t36:
5pin - 2.4v
6pin - 3.2v

Do you get a picture with a charged battery?

No volts with usb on yellow TP?

Looking like bq24193 to me. Fuel gauge appears good.

Got green light on dock...

I'm saying bq24193 at the moment.
 

ExzoTikFruiT

Member
OP
Newcomer
Joined
Aug 11, 2019
Messages
14
Trophies
0
Age
28
XP
64
Country
Russia
Do you get a picture with a charged battery?

No volts with usb on yellow TP?

Looking like bq24193 to me. Fuel gauge appears good.

Got green light on dock...

I'm saying bq24193 at the moment.
The charge console shows the correct one. Threw to another - the same data. Ok then order bq24193. and it certainly can be connected with an error 2101-0001?
 
Last edited by ExzoTikFruiT,

ExzoTikFruiT

Member
OP
Newcomer
Joined
Aug 11, 2019
Messages
14
Trophies
0
Age
28
XP
64
Country
Russia
Do you get a picture with a charged battery?

No volts with usb on yellow TP?

Looking like bq24193 to me. Fuel gauge appears good.

Got green light on dock...

I'm saying bq24193 at the moment.
Replace M92T36/BQ24193/P13USB.no effect. Consumption has become zero. It was 0.02A
After replacing BQ24193, the voltage at the point where it used to be 0 became 0.05.
After the replacement M92T36 сonsumption has become zero. Stopped turning on
@mattytrog
 
Last edited by ExzoTikFruiT,

ExzoTikFruiT

Member
OP
Newcomer
Joined
Aug 11, 2019
Messages
14
Trophies
0
Age
28
XP
64
Country
Russia
@mattytrog Please,help.
Changed all 3 controllers. Consumption is also 0.03A. Now shows the wrong charge with any combination of controllers. Shows temperature normally.Comes in RCM. It does not load into the atmosphere, hangs on the logo. apparently due to battery readings. Could this be in case of a malfunction of the battery itself? Can it be checked somehow without another console?
 

masterprosync

Active Member
Newcomer
Joined
Sep 29, 2019
Messages
36
Trophies
0
Age
31
XP
176
Country
Malaysia
switch poweroff:
On green testpoint:
without usb - 3.72
w/ usb - 3.72
yellow testpoint - always 0
Switch in hekate:
On green testpoint:
without usb - 3.72
w/ usb - 3.72
yellow testpoint - always 0

Docked - only green led on dock. No picture

m92t36:
5pin - 2.4v
6pin - 3.2v

Why my switch show battery info without "battery age"?
 

Theorem

Well-Known Member
Newcomer
Joined
Dec 19, 2018
Messages
57
Trophies
0
XP
980
Country
Czech Republic
Guys if charging works (slow - 0,47, no trickle), i can start Hekate (RCM works) but without RCM nothing - no OFW start and from CFW i can start OFW but i get error 2101-0001 is it still M92T36 as a main suspect ?
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    sombrerosonic @ sombrerosonic: at 60 FPS