Help with Broswerhax

Discussion in '3DS - Homebrew Development and Emulators' started by Ivosley, Jan 31, 2016.

  1. Ivosley
    OP

    Ivosley Newbie

    Newcomer
    2
    0
    Jan 31, 2016
    Macau
    So as I've got a 3ds Xl,I've been keen to install Homebrew on it

    Been following this guide : http://pastebin.com/ZfA8wtA2 which have been proved useful to some friends

    And while trying to install broswerhax,I couldn't get it to trigger the exploit and i've been faced with notification asking me to update my browser in order to use it.

    My browser's version 1.7610
    My 3ds Xl Ver.10.1.0-27E

    I've downloaded the starterkit from http://smealum.github.io/3ds/

    My SD card is 16 gb (No one mentioned it should be in a specific format so i left it in Fat32 )

    Here's a Screen of my Root directory : http://i.imgur.com/agpXNPf.png
    Screen of my 3ds folder : http://i.imgur.com/NfRGVpR.png

    I've been struggling with this for a while so any help is really appreciated,Thank you everyone
     
  2. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,104
    405
    Aug 15, 2015
    United States
  3. James310

    James310 GBAtemp Advanced Fan

    Member
    879
    319
    Oct 4, 2015
    United States
    Somewhere in California
    I like how people who see "You need to update the system in order to use the Browser" pop up and quickly blaim the issue on the hax it's self
     
  4. SANNIC789

    SANNIC789 GBAtemp Advanced Fan

    Member
    704
    91
    Oct 3, 2015
    United States
    ik rite
     
  5. @lexander

    @lexander Newbie

    Newcomer
    5
    4
    May 9, 2015
    United States
    Maryland, United States
    @Ivosley

    Hello!

    Unfortunately, the emboldened portion of your sentence is the problem. Considering that the most recent browser version for your O3DS XL is 1.7616, which was introduced in firmware version 10.2.0-28, you cannot use the browser unless you perform a system update. I would not recommend updating your console to 10.5.0-30 considering you want to downgrade. Do you have any games that consist of alternative entry points?
     
    Last edited by @lexander, Feb 1, 2016
  6. Ivosley
    OP

    Ivosley Newbie

    Newcomer
    2
    0
    Jan 31, 2016
    Macau
    Rather new into this and wasn't blaming the hack itself i respect The dev's work,i don't know if i didn't portrait that enough but i blamed my feeble understanding of the homebrewing ,sorry if i offended you.

    — Posts automatically merged - Please don't double post! —

    Sorry for the late reply,i don't think i do but i've been thinking about getting one still trying to choose the right one if you could enlighten me on the matter i'm still new to this.
     
  7. vgplayer54

    vgplayer54 GBAtemp Regular

    Member
    212
    12
    Feb 4, 2010
    Canada
    Hello, I'm having the exact same problem as you - attempting to downgrade but having the 3DS tell me the browser requires an update. I am using a N3DS firmware 9.9. Also, I attempted to use the OOTHax, but when I used Powersaves to load the hacked save onto my game, the game notifies me that the save is corrupted and automatically deletes it. Therefore I'm unable to load that save as well. I'm not sure where to go from here, any help would be greatly appreciated!
     
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,528
    5,474
    Mar 17, 2010
    Norway
    Alola
    Since you're on a n3DS there's still a way. https://gbatemp.net/threads/browserhax-is-still-working.400991/
    As for the powersaves thing, you are probably using the wrong savegame for your OoT3D revision. There were two different revisions of the cart and the saves are not compatible between the two.
     
  9. James310

    James310 GBAtemp Advanced Fan

    Member
    879
    319
    Oct 4, 2015
    United States
    Somewhere in California
    You can still downgrade from 10.5 just requires a Hardmod , you backup your nand, patch the nand with 10.2 firm , restore and sysupdater will work again
    All that is wip but testers said it worked
     
  10. vgplayer54

    vgplayer54 GBAtemp Regular

    Member
    212
    12
    Feb 4, 2010
    Canada
    The Real Jdbye, you are amazing!! I've now successfully downgraded, however after rebooting the system following the successful downgrade, I am no longer able to boot into the main menu or the homebrew launcher. If I remove the SD Card however, it boots just fine (although still can't load homebrew launcher). I've been reading the site and apparently the cause is that menuhax was meant for higher firmware versions and not compatible with 9.2 and thus crashes. I can't seem to figure out what to delete or modify on the SD card to allow the system to boot normally and once again have access to the homebrew launcher. Do you know what I should do?
     
  11. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,528
    5,474
    Mar 17, 2010
    Norway
    Alola
    Boot the system without the SD card inserted, insert the SD card and change the theme.
     
  12. vgplayer54

    vgplayer54 GBAtemp Regular

    Member
    212
    12
    Feb 4, 2010
    Canada
    Once again The Real Jdbye, you really know what you're doing. I wouldn't have progressed this far without your help! Thank you so much!! Now I've finally downgraded to 9.2 and have copied back my original downloaded VC games and DSWare titles. Now...to figure out how to install CFW. It seems I can no longer use menuhax on 9.2...do you have a recommendation of which CFW to use? (or the differences for that matter). And where to download the CFW Kit perhaps, although I'm sure I could find it with google, only if you have it on hand.
     
  13. @lexander

    @lexander Newbie

    Newcomer
    5
    4
    May 9, 2015
    United States
    Maryland, United States
    @Ivosley

    That's okay. Since you have an O3DS XL, the only viable entry points you can use now require money. These are the methods you can use:

    1) Cubic Ninja - This exploit is self-sufficient, meaning that the payload only requires the game itself and not any extra hardware or software. However, this game is of high demand and has a limited quantity which means it can be very expensive.

    2) The Legend of Zelda: Ocarina of Time 3D - With this game, you can write a raw saveimage into the game's savedata. More information is available here - https://gbatemp.net/threads/tutorial-how-to-install-oot3dhax.396339/. In your case, it is the easiest to perform method 2. All of what you need is in that tutorial.

    3) Purchasing a Sky3DS or a Sky3DS+ and using a Cubic Ninja ROM - You can use this flashcard with a Micro SD card and run Cubic Ninja like you would if you owned a retail copy.

    Sadly, these are all the options that you can do since you don't have access to any free, standalone exploits.
     
    Last edited by @lexander, Feb 1, 2016
  14. Joom

    Joom  ❤❤❤

    Member
    4,301
    2,948
    Jan 8, 2016
    United States
    You can use it on 9.2, and it acts as a really nice commodity for using a bootloader since you can use it to autoboot straight to a loader which will allow you to boot between a CFW or straight to the HBL. I'd recommend the ReiNand mod by Aurora Wright since you have an N3DS. It's worked very well for me and it's nothing overly fancy.
     
  15. vgplayer54

    vgplayer54 GBAtemp Regular

    Member
    212
    12
    Feb 4, 2010
    Canada
    Thank you for your suggestion. I now have ReiNand on my N3DS and everything seems to be working fine. Now I'm just trying to figure out how to restore my virtual console games and DSWare back onto the system. It seems just copying the "titles" folder from my SD Card backup (before any modification) doesn't restore the games of their saves...

    Oh! and for updating the firmware, do I want to do it on the SysNand? or the EmuNand? I believe it's EmuNand that gets updated, but not through Nintendo obviously. Is there a way to update it to the new 1.0.5 firmware yet?
     
    Last edited by vgplayer54, Feb 2, 2016
  16. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,104
    405
    Aug 15, 2015
    United States
    ik theres a prerelease of a agb_firm save manager right? Its on this website somewhere xD
    Edit-https://gbatemp.net/threads/pre-release-agbsave9-tool-to-extract-agb_firm-saves.410684/
     
    Last edited by Biff627, Feb 2, 2016
  17. vgplayer54

    vgplayer54 GBAtemp Regular

    Member
    212
    12
    Feb 4, 2010
    Canada
    Thank you, but that seems to be a way to inject ROMS into the system. I was asking if there is a way to take my previously installed virtual console games (and their gamesaves) and put them back onto my newly reformatted SD Card (after installing ReiNand and Emunand))
     
  18. Joom

    Joom  ❤❤❤

    Member
    4,301
    2,948
    Jan 8, 2016
    United States
    You want to update EmuNAND, not SysNAND, and you can do it the normal way through System Settings. Unfortunately, I don't think you can restore your saves unless you backed them up using a save manager like svdt beforehand. I'm not entirely sure though.
     
  19. @lexander

    @lexander Newbie

    Newcomer
    5
    4
    May 9, 2015
    United States
    Maryland, United States
    Hey there, Ivosley! There is some good news for you (in case you didn't update your 3DS's firmware). Yellows8, a reputable Nintendo console hacker, just publicly released a browser version-check timestamp bypass that allows you to remove the update message for a day. I'll quote directly from his browserhax webpage:
    If you still having issues or these instructions have worked for you, please let us know!

    (I apologize to other users for reviving this topic. Considering this thread was created around the beginning of this month and the issue has since not been declared solved, I decided to update this topic on relevant information regarding a possible, free solution to this problem for anyone who needs it!)
     
    Last edited by @lexander, Feb 29, 2016