Help please! Safea9lhinstaller.... "error firm0.bin doesn't exist or has a wrong size"

Discussion in '3DS - Homebrew Development and Emulators' started by tbclandot, Jan 5, 2017.

  1. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Really want that Luma firmware but hopefully this is an easy fix!
     


  2. ItsKipz

    ItsKipz l33t hax0r

    Member
    1,645
    983
    Sep 9, 2016
    United States
    The C: drive
    What guide are you following? https://3ds.guide/ should have you with all the right files by now?
     
  3. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Ya I was following that guide maybe I'm missing something on my sd card?
     
  4. Giodude

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,783
    1,097
    May 17, 2015
    United States
    New York
    I'd read over the a9lh page one more time, and make sure you have every file that it specifies. Also, crazy question, you are on 2.1 firmware right?
     
  5. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Yes been stuck on 2.1 firmware for hrs man lol
     
  6. Giodude

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,783
    1,097
    May 17, 2015
    United States
    New York
    Making sure, i figured as much, but i thought possibly the reason it couldn't access the partitions was because you were in a firmware that locked it out.
     
  7. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Here is what my sd card looks like!
     

    Attached Files:

  8. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,015
    Sep 13, 2009
    Australia
    The interior of your a9lh folder should look like this:

    a9lh folder.png
     
  9. tnecniv43208

    tnecniv43208 GBAtemp Regular

    Member
    135
    31
    Nov 9, 2016
    Taiwan
    Yeah like the error message, you don't have 4 .bin in your a9lh folder, you missed them from the guide
     
  10. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    If you see my screenshot the only difference is the order!

    — Posts automatically merged - Please don't double post! —

    wait where would that be what download?
     
  11. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,015
    Sep 13, 2009
    Australia
    You are missing four files, specifically the contents of the arm9loaderhax release.7z

    The guide directs you to "The latest release of arm9loaderhax (the .7z file)"
     
  12. tnecniv43208

    tnecniv43208 GBAtemp Regular

    Member
    135
    31
    Nov 9, 2016
    Taiwan
  13. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Oh wonder if that is it all along thanks for being so supportive!

    — Posts automatically merged - Please don't double post! —

    Those 4 payload files are already in that folder I'm so lost!
     
  14. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,015
    Sep 13, 2009
    Australia
    Not according to your earlier screenshot. Be sure those files are directly within the a9lh folder, not within any other folder. See my earlier screenshot I posted.
     
  15. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Oh yes that screenshot I do see is wrong man I'm losing it man you guys are the best! I'm such a noob!

    — Posts automatically merged - Please don't double post! —

    Updated screenshot same error think my 3ds just doesn't want cfw!

    — Posts automatically merged - Please don't double post! —

    I downgraded from 11.2 to install CFW that has nothing to do with this error as well right?
     

    Attached Files:

  16. tnecniv43208

    tnecniv43208 GBAtemp Regular

    Member
    135
    31
    Nov 9, 2016
    Taiwan
    Do you have the contents of safea9lhinstaller all set up?
     
  17. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,015
    Sep 13, 2009
    Australia
    No, I did a 2.1.0 ctrtransfer from 11.0 and installed a9lh fine, as did many other people.

    I honestly believe the issue may stem from the (un)archiver you're using, or the fact that you're using a Mac. I see a lot of 'random' errors like this from Mac users. Sorry I can't help more.

    Also, the fact that you're not getting an otp.bin is also troubling. You are on 2.1.0, right? Are you successfully booting into safea9lhinstaller?
     
  18. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Here I'll do another screenshot of my entire sd card.... how should the contents of safea9 be setup? Am I missing anything in this one?

    — Posts automatically merged - Please don't double post! —

    I have bootcamp man maybe I should retry the process on Windows 10? Guess Macs don't play well with 3DS's or something? Never thought like it but definitely a good idea!
     

    Attached Files:

  19. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,015
    Sep 13, 2009
    Australia
    You don't need the .3dsx (or .smdh); you need to run it through the browser. Please just follow the guide.

    Maybe. Worth a shot, I suppose.
     
  20. tbclandot
    OP

    tbclandot Member

    Newcomer
    39
    1
    Nov 14, 2016
    United States
    Yes I boot into safe9installer and then get said error message every time luckily I'm careful so I don't brick but not fun being stuck on 2.1 XD

    — Posts automatically merged - Please don't double post! —

    Xiphiidae I really appreciate you man it means a lot! Will try again tomorrow don't want to brick my new 3DS from being too tired and aggravated lol