Help needed with playing and saving .GBA on DSLite

Discussion in 'NDS - Emulation and Homebrew' started by khrall, Oct 22, 2010.

  1. khrall
    OP

    khrall Newbie

    Newcomer
    1
    Oct 22, 2010
    Netherlands
    Hello all,

    I have a problem with my DS and I can't figure out what to do. I have read many posts and visited a lot of websites on this subject and I can't find the solution to my problem.

    What do I want?
    • I would like to be able to play .GBA games on my DSL.
    • I would like to be able to save .GBA games on my DSL.
    What materials do I have?
    • DSLite (DSL)
    • Ez-Flash VI card (slot 1)
    • Ez-Flash V 3-in-1 card (slot 2)
    • Latest kernel and firmware
    • .GBA game: Pokemon FireRed (for testing)
    What have I tried?
    • I have tried running the game just without any additional programs on Ez-Flash. It works! I can play GBA games on my DSL, but when I save the game and restart the DSL the safe file is nowhere to be found.
    • I have tried GBA ExpLoader (latest version). The program works fine and I can start games with it. However, again no safe game. According to different websites and forums it should be possible to save a game with GBA ExpLoader. But how?
    • I have tried patching .GBA games to enable saving. Failure.
    • I have tried to convert a .GBA game to a .NDS file. No success.
    Now my question to you are:
    • Did I do something wrong
    • What is the best method to play .GBA games on the DSL?
    • How can I save the .GBA games on my DSL?
    I hope you guys can help me with this!
     
  2. Inunah

    Inunah The Female Mistaken for a Male.

    Banned
    0
    Sep 14, 2009
    United States
    USA
    Can you create new saves for NDS games?

    If yes:
    Your 3in1's save battery might be fried or dead or something. Either way, it'll need replacing.

    If no:
    You might need to format your Micro SD.
     
  3. khrall
    OP

    khrall Newbie

    Newcomer
    1
    Oct 22, 2010
    Netherlands
    Yes the NDS games save perfectly.

    Could it be that simple? That it is just broken? Because I can still play GBA games. When starting up Pokemon for example it does mention the clock does not work.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice