[HELP] Lost some system menu icons

Discussion in 'Wii U - Hacking & Backup Loaders' started by khara02, Feb 1, 2017.

  1. khara02
    OP

    khara02 Member

    Newcomer
    14
    3
    Jul 6, 2015
    Hi there,
    Somehow I lost Disc menu and vWii menu icons no where on WiiU dashboard.
    What I can think of the things that may cause this problem is,

    1. I edited sys_prod.xml by hand, downloading and uploading the file using FTPiiU everywhere, not by wupclient.py.
    2. I deleted some tik files in storage_slc/rights/ticket/apps because of I got the error 105-3087 by using FTPiiU everywhere.

    I have done factory reset, uploading the tik file that I backuped before the deletions, and still no luck.

    Please help...
     
  2. lordelan

    lordelan GBAtemp Advanced Maniac

    Member
    1,691
    481
    Jan 4, 2015
    Gambia, The
    Oh my ... that's why ftpiiu everywhere could be so dangerous.
    You obviously deleted the wrong tickets as it seems. Maybe you would only need to replace your sys_prod.xml with the original file and ask someone here for the tickets to the system titles you seem to have deleted as I'm not at home right now to send them to you.
     
  3. khara02
    OP

    khara02 Member

    Newcomer
    14
    3
    Jul 6, 2015
    That is quite odd.
    I looked up the title id database to find the ids for those been missing.
    http://wiiubrew.org/wiki/Title_database#0005xxxx:_System_titles
    Which one will be Wii menu? and Disc launcher?

    And I realized that, those sysytem title tickes are all in the directory storage_slc/rights/ticket/sys, not storage_slc/rights/ticket/apps that I actually FTP accessed.

    I even deleted the wholed tickets in apps folder to see what will happen, and those system icons left just stays, basically nothings seems to be happened.

    What is been affected for those system icons disappearance??

    — Posts automatically merged - Please don't double post! —

    I found this post.
    http://gbatemp.net/threads/disc-and-wii-icon.451387/
    I will try to reset the region things when I go home.
     
  4. lordelan

    lordelan GBAtemp Advanced Maniac

    Member
    1,691
    481
    Jan 4, 2015
    Gambia, The
    Yes try and report back. But as you describe it maybe only your sys_prod.xml changes did cause the problem.
     
  5. khara02
    OP

    khara02 Member

    Newcomer
    14
    3
    Jul 6, 2015
    Editing region code back to the original on sys_prod.xml and re-signing in made everythings back to be normal.
    The problem is solved. :)
     
    lordelan likes this.
  6. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,718
    2,099
    Aug 19, 2015
    United Kingdom
    Clydebank
    Glad the help I gave the other guy in the tread you linked to helped you out. I would also recommend you use mocha for region free as that does not alter any wiiu files so no side effects like you had. Or use haxchi if you are a bit more adventurous lol
     
    Last edited by Marko76, Feb 3, 2017
  7. khara02
    OP

    khara02 Member

    Newcomer
    14
    3
    Jul 6, 2015
    Yes, your post in that thread helped me a lot. I even thought about buying another WiiU.
    And again, thank you for your advice. :)
     
  8. George miller

    George miller Member

    Newcomer
    15
    5
    Sep 15, 2016
    United States
    Someone fixed this issue? I just formatted a wii u to start fresh, wii u of my friend is 5.5.2 added a new id and both disk and wii u menu icon dissapeared.
     
  9. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,885
    714
    Oct 10, 2009
    United States
    this can happen if you alter the sys_prod.xml . if you do that and create a new NNiD, this can happen.
     
  10. George miller

    George miller Member

    Newcomer
    15
    5
    Sep 15, 2016
    United States
    A friend of mine bought the console, we formatted the console and create a new nintendo user id and installed haxchi. But i guess we didnt realize the disc icon and the wii menu icon were missing. Since now it´s the only nintendo id on the system i can´t delete it, also, that would cause an issue with haxchi, since we bougth the brain age for the hack using this new nintendo id, not that one previously installed in the console, which was formatted before because we wanted to start from scratch.