Goddamn you, R and L buttons.

Discussion in 'NDS - Flashcarts and Accessories' started by War, Oct 18, 2008.

Oct 18, 2008

Goddamn you, R and L buttons. by War at 8:45 PM (1,564 Views / 0 Likes) 12 replies

  1. War
    OP

    Member War Take it easy~

    Joined:
    Oct 26, 2007
    Messages:
    5,409
    Location:
    California
    Country:
    Japan
    So yeah, I figured these sort of things couldn't happen to me...but lo and behold, my R button stopped working about 2 weeks ago. At first, if I just blew into it, it would work. Then, that trick stopped working... so I got out a can of compressed air and sprayed it a couple times, which worked really nicely, today, my R button does not work at ALL. I tried cleaning my DS, blowing into the R button, and spraying it several times with compressed air... none of those worked. Not only that, but now my L button is acting wonky too :\ How should I fix this?

    Please don't say "get a new DS". I honestly wouldn't mind getting a new one, but not only do I not have the money right now, but I feel like at this point, I might as well wait for the DSi.
     
  2. Rayder

    Former Staff Rayder Mostly lurking lately....

    Joined:
    Jan 14, 2007
    Messages:
    6,613
    Location:
    USA
    Country:
    United States
    I'm going to assume you have a DSlite, and that it's no longer under any kind of warranty.

    Here's what you need to fix it:

    http://www.dealextreme.com/details.dx/sku.13264

    Of course this would mean taking apart your DS and will also require some minor soldering skills, but that would definitely solve the problem and it's a heck of a lot cheaper than "buying a new DS" or waiting for the DSi.
     
  3. kevenka

    Member kevenka GBAtemp Advanced Fan

    Joined:
    Jul 15, 2007
    Messages:
    930
    Location:
    Texas
    Country:
    United States
    I am so confused as to why anyone would really want a DSi =/
    Isn't it just more and differet homebrews? The DS games will still be exclusive to any DS platformer right?
     
  4. Brian117

    Member Brian117 GBAtemp Psycho!

    Joined:
    Oct 1, 2007
    Messages:
    3,249
    Location:
    Cleveland, OH
    Country:
    United States
    I'm for sure buying a DSi when it comes out.

    Who wouldn't want a DS with 2 cameras?

    And so what, if I buy it, I'll still have my DS Lite to play homebrew and crap,
     
  5. SkyintheSea

    Member SkyintheSea GBAtemp Regular

    Joined:
    Sep 15, 2008
    Messages:
    199
    Location:
    America
    Country:
    United States
    This public forum is intended for users of all ages, please take this into consideration when posting. Please use common sense and don't post explicit profanity, we are not strict on the use of swearing but please show respect for the members of GBAtemp. [​IMG]
     
  6. Zenith94

    Member Zenith94 1337 h4x0r f0r t3h w1nz

    Joined:
    Jul 22, 2008
    Messages:
    825
    Country:
    United States
    ye gyz dont sai dam!
     
  7. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    when my R button got very hard to press nintendo wanted 80$+ just to look at it. i picked up some compressed air like you did. if you pull the button back near the power led is a small hole. get the end up to it and put a ton of air in there. i did it probably 10+ times until it fixed the problem. don't get frustrated and take your time. those micro controller switches are so sensitive to dust =/.

    -another world
     
  8. boojumz

    Member boojumz GBAtemp Regular

    Joined:
    May 12, 2008
    Messages:
    145
    Location:
    the heavens
    Country:
    Canada
    hmm...first my L broke, then a year later, my R broke. both seem to work if i press hard from out in...how would compressed air fix the problem?
     
  9. Dark

    Member Dark GBAtemp Advanced Fan

    Joined:
    Jul 6, 2008
    Messages:
    856
    Country:
    United States
    try blowing in to the botton it always works for me. Usually the dust is messing the botton a few blows might work for you.
     
  10. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    Game controller buttons usually work by having two traces on a circuit board seperated by a small gap. When you press the button, you push a conductor against both traces, completing the circuit and telling the system that the button is being pressed. If there is too much dust or debris between the conductor and the traces it won't make good contact and the button won't work. This can be fixed with compressed air.
     
  11. War
    OP

    Member War Take it easy~

    Joined:
    Oct 26, 2007
    Messages:
    5,409
    Location:
    California
    Country:
    Japan
    Please, let's not turn this into a DSi hate thread, or anything DSi related. I'm just saying, if I have to end up buying a new DS, I might as well buy a DSi.

    Like I said in the first post, I've already tried to blow into the button and it DOES NOT work. Someone said that if I lift up the shoulder button, there should be a small hole... my R button doesn't go up that much, so I don't see a hole at all.
     
  12. Hehe Moo

    Member Hehe Moo Moo?

    Joined:
    Jul 14, 2008
    Messages:
    1,137
    Location:
    Australia
    Country:
    Australia
    My L button was a bit weird for me..

    At first, I just needed to press HARDER.
    Then.. it stopped working altogether.
    However, I could feel it still clicking. It still made a *click click* noise when a pressed it.
    The L button probably screwed up because of over-Metroid Prime Hunters-ing.
    Sometimes the L button would repair itself, and sometimes it wouldn't.
    DO NOT SEND TO NINTENDO!!! I did this, and I paid $30 and they did nothing at all. They told us it "still worked"

    Months passed, and I was missing my L button *sob*
    One day.. I let my brother borrow my DS.

    And the bastard had to go and DROP IT!! He broke the R button. So, I have a retarded L button and a fully broken R button. The inside of the R button had broken off completely, and was therefore unattached to the main part of the DS Lite.

    Boy.. I was angry. But my dad got me a new one. And I gave the retarded one to my brother. We both got TopToys. Eventually, the L button stopped being retarded and works fully now.

    There you go War. Maybe give it some time... but don't put too much force into it.
     
  13. Sticks

    Member Sticks GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    215
    Country:
    Australia
    This is what I did, both on mine and a friend's DS - worked both times.

    Open up the DS, and pull out the plastic Shoulder button for the offending side, be careful of the spring - don't lose it, also note how it's positioned.

    Now once you've pulled out the button, check the conductor pad where the button was pushing against. It should be a little plasticky circle ~2-3mm diameter, it'll make a clicking sound when you push down on it. Now grab a paperclip, straighten it out and carefully jab at the pad from all sides, it'll come loose after a bit and you should be able to move it around - it shouldn't have come out entirely though, if it does just push it back in.

    Replace the shoulder button and spring, make sure that it 'clicks' when you push down on the shoulder button. Replace the back plate and battery and test the button to see if it works. If it does then put all the screws/etc back in.
     

Share This Page