GBA EXploader 0.58X M3 patch

Discussion in 'M3 Adapter' started by cornaljoe, Jan 18, 2009.

Jan 18, 2009

GBA EXploader 0.58X M3 patch by cornaljoe at 6:11 PM (9,113 Views / 0 Likes) 24 replies

  1. cornaljoe
    OP

    Member cornaljoe GBAtemp Advanced Fan

    Joined:
    Jan 13, 2006
    Messages:
    523
    Country:
    United States
    In the recent update of GBAExploader, Rudolph lived up to his word and removed support for M3 Real/Sakura, and iTouch. I've recently found out someone release a patch to remove this block. Does anyone have a link? I can't seem to find it.

    ----------------------------------------------------------------------------------------

    Edit: Lol, man this always happens. As soon as I start a thread after searching for 20 min, I find what I'm looking for! It seems to be in the wrong section of the forums. Well here is the link if anyone else interested.

    GBA Exploader 0.58X - Remove M3 block patch

    *Real edit: Bah, sorry for the double post I guess someone will merge them eventually.
     


  2. Beige

    Member Beige GBAtemp Regular

    Joined:
    Nov 2, 2008
    Messages:
    266
    Location:
    Volcano Bakemeat
    Country:
    United States
    This is good news. If we do his enough, Rudolph may change his mind (doubtful)
     
  3. Maikel Steneker

    Member Maikel Steneker M3 Fanboy

    Joined:
    May 16, 2007
    Messages:
    3,396
    Country:
    Netherlands
    It's not like Rudolph hates M3 users - it's just that he will get into trouble if his software works on M3 hardware.

    This is really great news! Rudolph can just keep making his software, and someone else can remove the protection [​IMG]
     
  4. Minox

    Supervisor Minox Spytech Employee

    Joined:
    Aug 27, 2007
    Messages:
    5,615
    Country:
    Sweden
    What?

    I'm fairly sure that Rudolph created that protection after being threatened to be sued by GBalpha for creating the DLDI-version of M3Sakura. It's not like he's forbidden to create homebrew for the M3 products, he chose that himself after being treated like that to avoid trouble.
     
  5. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom
    @cornaljoe add it to the DOWNLOADS section of the forum too please [​IMG]
     
  6. Sportsmaniac1322

    Member Sportsmaniac1322 GBAtemp Maniac

    Joined:
    Jun 26, 2008
    Messages:
    1,183
    Location:
    Forman's Basement
    Country:
    United States
  7. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom

    thanks [​IMG]

    for some reason the rapidshare link just seems to go round in circles saying the download session has expired!?

    Yet other files from rapidshare are fine!?


    EDIT @Sportsmaniac1322 which version of .58 did you use?? .58,.58a or .58b ? does not seem to work for me just hangs at Initialize ......

    [​IMG]
     
  8. Digital1980

    Member Digital1980 GBAtemp Fan

    Joined:
    Jan 8, 2008
    Messages:
    499
    Country:
    United States
    What does this patch do? Sorry I've been away from the M3 Real world for a while.
     
  9. Densetsu

    Former Staff Densetsu Pubic Ninja

    Joined:
    Feb 2, 2008
    Messages:
    3,435
    Location:
    Wouldn't YOU like to know?
    Country:
    United States
    M3 harassed Rudolph after he created a Sakura DLDI version to run on other flashcarts, so in order to avoid trouble with them, he locked all M3 products out of his homebrew releases. Without the patch, the latest version of GBAExploader won't run on an M3 flashcart.
     
  10. Beige

    Member Beige GBAtemp Regular

    Joined:
    Nov 2, 2008
    Messages:
    266
    Location:
    Volcano Bakemeat
    Country:
    United States
    It allows you to use GBA ExpLoader 0.58 with the M3 Real, because normally you can't. Rudolph did a little exclusion code so we wouldn't have to deal with M3 again due to DLDI Sakura.
     
  11. cornaljoe
    OP

    Member cornaljoe GBAtemp Advanced Fan

    Joined:
    Jan 13, 2006
    Messages:
    523
    Country:
    United States
    Awhile ago Rudolph released a DLDI-patch that allowed users of DLDI compatible carts use M3Sakura as a homebrew. As a response M3 told him to remove the download and stop working on it or they will sue him. In response he decided to block M3 Real/Sakura and iTouch in his future programs/updates. This patch just removes the block on said carts.
     
  12. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom

    which IPS patcher did you use?!

    tried with LUNAR ips patcher and Ipswin and it still hangs at Initialize ....

    hangs with both 3 IN 1 and M3 GBA expansion [​IMG]

    I'm currently using TRIPLE BOOT here and it does the same on all 3 loaders maby that's why!?
     
  13. Densetsu

    Former Staff Densetsu Pubic Ninja

    Joined:
    Feb 2, 2008
    Messages:
    3,435
    Location:
    Wouldn't YOU like to know?
    Country:
    United States
    I'm not sure that it matters which IPS patcher you use, but I use both ips XP and IPS-win. Never had problems with them.
     
  14. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom

    still no luck [​IMG]

    anyone else with the triple loader manage to get this to work??
     
  15. Mbmax

    Member Mbmax Homebrew addicted

    Joined:
    Nov 7, 2006
    Messages:
    2,272
    Country:
    Antarctica
  16. Madridi

    Member Madridi Card Collector

    Joined:
    May 9, 2008
    Messages:
    2,421
    Location:
    Doha
    Country:
    Qatar
    Sorry for such a stupid question, but what do i do with this .ips file?
    I mean, shouldnt I have a .nds file to use this?

    I have 2 versions of GBA exploader on my microSD, an old one that used to support m3 products, and 0.58b which doesnt.
    Would be nice if someone tells me what to do.
     
  17. Densetsu

    Former Staff Densetsu Pubic Ninja

    Joined:
    Feb 2, 2008
    Messages:
    3,435
    Location:
    Wouldn't YOU like to know?
    Country:
    United States
    You need an IPS patcher to apply the patch to GBA Exploader. Try IPS-win or ips XP, they're simple to use.
     
  18. Madridi

    Member Madridi Card Collector

    Joined:
    May 9, 2008
    Messages:
    2,421
    Location:
    Doha
    Country:
    Qatar
    Thanks, I'll try that [​IMG]
     
  19. bfoos

    Member bfoos GBAtemp Fan

    Joined:
    Dec 5, 2006
    Messages:
    328
    Location:
    Upstate, NY
    Country:
    United States
    Kind of useless since it doesn't work if you have the SoftReset.M3DS file on the root of your card. Well, not entirely useless, but you can't use your 3in1 as a RAM pack with .58x.
     
  20. Sumea

    Member Sumea Disco Ninja Frog

    Joined:
    Aug 16, 2008
    Messages:
    1,312
    Location:
    Turku
    Country:
    Finland
    can someone make same for GBA backup tool?

    oh, and to GBA exploader, this failed, hangs in initialize
     

Share This Page