Gateway filesystem error 99% of the time?

Discussion in '3DS - Flashcards & Custom Firmwares' started by joex11, Aug 6, 2015.

  1. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    Hi all,

    Got my 9.2 n3ds and a gateway. So I installed the mset and got everything set up. But when I tried using the gateway card with 3ds files, it gave me this error most of the time. If I try around 50 times to load something via multirom I can load once. Also, sometimes the games shows up in the multirom, but when I press a, nothing happens. And when I finally got xenoblade to work, after 2 minutes I got black screen and force reset. I tried 3 different legit sd cards and most of sd formatters. Do I have a defective gateway card? Can I try anything else?
     
  2. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,921
    1,211
    Aug 20, 2013
    straya m8
    You aren't really supposed to Defragment solid state storage, but have you tried that yet?
     
  3. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Format the card in the exfat format and run it through h2testw do a write+verify test and post the results, also what brand Microsd card is it and how big.
     
  4. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    Ok, I will try defrag and do a h2testw.
    I have 3 sds:
    32gb sandisk - bought at a good store
    4gb toshiba - came with my n3ds
    2gb kingmax - don't know anything about it
    All of them are class 4
     
  5. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Dont defrag it do what I said above you either have a corrupt/dying/fake card.
    Also when your going to pull out the sd card safely eject it by right clicking on it.
     
  6. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    Ok, I just checked for 400mb on toshiba and everything is fine. Now I'm doing a full size check. But I really doubt all my three cards are dying at the same time and when they used to work normally.
    Thanks for the help. Will post the results in a minute

    Edit: 4GB toshiba
    Test finished without errors.
    You can now delete the test files *.h2w or verify them again.
    Writing speed: 11.4 MByte/s
    Reading speed: 18.4 MByte/s
    H2testw v1.4
     
    Last edited by joex11, Aug 6, 2015
  7. Maximilious

    Maximilious GBAtemp Addict

    Member
    2,104
    892
    Nov 21, 2014
    United States
    Never defragment and SSD HDD. They work electrically, not through magnets. You can think of their individual blocks as mini fuses. As you delete files from the drive in your OS, the data actually stays persistent and the drive will write to blocks that have the least amount of passes over them first. When a file is removed via the OS, the drive will simply mark that block as a 0 instead of a 1 showing it can then be written to, but it also knows that block has had not one pass of electricity, but 2 passes (one for file write, another for marking it free), so it will opt for a block that has had 0 passes first over a "free" block even if it's at an earlier part of the drive. The more passes a block has, the higher rate of failure. Blocks that can't handle any more passes will eventually just not work and the drive will look elsewhere.

    You don't want to defragment them because defragmentation causes a whole mess of passes over blocks which will eventually kill off your SSD a lot sooner than expected.

    FYI - As of Windows 8, the OS knows if it's installed on an SSD verse a traditional HDD, so it will automatically turn off scheduled defragmentation for the drives that are SSD.

    And sorry if that explanation is long winded or may not make total sense. It's kind of hard to convey!
     
    ChaosEternal and Quantumcat like this.
  8. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Ok now put 2 simple 3ds roms that fit on that 4 gig card remember to format the Microsd card in the exFAT format and to safely eject the Microsd card by left clicking the drive its in then enter the gateway menu and do a diagnostic test with the red card in and tell me if it fails any tests.
     
  9. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    I did that yesterday and I got error on SD Test. And then one time I got an ok on the 4gb card, which I used to do the mset thing. I always eject my rom cards too.
    I will test once again and post here

    EDIT: Yep, sd fail once again
     
  10. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Post the h2testw results of the 32 gig card and the results of the gateway test if the card passes h2testw.
    post the entire h2testw log not a snippet
     
  11. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    DOing that now. It will be around 1-2 hours until it completes.
    Just now my 4GB was read normally but gateway. I really don't know whats going on anymore.
     
  12. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    im so sorry I forgot to mention something stop the h2testw test and format the 32 gig card using sd formatter 4 (in the options menu select format type full erase and format size adjust on) THEN run the card through h2testw.
     
  13. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    I will check if it works once again, since my 4gb started working and I don't know why since I didn't do anything different. If it doesn't, I'll upload the results
     
  14. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    dont forget to select write+verify in h2testw before running the test :P
     
  15. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    The 4GB that was working just now isn't working anymore, giving me the same error. I'll do the test, in 2 hours I'll post here

    EDIT: Flash erase was cancelled because it's not supported by the device?
     
  16. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Ok but it sounds like you may have a faulty gateway card to be honest but once I see the results of the 32 gig and you format it again in the exFAT format and place 2 simple roms from 'that" iso site we will know for sure.

    — Posts automatically merged - Please don't double post! —

    Thats fine it just doesnt support it you can continue to h2testw with the write+verify test.
     
  17. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    Done, here it is:

    Test finished without errors.
    You can now delete the test files *.h2w or verify them again.
    Writing speed: 4.91 MByte/s
    Reading speed: 18.4 MByte/s
    H2testw v1.4

    I can't find the log you mentioned anywhere, not even in the h2 folder...
     
  18. tyons

    tyons GBAtemp Advanced Fan

    Member
    642
    97
    Jul 11, 2012
    Italy
    here's a possible solution: put some paper between the gateway card and the card slot, so that it is pressed more tightly against the console. source: I have a gateway card with the same problem (it has been opened and repaired before that, though) and that's the only way I can manage to play with .3ds roms.
     
  19. joex11
    OP

    joex11 GBAtemp Regular

    Member
    179
    58
    Dec 2, 2013
    Brazil
    i'll check it right away and let you know if it worked. thanks

    edit: tried that some times and still not working. the paper was really tight but still same error.
     
    Last edited by joex11, Aug 6, 2015
  20. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,124
    3,422
    Nov 13, 2014
    United States
    Yeah you should RMA it its a faulty gateway card bummer.