Games crashing

Discussion in 'Switch - Console, Accessories & Hardware' started by sharaku17, Sep 4, 2018.

  1. sharaku17
    OP

    sharaku17 Member

    Newcomer
    2
    Nov 16, 2016
    Germany
    So i have been asking around the forum the last few days, im sure some of you already saw it, as i could not fix the problem i think a own thread is necesarry to discuss this.

    I have been trying to fix a switch console the past few days without any luck.
    I bought a switch which was specified as having a faulty game card reader.
    After getting the switch I noticed that cardridges inserted in the switch are recognized and I can start them but 4 out of 5 times the game crashes right away with the following error „the software was closed because of an error“
    But 1 out of 5 times the game actually plays. I can’t say if it might crash at a later point in the game.
    (this happened with Xenoblade cardridge) ( fifa 18 as a cardridge happens to play 4 out of 5 times)

    So to find out if it was really the card readers fault I loaded hekate and made a backup and then loaded ReiNX with some nsp I got from cdnsp
    What I found out is that a few games like Celeste,hollowknight and super Mario tennis play just fine without any problems at all
    But a bunch of other games have the exact same behavior as with the legit cardridges and they keep crashing at the start with the same error
    I tried RajNX afterwards to make sure it is not caused by the cfw but it’s the same behavior.

    I don’t know what other hardware could cause this type of effect apart maybe from some memory reading or smth.
    I have also tried to downgrade to fw 5.0.2 with ChoiDujourNX and then update to 5.1.0 to have a clean firmeware in case the software in the switch was somewhat corrupted as i thought it could be software related and some partition on the NAND is corrupted, but it didnt fix the problem aswell
    My last idea is to take my other switchs working RawNand dump and inject the faultys switch biskeys into that Nand dump and then restore it on the faulty switch. But im not sure how to do that or if it would be unnecessary as doing the firmware updates with ChoiDujourNX does maybe the same?
    Im not to sure about this.
    Has anyone else maybe just a slight guess what could be the cause for this weird behavior?
     
Loading...