Games and apps missing after upgrading microSD card

Discussion in '3DS - Flashcards & Custom Firmwares' started by t1op, Jul 6, 2018.

  1. t1op
    OP

    t1op Member

    Newcomer
    1
    Nov 13, 2016
    United States
    I have a New 3DS XL. I am on 11.5.0-38U. I have boot9strap and godmode9 both successfully installed.

    It came with a 32 GB micro SD. I was running out of room, so I decided to upgrade cards.
    I moved all of the data to a 64GB card, but, even though formatted to FAT32, the 3DS wouldn't read it.
    So I copied everything to hard drive. I tried to format to FAT32 again. Couldn't. Said the drive was in use.
    So I formatted to NTFS. Then I formatted to FAT32 successfully and the 3DS could read it. I copied everything back to the 64GB card.

    Now when I boot up, all games except 3 DSiware games are missing.
    The Homebrew Channel and other homebrew are gone, except TWL Slot-1 Launcher.
    FBI/Safety Warning also doesn't work.

    What went wrong? Is there a way to get everything working again without starting from scratch?
     
  2. TurdPooCharger

    TurdPooCharger Brush your teeth.

    Member
    5
    Jan 1, 2018
    United States
    1. Reformat the 64 GB card to FAT32 + 32 KB using guiformat.
    2. With nothing on the card, check using H2testw in a Full Write + Verify test.
    3. Report back what your result states. Take a screenshot if you're not sure how to interpret what it means.
    Edit - Do the test anyway. The DSiWare games are installed on your SysNAND (internally on the 3DS) or EmuNAND (which is emulated) on the SD card if one was setup.
     
    Last edited by TurdPooCharger, Jul 6, 2018
  3. t1op
    OP

    t1op Member

    Newcomer
    1
    Nov 13, 2016
    United States
    Thanks for the attempt. Didn't help, though. Tried two cards. Same problem. Nothing wrong with the cards.
    I did get things working again, though.
    On one of them I copied everything but the Nintendo 3DS folder. I inserted it and let the system create a home management folder. I copied everything but the management folder back on. Then I copied the files from the old management folder into the new one and everything came back, although outside of the created folders.
     
  4. Quantumcat

    Quantumcat Dead and alive

    Moderator
    18
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    Sounds like you had corrupted home menu data