forcing maintain aspect ratio in newer games

Discussion in 'Computer Software and Operating Systems' started by link491, Nov 11, 2012.

  1. link491

    link491 GBAtemp Fan

    Mar 17, 2010
    alright, I feel like an idiot having to ask here, because it seems so simple, but i can't figure this out. so, pretty much, my computer sucks. its a compaq cq56 laptop. the specs are:
    amdv140 processer
    3 gb ram
    amd hd4000 integrated graphics (im pretty sure)
    so by some miracle, i can run games such as skyrim, dishonored and civilization 5 on this thing. but they all have the same problem, they stretch the aspect ratio. (im running them all in 640x480 resolution, on a 1366x768 monitor) so i wanna know, is there any way to force an aspect ratio, like in older games, so that the graphics aren't stretched? what im saying is, i want those ugly black bars on the sides of the screen.

  2. Guild McCommunist

    Guild McCommunist (not on boat)

    May 6, 2009
    United States
    The Danger Zone
    It's a common problem for me as well, 1366x768 is just an odd ratio it seems. Pain in the ass finding wallpapers as well.

    So if there's a solution to this, I'd also be eager to know.
  3. gifi4

    gifi4 How am I a 'New Member'?

    Apr 21, 2010

    There's a filter for sketchy wallpapers as well and if you create a free account, you can get NSFW as well.

    Also, about the other issue, Not a clue... Maybe there is some sort of program that can do it for any game, who knows...
  4. FAST6191

    FAST6191 Techromancer

    pip Reporter
    Nov 21, 2005
    United Kingdom
    Usually people want to go the other way but what you want is perfectly valid. For the people wanting proper widescreen games we usually direct them to places like which I will also do here as the tweaks (hidden startup commands, ini options and such) to make things work for widescreen/multiscreen usually cut the other way and can help you here.

    I will also say consider trying for resolutions like 860 x 480 or so as it will probably not tax the processor hard enough to trouble it.

    Also for skyrim at least (other games are not always so lucky) there are things like so you might not be locked to such a low res anyway.
  5. DCG

    DCG GBAtemp Advanced Fan

    Jan 1, 2010
    You could also take a bigger wallpaper and cut it down to the propper size (using paint or etc.).
    That's how I do it if something isn't the propper size.
    (my sig for example, I cropped it to match the with and then cut of parts of the top and botom (... gonna change my language settings...))
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    Oct 27, 2002
    Engine room, learning
    some video cards allows per-game settings, adding black bar to the side of the screen to maintain aspect ratio for old games on new monitors.
    my video card setting doesn't seems to have that option (only per-game 3D settings, but no aspect ratio).

    I found on a forum this setting for Nvidia cards:
    It's in french, but it translate to "size of the desktop" -> "do not resize".
    The help shows "The screen will not be resized. the picture will be centered on screen with black bars around"
    I didn't test it.

    Maybe other card manufacturer have a similar setting.
    raulpica likes this.
  7. Minox

    Minox Thanks for the fish

    Former Staff
    Aug 27, 2007
    This is how it looks like in the latest Nvidia drivers:

    Though that does not help in this case since it's AMD in question. Personally I have no idea if there's an equivalent setting for aspect ratio and scaling in AMD's drivers.
  8. jagerstaffel

    jagerstaffel GBAtemp Advanced Fan

    Aug 20, 2008
    United States
    If you're using AMD Vision Engine (Catalyst Control Center), look at My Built-in Displays -> Properties. The older AMD control center should have it listed per game as "Scaling options", in this case try to set a profile for that game.
  9. marcus134

    marcus134 GBAtemp Advanced Fan

    May 7, 2011
    i'm pretty sure skyrim has something like that:[​IMG]
    (like any other games that runs on pc)
    If it's about performance, you can always try to set a custom resolution (683*384, 16:9 ratio, 4:1 stretch on your screen) or you can play it windowed so it doesn't get stretched.
  10. Arm73

    Arm73 GBAtemp Addict

    Mar 4, 2006
    OK , this should be very easy.
    No need to hacks or tricks.
    On an integrated graphic car ( I have an intel 3000 and an nVidia 540m GT in my laptop ) you just check the icons in the lower right corner of your taskbar.
    Most likely you have 3 or 4 and the rest are hidden.
    Click the little arrow if this is the case, and find the icon representing your integrated video card.
    Right click on it, and go to Graphic proprieties.
    By the general setting tab, you should find a setting for " scaling ", and that could be set to " center image ", " scale to full screen " and " maintain aspect ratio ".
    Now if you have a wide screen resolution ( like 1360x 768 ) you won't be able to see the " maintain aspect ratio " setting.
    However if you adjust it to a 4:3 resolution such as 1024x768, and you choose to " maintain aspect ratio ", then you'll see black bars on either side of the screen and the image won't be stretched .
    Remember such setting aren't usually in the game settings, you need to adjust it while on the desktop.
    Once the change is made, you can properly play the game in 4:3 at the given resolution.
    Hope it helps.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice