FMCB on slim?

Discussion in 'Sony PlayStation 1 & 2' started by serenade.63, Nov 10, 2011.

Nov 10, 2011

FMCB on slim? by serenade.63 at 11:14 PM (1,156 Views / 0 Likes) 9 replies

  1. serenade.63
    OP

    Member serenade.63 GBAtemp Fan

    Joined:
    Apr 17, 2011
    Messages:
    419
    Country:
    United States
    I read that there is a newer version of FMCB that works on all models of ps2's including the newer slim ps2's. Is this true, the tray in my old ps2 is broken and is eating my discs, so i want to get a slim one
     
  2. Nujui

    Member Nujui I need something to do.

    Joined:
    Aug 12, 2010
    Messages:
    3,933
    Location:
    Dreamland.
    Country:
    United States
    Could you post a link to where you've heard that? I've haven't seen any FMCB that's working on the new ps2s.
     
  3. serenade.63
    OP

    Member serenade.63 GBAtemp Fan

    Joined:
    Apr 17, 2011
    Messages:
    419
    Country:
    United States
    http://psx-scene.com...nstaller-96372/

    somewhere in the first post it says "all systems are supported"

    even if it isn't true, since I already have an FMCB memory card could I purchase a slim ps2 (pre march 2008 of course, scph-7xxxx) would It still work? or no?
     
  4. Armadillo

    Member Armadillo GBAtemp Psycho!

    Joined:
    Aug 28, 2003
    Messages:
    3,108
    Country:
    United Kingdom
    I believe the all consoles supported in that post means it supports all exploitable consoles (fat/slim, different regions), not that it works on the latest slims. As for your current fmcb, depends, if it was a multi-version install, it should work fine, if it was a normal install, then it won't.
     
  5. serenade.63
    OP

    Member serenade.63 GBAtemp Fan

    Joined:
    Apr 17, 2011
    Messages:
    419
    Country:
    United States
    sorry, im a noob, difference between multi version and normal?
     
  6. Magsor

    Member Magsor I am watching you

    Joined:
    Dec 1, 2010
    Messages:
    959
    Location:
    Amos
    Country:
    Canada
    Yes if you get a pre-2008 PS2 (99.99% of ps2 XD) it will work. multi-version refers to regions not console models.

    but...

    i would advise you to keep you good ol' ps2 and get a network adapter instead. You can then install your games on a hard drive ; you can never do that on a slim and the compatibility is very high (higher than ESR).
     
  7. serenade.63
    OP

    Member serenade.63 GBAtemp Fan

    Joined:
    Apr 17, 2011
    Messages:
    419
    Country:
    United States
    I've been using opl v.8, but the compatibility isnt great and cut scenes are choppy, i didnt have that problem with discs before the tray broke.
     
  8. Magsor

    Member Magsor I am watching you

    Joined:
    Dec 1, 2010
    Messages:
    959
    Location:
    Amos
    Country:
    Canada
    By using a hard drive i meant internal(IDE) not USB
     
  9. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    The normal install will only work on your ps2, and other ps2s with the same version and region. The multi install works on more(all?) supported ps2 models, and the latest achievement is that it also works for all regions now.

    With Open PS2 Loader, you need to tell which way you are loading the games. I personally see it as an internal HDD and LAN loader, and the usb is just useless bonus. When loading games via LAN, there's still some lag, but much less than you get with usb loading.
     
    1 person likes this.
  10. jinnpan

    Member jinnpan GBAtemp Regular

    Joined:
    Jul 22, 2010
    Messages:
    179
    Country:
    United States
    I have been installing FMCB and it works on all regions phat and slim [up 7500x]
     

Share This Page