1. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    It worked flawless for me even I never used linux before. Thx OP!
     
  2. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    @Crystallseed Can you make this app for joy-cons also? Or is there a app like this exist?
     
  3. Brando72

    Brando72 Member
    Newcomer

    Joined:
    Sep 3, 2019
    Messages:
    22
    Country:
    Canada
    is this still confirmed to work? is there a more modern method?
     
  4. SomeGamer

    SomeGamer GBAtemp Guru
    Member

    Joined:
    Dec 19, 2014
    Messages:
    6,776
    Country:
    Antarctica
    I think Hekate now does this at every boot.
     
  5. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    İ
    Its just a paylod bro, just send via tegra rcm and done, ita fixed its easy. This payload dont need any update i think. So its enoug modern.
     
  6. ritchiedonovan

    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    6
    Country:
    Noob needing help from the resident geniuses at gbatemp!

    So I use sxos and and hadn't used my switch for a few months. I turned it on today and the battery was all over the place - said it was at 79% when it was practically at 0%. I charged it for 3 hours (it was on 100%) for a couple of hours and then removed the charging cable. It is taking a long time for the battery to go down - it's at 92% and I've had it on for over an hour. So I think this battery fix might be what I'm looking for? Is there an easy way to do it via SXOS? As I said I am pretty hopless at these sorts of things so any advice greatly appreciated!
     
  7. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    Just send this payload, it wont break anything and probably fix the issue.
     
    ritchiedonovan likes this.
  8. ritchiedonovan

    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    6
    Country:
    Thanks for the reply! I use the dongle to enter sxos - is there a way to use this fix with sending the payload without hooking it up to a pc?
     
  9. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    I dont know about sx os, never used it but if i remember correctly, payload on dongle should be changeable. Search for that..
     
    ritchiedonovan likes this.
  10. gnmmarechal

    gnmmarechal GBAtemp Guru
    Member

    Joined:
    Jul 13, 2014
    Messages:
    5,758
    Country:
    Portugal
    I don't think that's the case. The SX Pro is hardcoded to launch the boot.dat. Now, you can use the SX Gear boot.dat and load something else, buut yeah.
     
  11. ritchiedonovan

    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    6
    Country:
    Thanks for the help guys, I managed to fix it (I think) by doing what Nintendo suggested (charging for 4 hours, letting it drain on the home screen etc) and it seems okay now.
     
    whateverg1012 likes this.
  12. whateverg1012

    whateverg1012 Fringe Weaver
    Member

    Joined:
    Sep 23, 2016
    Messages:
    521
    Country:
    United States
    Is it safe to use this while autorcm is enabled?
     
  13. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    Sure.
     
    whateverg1012 likes this.
  14. nero99

    nero99 GBAtemp Addict
    Member

    Joined:
    Sep 18, 2014
    Messages:
    2,801
    Country:
    United States
    you don't need to use this anymore. hekate has has this coded into it for quite a while now.
     
  15. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    Nope, I fixed my problem with only this payload. Hekate dont work for me.
     
    whateverg1012 likes this.
  16. whateverg1012

    whateverg1012 Fringe Weaver
    Member

    Joined:
    Sep 23, 2016
    Messages:
    521
    Country:
    United States
    How exactly did you use this? I injected this payload but my battery is still not fixed (still shuts off at around 40%), do I inject this payload when my battery reports to be at 100% or when it's at 40%?
     
  17. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    My problem was this; My battery shows wrong percent, still I can play rougly 3 hours but switch battery dies at 50, than 75, than 90 etc. I send this payload and resetted the battery stats and back to normal. What is your switchs problem? Also I think you just need to send payload, no need to charge.
     
  18. whateverg1012

    whateverg1012 Fringe Weaver
    Member

    Joined:
    Sep 23, 2016
    Messages:
    521
    Country:
    United States
    I can also play around 3ish hours in handheld but my switch dies somewhere between 40-45% (so my battery is showing the wrong percent)

    I sent this payload but it still dies around that point. The payload was sent properly because my clock got reset which indicated that it worked.

    I've basically given up at this point though, just gonna accept that 40% is my new 0% now. Hoping it will fix itself over time.
     
  19. TR_mahmutpek

    TR_mahmutpek medic
    Member

    Joined:
    Jul 28, 2015
    Messages:
    1,287
    Country:
    Turkey
    Interesting. It worked for me but on nearly impossible levels. I mean switch battery shows 100 or 99 but its actually 0 or 1 (yes!) and it cant charge itself because it reads battery 100 and rejects electricity i think. I sent this and worked. Showed 0 and charged normally. Maybe you should wait for worse percent :D or ask op, Ctcaer.

    Oh, alternatively, you can dissasembly and eject switch battery manually, which this payload does that but you can try if you want. So maybe maybe will work.

    Hope you will fix issue soon.
     
    whateverg1012 likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Battery, Linux, issue