[firmware hack] Multiple firmwares on one micro SD

Discussion in 'EZ-Flash' started by opearn, Jun 9, 2009.

?

What can you do in 1.86 that no longer works in beta 11?

  1. Watch DPGs (Movie Length)

    0 vote(s)
    0.0%
  2. Listen to long audio streams

    0 vote(s)
    0.0%
  3. Play certain games (e.g Korg)

    0 vote(s)
    0.0%
  4. Other

    0 vote(s)
    0.0%
Multiple votes are allowed.
  1. opearn
    OP

    Newcomer opearn Advanced Member

    Joined:
    May 27, 2008
    Messages:
    50
    Country:
    Australia
    hello everyone,
    i have just hacked the 1.86 firmware so it can be on the same micro sd as 1.90 beta 11 (or any other version),

    The Reason:
    Beta 11 is unstable but can run newer games,
    1.86 is stable but can't run newer games,

    How it works:
    The ez5sys.bin is for all purposes a .nds file,
    So i hacked it and changed the folder it thinks moonshell is in.

    To install:
    Download the firmware.
    copy ez5sys.bin.nds and moonold into the ROOT of your micro sd

    To use:
    Simply run ez5sys.bin.nds from the root of your flashcart.

    Future goals:
    A ez5sys.bin that allows you to choose between firmwares on your cart.

    Warning:
    Please use only with 1.90 beta 11, all other firmwares are untested and use on other firmwares may or may not brick your flashcart.

    NOTE: the poll above is to get the idea about other peoples experiences with beta 11.
    personaly i like it, but it won't play DPGs or Run Korg.
    -opearn
     
  2. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,727
    Country:
    United Kingdom
    Nice work, I had toyed with the idea of this before but never got around to putting things in code. It might also be worth a look to see if you can do the same for the even older savelist using kernels (they frequently do not have a problem with new games due to the way they work).

    I am back on 2.0 now but I can not recall KORG stopping working when was on the 1.9 line.

    Moonshell, I can not recall if I was on 1.9 at the time (I rarely updated) but there was a problem with some of the later moonshell betas and the EZ5 that should have been sorted by now.
     
  3. opearn
    OP

    Newcomer opearn Advanced Member

    Joined:
    May 27, 2008
    Messages:
    50
    Country:
    Australia
    I couldn't even get v2.0 (second version) to run, (i didn't try the first)
    i think my card might be a fake, and i paid a fair amount of money for it.
    which might cause some things to stop working.
     
  4. DSGamer64

    Member DSGamer64 Canadian, Eh?

    Joined:
    Nov 9, 2007
    Messages:
    2,931
    Location:
    A cold cold place
    Country:
    Canada
    2.0 works perfectly on mine, aside from some games crashing here and there things are dandy. Why would you even bother hacking old firmware that is redundant and slow?
     
  5. opearn
    OP

    Newcomer opearn Advanced Member

    Joined:
    May 27, 2008
    Messages:
    50
    Country:
    Australia
    apparently 2.0 lacks the features of the older 1.86 kernal,
    it wouldn't even boot on my V+ though.
     
  6. Islay

    Member Islay GBAtemp Fan

    Joined:
    Dec 15, 2008
    Messages:
    308
    Country:
    Ireland
    because the 2.0 wont even boot a game for some people.

    p.s:
    does this work on the DSi ? as 1.9 11 beta just lag sound wise on movies, and 2.0 is useless at the moment for me.
     
  7. DSGamer64

    Member DSGamer64 Canadian, Eh?

    Joined:
    Nov 9, 2007
    Messages:
    2,931
    Location:
    A cold cold place
    Country:
    Canada
    Then most likely those cards are either fake or defective.
     
  8. opearn
    OP

    Newcomer opearn Advanced Member

    Joined:
    May 27, 2008
    Messages:
    50
    Country:
    Australia
    2.0 dosn't run most homebrew games i've tried, it dosn't play music, it basicly only runs ILLEGAL games.
     
  9. karnik95

    Newcomer karnik95 Member

    Joined:
    Aug 11, 2008
    Messages:
    26
    Country:
    Australia
    Where did you buy it from?

    I got mine from Singapore and 2.0 works on mine.
     
  10. Drag0nflamez

    Member Drag0nflamez GBAtemp Regular

    Joined:
    Jun 20, 2009
    Messages:
    231
    Location:
    127.0.0.1
    Country:
    Netherlands
    I shouldn't try it on my Vi.
     
  11. karnik95

    Newcomer karnik95 Member

    Joined:
    Aug 11, 2008
    Messages:
    26
    Country:
    Australia
    Just out of curiosity, what software did you use to hack the firmware?
     

Share This Page