Firmware 5.1.0

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by awaawaawa73, Aug 7, 2018.

  1. awaawaawa73
    OP

    awaawaawa73 Member

    Newcomer
    2
    Jul 31, 2018
    Italy
    It is safe firmware 5.1.0??

    Somewhere I read that firmware block Homebrew.

    Someone can confirm please??
     
  2. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
  3. Nononoki

    Nononoki Advanced Member

    Newcomer
    3
    Jan 31, 2012
    Gambia, The
    Short answer: If your firmware is <=4.1.0 don't update. Otherwise just update!
     
  4. Serfrost

    Serfrost GBAtemp Fan

    Member
    3
    Jan 7, 2015
    United States
    • You can use ChoiDujourNX on any firmware to update to 5.1.0 or other without burning fuses.
      • Updating is safe as long as you use AutoRCM, which means you will have to boot using a payload over USB from PC or Android Phone (that supports it.)
        • You can downgrade as long as your fuses meet the requirement for that firmware.
        • Before you downgrade, always System Initialize/Format or you'll get a bootloop.
    • When updating, you update your gamecart slot unless you use nogc (which disables your cart slot altogether.)
      • This means you can keep using carts on lower firmware if you feel that is necessary
    • You can add the nogc option to some CFWs but research is necessary there; some do not support it or do it differently.
      • Currently, RajNX lets you add it to the rajnx_ipl.ini and it also doesn't hang for 10 seconds like on other CFWs.
    You can go without AutoRCM but only if you're comfortable booting manually with a jig. And if you boot stock on accident, you burn your fuses and then you can't downgrade.
     
    Last edited by Serfrost, Aug 7, 2018
  5. rahaat

    rahaat Member

    Newcomer
    2
    Dec 17, 2016
    u can use homebrew on 5.1.0
     
  6. BaamAlex

    BaamAlex GBAtemp Advanced Fan

    Member
    3
    Jul 23, 2018
    Germany
    You can safely update. Homebrew works on 5.1.0. I tested it yesterday.
     
  7. awaawaawa73
    OP

    awaawaawa73 Member

    Newcomer
    2
    Jul 31, 2018
    Italy
    I have 4.0.1 but I do not understand why not update....

    Now I use switch only for backup NAND and probably if I update to 5.1.0 I can do online without ban.

    If I do not update and I use some game I can not update online or my switch will ban.

    The problem is if some game goes out with a new firmware if I remain in a lower one I will can not run it....

    I’m so confused.....
     
  8. Thetoto

    Thetoto GBAtemp Advanced Fan

    Member
    5
    May 10, 2018
    France
    Simple. Update without burning fuses, so you can downgrade when you want.

    <= 4.1 is only for a unreleased soft exploit
     
  9. awaawaawa73
    OP

    awaawaawa73 Member

    Newcomer
    2
    Jul 31, 2018
    Italy
    And how??
    What are fuses??
     
  10. Thetoto

    Thetoto GBAtemp Advanced Fan

    Member
    5
    May 10, 2018
    France
    http://switchbrew.org/index.php?title=Fuses#Anti-downgrade
     
Loading...