Finding SNES and NES Emulators for Wii that dont lag?

Discussion in 'Wii - Emulation and Homebrew' started by Jellyman8, Aug 11, 2012.

  1. Jellyman8
    OP

    Newcomer Jellyman8 Newbie

    Joined:
    Aug 8, 2012
    Messages:
    1
    Country:
    United States
    So for a year now ive been trying to find out why SNES9x and FNES have lag - press a button and the action happens half a second later - making it impossible to enjoy nearly any game.

    But ive been reading on here that these two emulators are known to lag? Are there any emulators for SNES or NES that dont lag?

    Im new here so i apologize if this is all old news.......i went back a few pages and couldnt find anything on this topic.

    THanks so much!
     
  2. Luigi2012SM64DS

    Banned Luigi2012SM64DS G-old member

    Joined:
    Aug 27, 2011
    Messages:
    2,060
    Location:
    Minecrapt
    Country:
    Canada
    Are you sure you don't have old versions?
    on my wii i don't have input lag.
     
  3. the_randomizer

    Member the_randomizer The Temp's official fox whisperer

    Joined:
    Apr 29, 2011
    Messages:
    17,325
    Location:
    Unknown
    Country:
    United States
    Doesn't happen on my end, are you using a Gamecube controller, Classic controller, etc? If you're using a third party controller, that might be why. As far as there being other Snes/Nes emulators for the Wii, there aren't any others. Tantric fixed any lag-related issues, but I could be wrong. Hopefully he'll see this thread and provide better info than I did.

    Using Snes9xGx 4.2.9
     
  4. bradzx

    Member bradzx x-Darkie-x

    Joined:
    Sep 19, 2009
    Messages:
    1,936
    Location:
    Ponyville
    Country:
    United States
    It look fine to me when I use it.
     
  5. Clarky

    Member Clarky Don't you know who I think I am?

    Joined:
    Oct 4, 2007
    Messages:
    1,960
    Country:
    United States
    If you are not happy with the homebrew side of things, there is always the Virtual Console
     
  6. Devante

    Member Devante Crescent fresh at best.

    Joined:
    Nov 29, 2002
    Messages:
    1,212
    Country:
    United States
    Just letting you know I've tried GBA, SNES, NES, and Genesis with a Classic Controller Pro and the Wiimote... AND a third part Wiimote (by Memorex) and they all work perfectly.
    I'm thinking it has something to do with your mod on the Wii.

    I'd try to resync the controller a few times.

    Emulators I use are VBAGX, SNESGX, um... forgot the rest at the moment ha. Whatever the GX ones are.
     
  7. Fishaman P

    Member Fishaman P Speedrunner

    Joined:
    Jan 2, 2010
    Messages:
    3,174
    Location:
    Wisconsin
    Country:
    United States
    Both emulators were VERY recently updated to remove that lag. Please make sure you're using the latest versions.
     
  8. Centrix

    Member Centrix Stop Poking the Moogle!

    Joined:
    Aug 28, 2008
    Messages:
    888
    Location:
    Seattle,WA
    Country:
    United States
    I have never had any lag problem with either of those emulators they both work perfectly for them most part its the GBA emulator I'm having problems with but I found out that apparently the Wii isn't powerful enough to handle the GBA at full speed (bull shit is what I have to say to that, that has to be a joke!)
     
  9. deshayzilla

    Member deshayzilla GBAtemp Regular

    Joined:
    Sep 29, 2011
    Messages:
    288
    Country:
    United States
    It could be your TV. Some HDTVs have some lag because they're processing the upscale of the Wii.
     

Share This Page