1. Dave_Chad

    OP Dave_Chad GBAtemp Advanced Fan
    Member

    Joined:
    Jun 29, 2016
    Messages:
    699
    Country:
    Just wondering if anyone has it working correctly yet? Not seen confirmation, only of the partition based one.

    I have emummc.kip in the atmosphere folder. I have emummc folder with my nand files in. (boot0, boot1 and 00) I have emummc.ini with,

    [emummc]
    emummc!emummc_enabled = 1
    emummc!emummc_path = atmosphere/emummc
    emummc!emummc_id = 30

    I have booted Hekate and done the fix archive bit part too.

    I just boot into standard nand.

    EDIT: I am aware they said wait so i don't need telling that...this is a hobby i find it fun.
     
  2. Shadow#1

    Shadow#1 Wii, 3DS Softmod & Dumpster Diving Expert
    Member

    Joined:
    Nov 21, 2005
    Messages:
    8,876
    Country:
    United States
    Just wait
     
  3. Dave_Chad

    OP Dave_Chad GBAtemp Advanced Fan
    Member

    Joined:
    Jun 29, 2016
    Messages:
    699
    Country:
    Thank you for your well thought out and informative reply. My simple question was answered. :rolleyes:
     
  4. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer
    Developer

    Joined:
    Jul 23, 2012
    Messages:
    8,031
    Country:
    United States
    I'd be on board with doing emummc using a "files and folders" method instead of one huge partition/one huge file. The DSi and Wii useds files and folders, so I'm sure the Switch can too.
     
    switchnell and MUDD_BR like this.
  5. Muxi

    Muxi GBAtemp Advanced Fan
    Member

    Joined:
    Jun 1, 2016
    Messages:
    529
    Country:
    Germany
    I hope it's ok that I put my request here, since it's about the file based emuMMC.

    It should be possible by now to create a file based emuMMC via Hekate, which is nearly as fast as the partition variant. I already use a partition emuMMC, but I wanted to test it anyway. Are there any requirements for booting this emuMMC? Because when I tried to boot it via fusee-primay (AMS 0.13.0) it ends up in a black screen with strange characters. I had experienced something similar with AMS 0.12.0 before, but here the emuMMC up to FW 8.1.0 was still booted (very slowly) and with higher FW versions it came to a black screen. Or can this emuMMC only be booted via Hekate?

    Short summary:

    file based emuMMC FW 10.0.4 created via Hekate v5.2.1 --> cannot be booted via fusee-primary (AMS 0.12.0) ---> black screen

    file based emuMMC FW 10.0.4 created via Hekate v5.3.0 --> cannot be booted via fusee-primary (AMS 0.13.0) ---> black screen witch strange characters

    partition emuMMC FW 10.0.4 created via Hekate v5.2.1 / v5.3.0 --> can be booted without problems via fusee-primary (AMS 0.12.0 / 0.13.0)
     
    Last edited by Muxi, Jun 16, 2020
  6. tataniko

    tataniko GBAtemp Regular
    Member

    Joined:
    Jul 20, 2016
    Messages:
    113
    Country:
    Antarctica
    @annson24 & @Muxi

    This works well for fast file based emuMMC.
    Check it yourself.
     

    Attached Files:

    annson24 likes this.
  7. Muxi

    Muxi GBAtemp Advanced Fan
    Member

    Joined:
    Jun 1, 2016
    Messages:
    529
    Country:
    Germany
    Thanks, but isn't that the data of the official AMS release of v0.12.0? If I go by the version number, this is the same one I used (before v0.13.0).
     
  8. tataniko

    tataniko GBAtemp Regular
    Member

    Joined:
    Jul 20, 2016
    Messages:
    113
    Country:
    Antarctica
    The officials don't work yet. This is a fork of AMS 0.12.0, fusee-secondary by Kronos2308, which is working. I use it on firmware 10.0.2 for fast file based emuMMC. At least, this works on 10.0.2.
     
    Last edited by tataniko, Jun 18, 2020
  9. annson24

    annson24 The Patient One
    Member

    Joined:
    May 5, 2016
    Messages:
    1,164
    Country:
    Philippines
    @tataniko I believe this build is prior to the v0.13.0 but after the commit on the new emummc driver, correct? If so, this would be good for the time being until a fix has been made on the official build.

    @Muxi replying to your post about ams v0.12.0 not booting file-based emummc; I believe it does boot the emummc, it's just super slow that it will take a few minutes before showing the nintendo logo.
     
  10. Muxi

    Muxi GBAtemp Advanced Fan
    Member

    Joined:
    Jun 1, 2016
    Messages:
    529
    Country:
    Germany
    This was the case with ams up to and including v0.12.0 and only up to a file based emuMMC on FW 8.1.0. Everything beyond that I could not boot. A retry of the setup under Hekate 5.3.0 and subsequent booting via fusee-primary (ams 0.13.0) resulted in a black screen with strange characters on the right side of the screen. This emuMMC was created from a sysMMC on FW 10.0.4.

    However, this emuMMC can be booted via Hekate and is also nearly as fast as the partition variant, but it does not work via fusee-primary. The composition of my CFW still requires booting via fusee-primary, otherwise I could just boot via Hekate.
     
    Last edited by Muxi, Jun 17, 2020
  11. tataniko

    tataniko GBAtemp Regular
    Member

    Joined:
    Jul 20, 2016
    Messages:
    113
    Country:
    Antarctica
    Yes, that build has the new fast FS for file based emuMMC, I use it for a month via fusee-primary. I created a reduced size (4gb user partition) file based emuMMC from NAND backup with NxNandManager by eliboa. It works very well.
     
    tiliarou likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - EmuMMC, Based,