FBI takes hours to install CIAs

Discussion in '3DS - Homebrew Development and Emulators' started by toshineon, Mar 15, 2016.

  1. toshineon
    OP

    toshineon Member

    Newcomer
    13
    4
    Nov 1, 2012
    First of all, excuse me if this isn't the right place to post this, but I couldn't figure where else this would fit.

    Anyways, like the title says, FBI takes hours to install CIAs on my 3DS. I installed a 1.5 GB CIA last night, and it took almost 12 hours for it to finish. I'm sure this isn't normal, as I've installed larger ones before that only took about 30 minutes.

    I'm using an o3DS with 9.2 sysNAND and 10.6 emuNAND with CakeFW. My memory card is a SanDisk microSD 128GB SDXC class 10. I know the memory card might be a little overkill in terms of class, as I believe the 3DS can't even use the full speed, but the kind of slowness I'm experiencing seems ridiculous.

    I'd like to add that after installing, the whole 3DS becomes slow to the point of being completely useless. Restarting it returns everything to normal until I try installing a CIA again.

    Finally, the SD card was previously used as storage in a laptop I have, before I repurposed it for the 3DS. Don't know if it makes any difference, as I prepared it with emuNAND9.

    Thanks in advance, any help is definitely appreciated.
     


  2. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,704
    632
    Sep 4, 2014
    Italy
    Then buy original cartridges. Seriously, it's normal, the 3ds can't handle high speeds with SD.
     
  3. Joom

    Joom  ❤❤❤

    Member
    4,035
    2,735
    Jan 8, 2016
    United States
    Yeah, you'll need to format it properly since you used it for a laptop. Get the GParted Live distribution, create a new partition table for it, and format it to FAT32.
     
  4. Real.96

    Real.96 GBAtemp Advanced Fan

    Member
    977
    256
    Sep 14, 2015
    Italy
    Try with Bigbluemenu. I intalled a 1.9 GB in 10 minutes. If also Bigbluemenu take long time to install, i think is only SD fault
     
  5. Tomato Hentai

    Tomato Hentai baja boner blast

    Member
    3,751
    6,113
    Oct 30, 2014
    Canada
    actually north korea. please send help
    FBI was taking a hella long time for things to install for my little sister too. Use BBM or DevMenu instead. Switching to DevMenu helped a lot.
     
  6. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    1,646
    1,187
    Nov 19, 2015
    United States
    It's very fast for me. But I rarely do it since I only install my personal CIA dumps.
     
  7. Edgarska

    Edgarska GBAtemp Fan

    Member
    377
    99
    Oct 24, 2011
    United States
    As long as the card is fat32 it should work even if you used it on a laptop previously, though I'm not sure if it needs to use 32k cluster or some other.
    As for fbi, personally I was having trouble installing cias with it, and use nasa now instead, so maybe try that.
     
  8. Bu2d85

    Bu2d85 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    Bu2d85 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    908
    237
    Nov 6, 2014
    United States
    It's not normal, you're an ass.

    Also I've been drinking. Sorry.
     
    saikorican likes this.
  9. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,704
    632
    Sep 4, 2014
    Italy
    At least it's normal for me...
     
  10. toshineon
    OP

    toshineon Member

    Newcomer
    13
    4
    Nov 1, 2012
    SD card is formatted to FAT32, so it should be fine. Couldn't get devmenu or bigbluemenu to run (3DS reported an error and then restarted), but I did get NASA to run just fine. Currently installing the same CIA I was struggling with before, so we'll see how this goes.
     
  11. Tomato Hentai

    Tomato Hentai baja boner blast

    Member
    3,751
    6,113
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Did you install DevMenu to the NAND?
     
  12. fr3quency

    fr3quency GBAtemp Advanced Fan

    Member
    793
    346
    Jan 11, 2016
    Greece
    Wherever my imagination decides.
    What? It's no way normal. I installed bravely second(3-3,5GB?) on my 64GB microSD class 10 in 45 minutes, so it's NOT normal to take lots of time for an installation. Don't listen to him.
     
    Last edited by fr3quency, Mar 15, 2016
    RedBlueGreen and Tomato Hentai like this.
  13. toshineon
    OP

    toshineon Member

    Newcomer
    13
    4
    Nov 1, 2012
    On the sysNAND?
     
  14. Tomato Hentai

    Tomato Hentai baja boner blast

    Member
    3,751
    6,113
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Yeah.
     
  15. toshineon
    OP

    toshineon Member

    Newcomer
    13
    4
    Nov 1, 2012
    I have not. Should I try it? I thought installing to sysNAND was dangerous.
     
    Tomato Hentai likes this.
  16. Tomato Hentai

    Tomato Hentai baja boner blast

    Member
    3,751
    6,113
    Oct 30, 2014
    Canada
    actually north korea. please send help
    Oh wait, actually I read that wrong. In FBI in emuNAND, can you set the destination to NAND? That's what I meant. The Dev software is supposed to run from NAND instead of your SD card.
     
  17. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,072
    3,385
    Nov 13, 2014
    United States
    Where did you buy that 128gb card?
     
  18. toshineon
    OP

    toshineon Member

    Newcomer
    13
    4
    Nov 1, 2012
    In a general electronics store in Stockholm called "Kjell & Company".
     
  19. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,072
    3,385
    Nov 13, 2014
    United States
    It could be fake thats why your getting erros when trying to open things and before anyone says anything yes even shops sell fake cards. I would run that card through h2testw (write+verify) after formatting it with sdformatter4 with format type full erase and format size adjustment on.
     
    Last edited by Xenon Hacks, Mar 15, 2016
  20. toshineon
    OP

    toshineon Member

    Newcomer
    13
    4
    Nov 1, 2012
    Oh, I see. I installed DevMenu to NAND in FBI, but it doesn't show up on the menu, even though FBI reports the installation as successful. Same with BigBlueMenu, it appears to install fine, but it doesn't show up on the menu.

    — Posts automatically merged - Please don't double post! —

    If all else fails, I'll try your suggestion. I doubt it's fake, though. Fake electronics are very uncommon in Sweden.
     
    Tomato Hentai likes this.