Eshop won't download updates. :(

Discussion in '3DS - Homebrew Development and Emulators' started by RandomKid150, Jan 23, 2016.

  1. RandomKid150
    OP

    RandomKid150 Translator

    Member
    361
    94
    Nov 4, 2015
    United States
    Texas
    I got the E-shop homebrew application from the starter kit, and when I try to download Game Updates, it always gives me an error 007-2920. Is there anyway to fix this?
     
  2. koffieleut

    koffieleut GBAtemp Fan

    Member
    366
    44
    Jan 22, 2009
    Netherlands
    probably at home
    On what fw are you on?
     
  3. RandomKid150
    OP

    RandomKid150 Translator

    Member
    361
    94
    Nov 4, 2015
    United States
    Texas
    10.3.0-28U
     
  4. koffieleut

    koffieleut GBAtemp Fan

    Member
    366
    44
    Jan 22, 2009
    Netherlands
    probably at home
    Ofw or cfw?
     
  5. RandomKid150
    OP

    RandomKid150 Translator

    Member
    361
    94
    Nov 4, 2015
    United States
    Texas
    OFW.
     
  6. Blue_Mew

    Blue_Mew Team Skull ☠️Grunt☠️

    Member
    2,434
    1,028
    Oct 2, 2015
    United Kingdom
    Faraway Island
    I think it's because of the new NVER "-29"
     
  7. RandomKid150
    OP

    RandomKid150 Translator

    Member
    361
    94
    Nov 4, 2015
    United States
    Texas
    ?
     
  8. Blue_Mew

    Blue_Mew Team Skull ☠️Grunt☠️

    Member
    2,434
    1,028
    Oct 2, 2015
    United Kingdom
    Faraway Island
    Because 10.4 is "-29"and the eshop has updated it won't work.
     
  9. RandomKid150
    OP

    RandomKid150 Translator

    Member
    361
    94
    Nov 4, 2015
    United States
    Texas
    Oh. :(
     
  10. Blue_Mew

    Blue_Mew Team Skull ☠️Grunt☠️

    Member
    2,434
    1,028
    Oct 2, 2015
    United Kingdom
    Faraway Island
    @ihaveamac has a solution.
     
  11. koffieleut

    koffieleut GBAtemp Fan

    Member
    366
    44
    Jan 22, 2009
    Netherlands
    probably at home
    Why don't you downgrade your 3ds and update the emunand to 10.4, worked for me on rx tools ;)
     
  12. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,517
    6,110
    Apr 20, 2015
    United States
    Tigard, OR
    only I don't yet...

    even when I installed the -29 NVer and new eShop, it fails to download. I have the feeling it's HANS patching the URLs to old ones
     
  13. Blue_Mew

    Blue_Mew Team Skull ☠️Grunt☠️

    Member
    2,434
    1,028
    Oct 2, 2015
    United Kingdom
    Faraway Island
    :angry:
     
  14. D34DL1N3R

    D34DL1N3R Nephilim

    Member
    1,711
    197
    Dec 6, 2008
    United States
    If you're trying to access the eShop from within your emunand, you have to either install the latest NVER or update your emunand to 10.4. Just use the built in eShop & forget about the homebrew eShop stuff. Make sure your emunand supports 10.4 first. rxTools does on O3DS & Reinand does on N3DS.

    I don't even know why the homebrew/hans eShop stuff is in the starter package.
     
    Last edited by D34DL1N3R, Jan 23, 2016
  15. ihaveamac

    ihaveamac GBAtemp Guru

    Member
    5,517
    6,110
    Apr 20, 2015
    United States
    Tigard, OR
  16. Blue_Mew

    Blue_Mew Team Skull ☠️Grunt☠️

    Member
    2,434
    1,028
    Oct 2, 2015
    United Kingdom
    Faraway Island