Error whiloe trying to install cIOSX

Discussion in 'Wii - Emulation and Homebrew' started by zelazzin, Sep 6, 2014.

  1. zelazzin
    OP

    zelazzin Member

    Newcomer
    44
    0
    Jul 14, 2012
    Hi. When I try to install cIOSX rev20b using the homebrew channel it goes along fine until the installation itself starts. When this happends it says (instead of just keep installing): ERROR! (ret= -1)
    What does this mean? and what am I doing wrong?

    sincerely,
    zelazzin
     
  2. Smuff

    Smuff Fossilized Gamer

    Member
    1,024
    176
    Jul 29, 2006
    By the sea
    A quick googly turned this up - Might help



    -1:
    SD/USB Loader Error: Hardware not recognized. Most likely have a cIOS installed incorrectly, out of date, or missing. Possibly formatted the SD card or USB incorrectly, is unsupported, or not enough space.
    Q. I have formatted the device correctly but I am still getting this error; how would i fix this?
    A. Be sure to have the device hooked up to the Wii before you power it on. You may lack USB support as well. Installing a newer cIOS 249 would clear this up.(cIOS249 [56] d2x-v6)

    -1:
    Wad Install Error:Most likely you have cIOS installed incorrectly, out of date, or missing.Your SD card is not Formatted as FAT16 or FAT32 properly, reformat it. If a file was needed, then it was not in the correct folder.Each application needs its files in specific folders, so pay attention to that. Can also be a bad wad or not enough space on the Wii. (example: If your installing cios38rev17 offline make sure you have ios38-64-v3867 on the root of your sd)
     
  3. zelazzin
    OP

    zelazzin Member

    Newcomer
    44
    0
    Jul 14, 2012
    Hmm.., okay...
    A follow up question (quite noobish) do you really need to install cIOS?
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,677
    8,291
    Oct 27, 2002
    France
    Engine room, learning
    no, you don't need to install cIOS to run homebrew.
    You need one to play games from USB.

    if you don't plan on playing games from USB, then you don't need cIOS.


    rev20b is OLD.
    don't follow random old outdated tutorials.
    Do you need this specific version? why 20b instead of 17 or 21?

    The latest version is rev21 d2x v10 (NOT v6. the link above if also from an old FAQ)

    99% of users are installing cIOS because they hack their console to play games from USB.
    I'll just assume you also want to play games from USB, then you need to install cIOS.

    1. don't install an old version. (I understand that you think the guide you found was the way to do things, but look at the date of the guide)
    2. read a lot, be sure that what you are doing is the updated and correct way to do it.
    3. ask if you need help before acting.
     
  5. zelazzin
    OP

    zelazzin Member

    Newcomer
    44
    0
    Jul 14, 2012
    Okay. Well the thing is that I am trying to mod this Wii for my friends so that you can play games from USB or burnt games (it does not matter which) and well, this is what I stumbled upon, but I´ll look for a newer one right now and see if I can find it. Thank you.

    Okay so I think that I have gotten it to work now but I just tought of another thing that I would like to do to my own Wii; remove the region lock. Does anyone know how to do that?
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,677
    8,291
    Oct 27, 2002
    France
    Engine room, learning
    Playing from USB, and playing from disc are two different things.
    Playing from Disc is more invasive and requires that you change almost all your system files. I wouldn't personally recommend this, it can be a cause of many problems. don't use DarkCorp/cIOSCorp/PimpMyWii. He will only have issues in the future.


    Playing from USB is so much easier, faster and convenient (all games listed on screen, no need to burn discs and go to the console to switch them, many many options like region free, video mode, language selection, cheat codes, automatic anti-piracy patches, etc.).
    But, I guess it's personal preferences.

    For USB loading, you only need to add 2 (or 3) patched system files (cIOS). It doesn't touch existing ones.
    d2x cIOS v8 or v10 is recommended.
    slot249, 250 and 251, using respectively base 56, 57 and 58.



    For the region free, it depends what you want to do and launch.
    Wii game image or channels from USBLoaders: nothing special required when launched from a loader. like I said, it's so much more convenient to use a loader and USB than the game disc. it has automatic region free.
    Wii games Disc or channels from system menu: you need to patch your system menu. It's done temporarilly by a Disc loader (like GeckoOS, or wiiLauncher), or always at launch by Priiloader (keep reset pressed when you boot to see if you have priiloader installed, go to the settings and enable region free all).
    For the channels, you from system menu, you will also require to patch your IOS used by the system menu. it can be dangerous if something goes wrong. Always make a NAND backup before editing your system files.