ePSXe 2.0.5 crashes after loading a game.

Discussion in 'Computer Programming, Emulation, and Game Modding' started by LingFox, Jan 7, 2018.

  1. LingFox
    OP

    LingFox Newbie

    Newcomer
    4
    3
    May 7, 2017
    Italy
    Hello.
    I'm having some troubles with ePSXe lately. Whenever I load a playable stage, the emulator crashes shortly after. For example, whenever I go to the arcade of Gran Turismo 1, I can stay in the menus as long as I want to, but after I choose a race, it'll crashes few seconds after loading it.
    This is happening since 2 days ago, after installing visual studio (i'm trying to study c# and get over with already). I'm also using the 8Bitdo SFC30 Pro controller (if it can somehow help), and it's really giving me shit these days. It won't connect,and when it does it'll freeze.... hooray. (And so I'm forced to use it with the cable. I think that it's probably the bluetooth dongle's fault. I'll try to change it asap).

    The ePSXe's configurations are mainly defaults, except for the video plugin that is the "ePSXe GPU core 2.0.0" Because it's the one that glitch the less in games, like in ace combat 3 it won't gives me those textures errors in the "enter dision" mission. - but the emu crashes with all the other video plugins. Also the "CPU Overclocking" is already at x1, CPU Mode is at Dynarec (fast), too. I also don't have any gte hacks enabled.
    video settings

    Also, visual studio tells me that the error is
    Code:
    Unhandled exception at 0x0117B11D in ePSXe.exe: 0xC0000005: Access violation reading location 0x00000038.
    this is a video of the crash happening

    EDIT: Problem partially solved:
    I changed controller (from that 8bitdo sfc30 pro blah blah to a ps3 in direct input). Why would a controller crash a program? (it was in xinput, anyway.) And why isn't the controller working anymore? i can't even pair it now.
     
    Last edited by LingFox, Jan 7, 2018