EmuNand + Pokemon save file

Discussion in '3DS - Flashcards & Custom Firmwares' started by darcangel, Dec 18, 2013.

  1. darcangel
    OP

    darcangel Lovely Troll

    Member
    236
    50
    Sep 12, 2009
    Brazil
    I have a 3DS XL with emunand 7.0 and w/GateWay,
    Botting on calssic mode I can play and save my retail copy of pokemon w/ no problem at all, but when I started I had to delete de save so The emunand could star a new one.

    So my question: when the gateway be able to emulate nada sav I will have to reset my pokemon save again? because I wont need emunand, and/or will have a diffente nand, so the game will say its a corrupted save and ask to delet and restart?

    Will I be able to port my save from retail? or even keep playing the game form the retail card after the new gateway 2.0 final?
     
  2. Huntereb

    Huntereb GBAtemp Addict

    Member
    2,748
    948
    Sep 1, 2013
    United States

    I can answer this question: No, at least not until a Save dumper comes out supporting Nand dumping.
     
  3. darcangel
    OP

    darcangel Lovely Troll

    Member
    236
    50
    Sep 12, 2009
    Brazil
    BU will I be abel to keep playing the Retail card on classic mode even with a different nand or emunand?
     
  4. darcangel
    OP

    darcangel Lovely Troll

    Member
    236
    50
    Sep 12, 2009
    Brazil
    But will I be able to keep playing the Retail card on classic mode even with a different nand or emunand?
     
  5. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,931
    Sep 8, 2009
    One's inner self
    Classic mode doesn't patch the saves on a game, they save normally
     
  6. darcangel
    OP

    darcangel Lovely Troll

    Member
    236
    50
    Sep 12, 2009
    Brazil
    So why it said the file was corrupted and I had to delete the saved file on the cartige and start a new one(pokemon Y)?
     
  7. n1ghty

    n1ghty GBAtemp Regular

    Member
    273
    345
    Aug 8, 2013
    Saint Kitts and Nevis
    Games compiled with the SDK6+ have a new method to encrypt the saves. The Gateway does not know this method => uses old encryption and the save file on the card looks corrupt.

    Read this in the wiki: 7.8 Is a save from EmuNAND compatible with SysNAND?
     
  8. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,931
    Sep 8, 2009
    One's inner self
    File is corrupted because the KeyY (save key) is done on boot of the console
    because it uses 4.5.0 as a base, it uses the 4.5.0 KeyY
    even when you then softboot into 6.3.0 or 7.0.0 the KeyY still is 4.5.0's key

    all EmuNAND's use the 4.5.0 KeyY but official consoles obviously use the correct 6.0.0 KeyY
    so if you switch between using the cart on one to the other they think the key is wrong and believe its corrupted
     
  9. DragonSky

    DragonSky GBAtemp Advanced Fan

    Member
    740
    71
    Oct 27, 2010
    Belgium
    Hm interesting I'm wondering this also for my retail.
    Can I use my old save data or need it to be deleted?
     
  10. inuyasha555

    inuyasha555 GBAtemp Regular

    Member
    251
    52
    Oct 10, 2013
    Canada
    If your save data came from an updated system of at least 6.1 (the update included with pokemon) then it'll show up as corrupt in emuNAND and you'll need to delete it.
     
  11. redkeyboard

    redkeyboard GBAtemp Advanced Fan

    Member
    627
    154
    Jan 8, 2013
    United States
    Curious question, if you boot a cart like pokemon originally played in emunand onto a updated normal 3ds, will the save load? What if you continue playing on the updated 3ds and it saves over?
     
  12. Saturosias

    Saturosias Sakura-sō Resident

    Member
    594
    290
    Dec 27, 2010
    United States
    Neither works, you can't load an EmuNAND saved Pokémon save on a 6.1+ SysNAND and you can't do the reverse either. Gateway would need to update for new keyY encryption, which they've stated they're "working on".
     
  13. redkeyboard

    redkeyboard GBAtemp Advanced Fan

    Member
    627
    154
    Jan 8, 2013
    United States
    So would that mean if you're playing Pokemon X/Y now it most likely won't work with the newest version of Gateway's software?
     
  14. Saturosias

    Saturosias Sakura-sō Resident

    Member
    594
    290
    Dec 27, 2010
    United States
    It depends on whether or not they're even able to do it and, if so, if it'll be optional to use either 4.5 or 6.1 KeyY.
     
  15. DragonSky

    DragonSky GBAtemp Advanced Fan

    Member
    740
    71
    Oct 27, 2010
    Belgium
    Yes it comes from over 6.1. Or else I wouldn't ask this question.
     
  16. profi200

    profi200 Banned

    Banned
    330
    216
    Sep 3, 2011
    Gambia, The
    The key never leaves the hardware. They can promise, what they want. The only way for them to do it is to bruteforce the encryption, which takes to long to be useful.