RELEASE emuiibo - MitM'ing NFP services for Amiibo emulation

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by XorTroll, Apr 17, 2019.

  1. XorTroll
    OP

    XorTroll Dev: Goldleaf, emuiibo, Brew.js...

    Member
    12
    Dec 28, 2017
    Spain
    Nowhere
    Good news!

    emuiibo 0.3 has been finally released, no longer requiring dumps!
    Enjoy playing with your custom virtual amiibos!

    https://github.com/XorTroll/emuiibo/releases/tag/0.3

    — Posts automatically merged - Please don't double post! —

    In fact this might be a major update, since no longer needing dumps is one of all the several features it comes with...
     
    Jonhy, 0000ff, lordelan and 7 others like this.
  2. Drake1427

    Drake1427 Member

    Newcomer
    5
    Sep 8, 2017
    Mexico
    Such a shame that Diablo 3 and Fire Emblem still don't seem to work (either that or I'm doing something terribly wrong, which is very likely >.>).
    Pretty cool update nonetheless. Thanks a lot for all your work, @XorTroll
     
    lordelan and SAKyle like this.
  3. DarknessPlay3r

    DarknessPlay3r Member

    Newcomer
    3
    Jan 27, 2019
    Canada
    Just out of curiosity, did you enable this via amiiSwap or the button combo then load the game? I know for a fact 0.2 would only work in BOTW if it was enabled before loading the game.

    This might be related as in BOTW if I disable this either via amiiSwap or the button combo it doesn't actually disable even though amiiSwap says disabled. However if it is disabled and BOTW is quit and reloaded it is then disabled and unable to be re-enabled. Other games I've used it in like Mario Kart 8, Mario Odyssey all work as expected.

    Two things, do you have it enabled before starting BOTW, and what happens when you disable and use a real amiibo or a powertag (or the like)?
     
    Last edited by DarknessPlay3r, Aug 2, 2019
  4. almmiron

    almmiron GBAtemp Regular

    Member
    4
    Jan 9, 2012
    Brazil
    Anyone understand how this part works?

    "Amiibos can be placed inside /emuiibo/amiibo// to be only used in that specific game. Amiibos outside those directories will be used on any game."

    [​IMG]

    I want make some amiibos only work in zelda, some only work in mario odyssey, and goes on.. This 8-bit link was generated by emuGUIibo, but how make it work only with botw?


    I used to amiiswap them, but now seems to be a good way to swap among specific amiibos when a specific game is runnig.
     
  5. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    My guess would be to create this folder and throw 'em in:
    sd:\emuiibo\amiibo\botw\
     
  6. XorTroll
    OP

    XorTroll Dev: Goldleaf, emuiibo, Brew.js...

    Member
    12
    Dec 28, 2017
    Spain
    Nowhere
    The game's title ID.
     
    Zukov, almmiron and lordelan like this.
  7. Drake1427

    Drake1427 Member

    Newcomer
    5
    Sep 8, 2017
    Mexico
    Believe me,I've tried that and every other way I could think of. The amiibo portal in diablo just desummons if I enable emulation before loading the game, and IIRC it just does nothing if you enable it after the game is loaded. I've also looked everywhere online and others seem to have the same problem but couldn't find a solution:(

    As for Fire Emblem, according to XorTroll it's a known issue and he's looking into it (he said so a few days ago on his discord). I just got excited thinking that maybe this update fixed that.
     
    Last edited by Drake1427, Aug 2, 2019
  8. almmiron

    almmiron GBAtemp Regular

    Member
    4
    Jan 9, 2012
    Brazil
  9. cucholix

    cucholix Banners guy

    Member
    9
    Jan 17, 2017
    Chile
    Diablo riches portal works for me, make sure you enable emuiibo before starting the game.
     
  10. Drake1427

    Drake1427 Member

    Newcomer
    5
    Sep 8, 2017
    Mexico
    I had done that before and it didn't work (just like I said in my post). Just tried it again multiple times and got the same result, portal desummoned every time.

    BUT (and this is important) somehow the idea of depositing and retiring the portal item from my stash came to me. No rhyme or reason, just a random thought. Guess what? It works now; whatever the problem was, doing that seems to have fixed it.
     
    cucholix likes this.
  11. SAKyle

    SAKyle Newbie

    Newcomer
    2
    Jan 5, 2018
    United States
    im still having the same issue, are you saying you just put it in your stash and pulled it back out?
     
  12. Drake1427

    Drake1427 Member

    Newcomer
    5
    Sep 8, 2017
    Mexico
    Here's a detailed step by step of everything I did.

    Activate Emuiibo 0.3 in the home screen, with no games open and only the Loot Goblin Amiibo in my SD card.
    Started Diablo 3 and continued my game
    Used the Amiibo portal item (which was already in my inventory) several times, walking a few steps in a random direction in case the problem was an invalid location; The portal unsummoned every time.
    Without closing or restarting the game or disabling emuiibo, went to my stash and deposited the Amiibo portal.
    Immediately took the item out of the stash, into my inventory.
    Used the Amiibo portal and to my surprise, it worked.

    Let me know if it helps, I really hope this works for you.
     
    Last edited by Drake1427, Aug 3, 2019
  13. slowmotioning

    slowmotioning GBAtemp Regular

    Member
    4
    Nov 1, 2014
    United States
    Emuiibo worked in Fire Emblem for me, but it wasn't instant. I had to wait around 5 minutes for the Amiibo to actually be recognized.
     
  14. SAKyle

    SAKyle Newbie

    Newcomer
    2
    Jan 5, 2018
    United States
    Just got around to trying it out, I've tried your method several times still no luck. Thanks for trying to help.
     
  15. Drake1427

    Drake1427 Member

    Newcomer
    5
    Sep 8, 2017
    Mexico
    Sorry about that, I was so excited to finally get it working that I didn't do any further testing.
    Today I took my switch off of sleep mode and tried the amiibo portal again and got the desummoned problem again.
    Tried depositing and withdrawing the item, didn't work.
    However, if I walked into the house closest to the stash and tried in there it gave me a different message about every 5 tries (the message was that I had to wait 3 hours to use it again), same when I got out of the house. I assume that means that it would've worked, was it not for the cooldown. Maybe changing areas and walking around did something? Maybe it's just random? I don't know what to think anymore >.>
    This time I'm doing some more testing in other areas, but I haven't had any luck getting it to work out of town.

    I hope you can get it working and maybe eventually we find out what the problem is. Knowing that I'm not the only one having this problem does make me feel better. Does that make me a bad person? >.>
     
  16. SapphireExile

    SapphireExile Advanced Member

    Newcomer
    3
    May 2, 2018
    United States
    Plant City, FL
    Confirming this. Time seemed completely random from instant to ~5 minutes.
    Steps (Without swap):
    1.Boot CFW
    2. R3 + Up
    3. Start FETH, and go to the Amiibo Gazeebo
    4. Wait

    Didn't seem to work at all if Emuiibo was activated inside the game, only when in the home menu with no game running.
     
  17. ultimatepump

    ultimatepump GBAtemp Regular

    Member
    5
    Feb 9, 2004
    This is awesome! Of course right after I buy the N2Elite.

    Any chance of this ever getting an Android port?
     
  18. GrumpCatPie

    GrumpCatPie Member

    Newcomer
    1
    Feb 24, 2019
    United States
    Hey I am not able to switch amiibos I have 3 virtural ones and when I hit ALL it says its empty. Did I do something wrong?

    Edit: This is for AmiiSwap
     
    Last edited by GrumpCatPie, Aug 5, 2019
  19. SilentOne1994

    SilentOne1994 SilentOne2k94

    Member
    3
    Feb 5, 2016
    Australia
    Australia
    Any reason why my amiibo bin files don't get recognised on Fire Emblem Three Houses?
    I enabled Emuiibo, restarted the switch, then on Home menu.. pressed R3 + UP
    and then I started Fire Emblem Three Houses
    went to the Amiibo Gazebo and pressed R3 + Left and i receive this error..
    2019081222532700-0DC6ECE91CF3F6F02BAFC002E3FFBAAD. hmm.
    am i doing something wrong?
     
  20. jammybudga777

    jammybudga777 GBAtemp Addict

    Member
    7
    Aug 23, 2013
    I'm using atmosphere and amiiswap. When emuiibo is off it says top right corner the selected amiibo. But if I go through any settings it says cant find amiibo. And if I activate emuiibo then it says its unsure if its active
     
Loading...