E3 flasher to downgrade from 4.75

Discussion in 'PS3 - Console, Accessories and Hardware' started by devag, Aug 27, 2015.

  1. devag
    OP

    devag Member

    Newcomer
    1
    Jul 8, 2015
    Last edited by devag, Aug 27, 2015
  2. master801

    master801 GBAtemp Fan

    Member
    3
    Feb 24, 2011
    United States
    The E3 Flasher allows you to downgrade from any OFW, of course if your PS3 is compatible with the flasher (meaning it has a NOR chip in it), and it can also downgrade to at least 3.55 (the firmware required for CFW).

    Use this list to figure out if your PS3 is compatible or not.

    Here's a guide I used when I flashed my PS3. And here's another guide that I used to unbrick my PS3, when I bricked it by incorrectly flashing it (the clip was not making good contact with the chip).
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice