DSi XL - firmware 1.5

Discussion in 'NDS - Flashcarts and Accessories' started by JUGG3R, Jul 21, 2010.

Jul 21, 2010

DSi XL - firmware 1.5 by JUGG3R at 4:29 AM (5,197 Views / 0 Likes) 11 replies

  1. JUGG3R
    OP

    Newcomer JUGG3R Newbie

    Joined:
    Dec 18, 2009
    Messages:
    6
    Country:
    Brazil
    I'm researching a lot about DSi XL, and i know that flashcards don't work with firmware 1.5. I'm taking a Acekard2i to use with it.
    My question is, there's already DSi XL with firmware 1.5 on stores?
    Theres a way to know that trough the serial number? Can someone explain how to read the serial number? Can't find on google.

    Thanks in advance
     
  2. Crimsonclaw111

    Member Crimsonclaw111 GBAtemp Fan

    Joined:
    Apr 7, 2010
    Messages:
    387
    Country:
    United States
    Latest DSi firmware is 1.4. There is no "1.5".
     
  3. JUGG3R
    OP

    Newcomer JUGG3R Newbie

    Joined:
    Dec 18, 2009
    Messages:
    6
    Country:
    Brazil
    ooh, ok. Sorry for the noobish :\
    I don't know where I got this information.
    So basically I don't have to worry with the current firmware when I buy one? Acekard 2i is compatible with 1.4 from what I've heard. Is that correct?
     
  4. Crimsonclaw111

    Member Crimsonclaw111 GBAtemp Fan

    Joined:
    Apr 7, 2010
    Messages:
    387
    Country:
    United States
    No need to apologize...
    And yes, the Acekard is compatible with firmware 1.4 if you flash the cart.
     
  5. Skyline969

    Member Skyline969 MENUdo Afficionado

    Joined:
    Nov 18, 2008
    Messages:
    2,206
    Location:
    Saskatchewan
    Country:
    Canada
    That's correct - the AK2i works with firmware 1.4. To confirm this, my DSi is on 1.4 and I have an AK2i. You might need to flash your AK2i to get it to work, but that's really easy to do. You just need a DS Lite/Phat or DSi with 1.3 or less.
     
  6. JUGG3R
    OP

    Newcomer JUGG3R Newbie

    Joined:
    Dec 18, 2009
    Messages:
    6
    Country:
    Brazil
    Thanks for all your support [​IMG]
    I'm gonna use AKAIO as well, read good things about it. Is it that better than the original acekard firmware? What's the biggest differences?
     
  7. Bulit

    Member Bulit GBAtemp Regular

    Joined:
    Sep 15, 2009
    Messages:
    293
    Location:
    San Jose, CA
    Country:
    United States
    1.Yes
    2.Game compatibility (along with several other things)
     
  8. JUGG3R
    OP

    Newcomer JUGG3R Newbie

    Joined:
    Dec 18, 2009
    Messages:
    6
    Country:
    Brazil
    Mentioning compatibility, is Nintendo adding protection to the new games?
    Is it rare a new release don't work because of protection?
    Any current game releases are flashcard blocked?
    How much would you say the compatibility is? 99,9%?

    thx again [​IMG]
     
  9. locoperson

    Newcomer locoperson Newbie

    Joined:
    Jul 25, 2010
    Messages:
    2
    Country:
    United States
    I was wondering if anyone has updated past firmware 1.4u - I looked up system update today and saying there is a update, should I update or will this block my flashcard.
     
  10. BobTheJoeBob

    Member BobTheJoeBob The most optimistic person on the temp. :)

    Joined:
    Aug 2, 2009
    Messages:
    1,691
    Location:
    London
    Country:
    United Kingdom
    Check your DSi's current firmware, if it's 1.3 then it's safe to update, if it's 1.4 then you shouldn't be able to update.
     
  11. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
    It's a minor update, doesn't do much. If firmware 1.5 is released, there will be a alot of talk on here and you'll see it on the homepage.

    Of course you could be unluckly and be the first person to update to FW1.5, but that's highly unlikely.
     
  12. locoperson

    Newcomer locoperson Newbie

    Joined:
    Jul 25, 2010
    Messages:
    2
    Country:
    United States
    Thanks for the reply's I did the update and my ds firmware is still 1.4u, you were right it was just a minor update!
     

Share This Page