DSi shop and AK2i

Discussion in 'Acekard' started by sam043060, Dec 14, 2010.

  1. sam043060
    OP

    sam043060 Newbie

    Newcomer
    1
    0
    Dec 14, 2010
    United States
    hey guys. Today, I just bought a DSi xl (1.4u version) and got my ak2i from RHS which is compatible 1.4.1 firmware. I want to purchase the Warioware Snapped from DSi shop, but I've heard that my firmware would be forced to update once I connect to the DSi shop. Is 1.4.2 the newest firmware? Would anyone recommend me to do so? Thanks
     
  2. ShadowSoldier

    ShadowSoldier GBAtemp Guru

    Member
    9,383
    3,300
    Oct 8, 2009
    Canada
    1.4.1U is the latest firmware for DSi's.

    If your Acekard has a logo of Alex Rider Stormbreaker or whatever, then you can update. But if it has Danny Phantom, you need to update your Acekard.
     
  3. Evo.lve

    Evo.lve All that you could be.

    Member
    1,786
    21
    Oct 11, 2010
    Away from you.
    YAAAAAAAAH!

    My spidey senses are tingling!

    According to Ryukouki on DSDatabase, 1.4.2 blocks all flashcarts except for the EX-Flash Vi and maybe the iSmart MM.

    So no, don't update!

    But, thanks to Ryan, I fear I may already be too late.
     
  4. CannonFoddr

    CannonFoddr Regular GBATemp Lurker

    Member
    4,115
    68
    Sep 23, 2006
    Sitting by computer
    1.4.2 ???? - is there such a thing ???

    Oh hang on yes there is BUT it seems it only applies to certain regions....
    So us people in Europe & in the USA seem to be lucky (so far)
     
  5. ShadowSoldier

    ShadowSoldier GBAtemp Guru

    Member
    9,383
    3,300
    Oct 8, 2009
    Canada
    Japans 1.4.2 = North America and the rest of the worlds 1.4.1.